]> andersk Git - zcommit.git/blob - src/zsend-0.0.1/debian/rules
Added source for zsend
[zcommit.git] / src / zsend-0.0.1 / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper. 
3 # GNU copyright 1997 by Joey Hess.
4 #
5 # This version is for a hypothetical package that builds an
6 # architecture-dependant package, as well as an architecture-independent
7 # package.
8
9 # Uncomment this to turn on verbose mode. 
10 #export DH_VERBOSE=1
11
12 # This is the debhelper compatability version to use.
13 export DH_COMPAT=3
14
15 # This has to be exported to make some magic below work.
16 export DH_OPTIONS
17 SONAME=3
18
19 configure: configure-stamp
20 configure-stamp:
21         dh_testdir
22
23         # Add here commands to configure the package.
24         -mkdir build-tree
25         cp *.c build-tree/
26         cp *.h build-tree/
27         cp Makefile build-tree/
28
29 build: configure-stamp build-stamp
30 build-stamp:
31         dh_testdir
32
33         # Add here commands to compile the package.
34         $(MAKE) -C `pwd`/build-tree 
35         touch build-stamp
36
37 clean:
38         dh_testdir
39         dh_testroot
40         -rm -f build-stamp configure-stamp
41
42         # Add here commands to clean up after the build process.
43         -rm -rf build-tree debian/tmp
44
45         dh_clean
46
47 install: DH_OPTIONS=
48 install: build
49         dh_testdir
50         dh_testroot
51         dh_clean -k
52         -rm -rf debian/tmp
53         dh_installdirs
54         mkdir -p debian/tmp/usr/bin/
55
56         # Add here commands to install the package into debian/tmp.
57         cd build-tree&&$(MAKE)  DESTDIR=`pwd`/../debian/tmp install
58
59
60 # Build architecture-independent files here.
61 # Pass -i to all debhelper commands in this target to reduce clutter.
62 binary-indep: build install
63
64
65 # Build architecture-dependent files here.
66 # Pass -a to all debhelper commands in this target to reduce clutter.
67 binary-arch: build install
68         dh_testdir
69         dh_testroot
70         set -e; \
71         dh_movefiles -pzsend
72         dh_movefiles --sourcedir=debian/tmp -pzsend 
73         dh_installdebconf 
74         dh_installdocs
75         dh_installchangelogs 
76         dh_strip
77         dh_compress
78         dh_fixperms
79         dh_makeshlibs
80         dh_shlibdeps
81         dh_installdeb
82         dh_gencontrol
83         dh_md5sums
84         dh_builddeb
85
86 binary: binary-indep binary-arch
87
88 .PHONY: build clean binary-indep binary-arch binary install configure
89
90
This page took 0.289418 seconds and 5 git commands to generate.