]> andersk Git - splint.git/blob - splint.spec
noexpand always false.
[splint.git] / splint.spec
1 %define prefix /usr
2 %define ver    3.0.1.6
3 Summary:   Splint - A tool for statically checking C programs
4 Name:      splint
5 Version:   %ver
6 Release:   1
7 Copyright: MIT
8 Url:       http://www.splint.org
9
10 Packager:  Heiko Abraham, abrahamh@web.de
11 Group:     Development/Languages
12 Source:    %{name}-%{ver}.src.tgz
13
14 BuildRoot: /var/tmp/%{name}-%{PACKAGE_VERSION}-root
15 Requires:  gcc
16
17
18
19
20
21 %description
22 Splint  is a tool for statically checking C programs for security vulnerabilities 
23 and common programming mistakes. With minimal effort, Splint can be used as a 
24 better lint(1).If additional effort is invested adding  annotations  to  programs,  
25 Splint can perform stronger checks than can be done by any standard lint.  For 
26 full documentation, please see http://www.splint.org.  
27
28 Please set environment variables:
29 - LARCH_PATH=%{prefix}/share/splint/lib
30   and
31 - LCLIMPORTDIR=%{prefix}/share/splint/imports
32 .
33
34 %prep
35 %setup -q
36
37 %build
38 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix}
39 make
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 mkdir -p $RPM_BUILD_ROOT%{prefix}/bin
44 mkdir -p $RPM_BUILD_ROOT%{prefix}/share/doc/%{name}-%{PACKAGE_VERSION}
45 mkdir -p $RPM_BUILD_ROOT%{prefix}/share/splint/imports
46 mkdir -p $RPM_BUILD_ROOT%{prefix}/share/splint/lib
47 mkdir -p $RPM_BUILD_ROOT%{prefix}/share/man/man1
48
49 make DESTDIR=$RPM_BUILD_ROOT  install
50
51 # now install docs, why 'make install' will not do this
52 cp README     $RPM_BUILD_ROOT%{prefix}/share/doc/%{name}-%{PACKAGE_VERSION}
53 cp doc/*.html $RPM_BUILD_ROOT%{prefix}/share/doc/%{name}-%{PACKAGE_VERSION}
54 cp doc/*.pdf  $RPM_BUILD_ROOT%{prefix}/share/doc/%{name}-%{PACKAGE_VERSION}
55
56
57
58 %post
59
60 %preun
61
62
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT/*
66 rm -rf $RPM_BUILD_DIR/%{name}-%{PACKAGE_VERSION}/*
67
68
69
70
71 %files
72 %{prefix}/bin/splint
73 %{prefix}/share/splint/imports/*
74 %{prefix}/share/splint/lib/*
75 %{prefix}/share/doc/%{name}-%{PACKAGE_VERSION}/*
76
77
78
79
80
81
This page took 0.057728 seconds and 5 git commands to generate.