]> andersk Git - openssh.git/blob - packages/redhat/openssh.spec
Doh! RPM doesn't support conditional building
[openssh.git] / packages / redhat / openssh.spec
1 # Version of OpenSSH
2 %define oversion 1.2.1pre21
3
4 # Version of ssh-askpass
5 %define aversion 0.99
6
7 Summary: OpenSSH free Secure Shell (SSH) implementation
8 Name: openssh
9 Version: %{oversion}
10 Release: 1
11 Packager: Damien Miller <djm@ibs.com.au>
12 Source0: http://violet.ibs.com.au/openssh/files/openssh-%{oversion}.tar.gz
13 Source1: http://www.pobox.com/~jmknoble/jmk/x11-ssh-askpass-%{aversion}.tar.gz
14 Copyright: BSD
15 Group: Applications/Internet
16 BuildRoot: /tmp/openssh-%{version}-buildroot
17 Obsoletes: ssh
18 Requires: openssl
19 PreReq: openssl
20 BuildPreReq: openssl-devel
21 BuildPreReq: tcp_wrappers
22 BuildPreReq: gnome-libs-devel
23
24 %package clients
25 Summary: OpenSSH Secure Shell protocol clients
26 Requires: openssh
27 Group: System Environment/Daemons
28 Obsoletes: ssh-clients
29
30 %package server
31 Summary: OpenSSH Secure Shell protocol server (sshd)
32 Requires: openssh chkconfig >= 0.9
33 Group: System Environment/Daemons
34 Obsoletes: ssh-server
35
36 %package askpass
37 Summary: OpenSSH X11 passphrase dialog
38 Group: Applications/Internet
39 Requires: openssh
40 Obsoletes: ssh-extras
41
42 %package askpass-gnome
43 Summary: OpenSSH GNOME passphrase dialog
44 Group: Applications/Internet
45 Requires: openssh
46 Obsoletes: ssh-extras
47
48 %description
49 Ssh (Secure Shell) a program for logging into a remote machine and for
50 executing commands in a remote machine.  It is intended to replace
51 rlogin and rsh, and provide secure encrypted communications between
52 two untrusted hosts over an insecure network.  X11 connections and
53 arbitrary TCP/IP ports can also be forwarded over the secure channel.
54
55 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
56 up to date in terms of security and features, as well as removing all 
57 patented algorithms to seperate libraries (OpenSSL).
58
59 This package includes the core files necessary for both the OpenSSH
60 client and server.  To make this package useful, you should also
61 install openssh-clients, openssh-server, or both.
62
63 %description clients
64 Ssh (Secure Shell) a program for logging into a remote machine and for
65 executing commands in a remote machine.  It is intended to replace
66 rlogin and rsh, and provide secure encrypted communications between
67 two untrusted hosts over an insecure network.  X11 connections and
68 arbitrary TCP/IP ports can also be forwarded over the secure channel.
69
70 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
71 up to date in terms of security and features, as well as removing all 
72 patented algorithms to seperate libraries (OpenSSL).
73
74 This package includes the clients necessary to make encrypted connections
75 to SSH servers.
76
77 %description server
78 Ssh (Secure Shell) a program for logging into a remote machine and for
79 executing commands in a remote machine.  It is intended to replace
80 rlogin and rsh, and provide secure encrypted communications between
81 two untrusted hosts over an insecure network.  X11 connections and
82 arbitrary TCP/IP ports can also be forwarded over the secure channel.
83
84 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
85 up to date in terms of security and features, as well as removing all 
86 patented algorithms to seperate libraries (OpenSSL).
87
88 This package contains the secure shell daemon. The sshd is the server 
89 part of the secure shell protocol and allows ssh clients to connect to 
90 your host.
91
92 %package askpass-gnome
93 %description askpass
94 Ssh (Secure Shell) a program for logging into a remote machine and for
95 executing commands in a remote machine.  It is intended to replace
96 rlogin and rsh, and provide secure encrypted communications between
97 two untrusted hosts over an insecure network.  X11 connections and
98 arbitrary TCP/IP ports can also be forwarded over the secure channel.
99
100 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
101 up to date in terms of security and features, as well as removing all 
102 patented algorithms to seperate libraries (OpenSSL).
103
104 This package contains Jim Knoble's <jmknoble@pobox.com> X11 passphrase 
105 dialog.
106
107 %package askpass-gnome
108 %description askpass
109 Ssh (Secure Shell) a program for logging into a remote machine and for
110 executing commands in a remote machine.  It is intended to replace
111 rlogin and rsh, and provide secure encrypted communications between
112 two untrusted hosts over an insecure network.  X11 connections and
113 arbitrary TCP/IP ports can also be forwarded over the secure channel.
114
115 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
116 up to date in terms of security and features, as well as removing all 
117 patented algorithms to seperate libraries (OpenSSL).
118
119 This package contains the GNOME passphrase dialog.
120
121 %changelog
122 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
123 - Added Jim Knoble's <jmknoble@pobox.com> askpass
124 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
125 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
126 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
127 - Added 'Obsoletes' directives
128 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
129 - Use make install
130 - Subpackages
131 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
132 - Added links for slogin
133 - Fixed perms on manpages
134 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
135 - Renamed init script
136 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
137 - Back to old binary names
138 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
139 - Use autoconf
140 - New binary names
141 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
142 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
143
144 %prep
145
146 %setup -a 1
147
148 %build
149
150 CFLAGS="$RPM_OPT_FLAGS" \
151         ./configure --prefix=/usr --sysconfdir=/etc/ssh \
152                     --with-gnome-askpass --with-tcp-wrappers
153
154 make
155
156 cd x11-ssh-askpass-%{aversion}
157 xmkmf -a
158 make
159 cd ..
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 make install prefix="$RPM_BUILD_ROOT/usr"
164
165 install -d $RPM_BUILD_ROOT/etc/ssh
166 install -d $RPM_BUILD_ROOT/etc/pam.d/
167 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
168 install -m644 packages/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
169 install -m755 packages/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
170 install -m600 ssh_config $RPM_BUILD_ROOT/etc/ssh/ssh_config
171 install -m600 sshd_config $RPM_BUILD_ROOT/etc/ssh/sshd_config
172
173 install -s x11-ssh-askpass-%{aversion}/ssh-askpass $RPM_BUILD_ROOT/usr/libexec/ssh/x11-ssh-askpass
174 ln -s /usr/libexec/ssh/x11-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/ssh/ssh-askpass
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post server
180 /sbin/chkconfig --add sshd
181 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
182         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
183 fi
184 if test -r /var/run/sshd.pid
185 then
186         /etc/rc.d/init.d/sshd restart >&2
187 fi
188
189 %preun server
190 if [ "$1" = 0 ]
191 then
192         /etc/rc.d/init.d/sshd stop >&2
193         /sbin/chkconfig --del sshd
194 fi
195
196 %files
197 %defattr(-,root,root)
198 %doc ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen INSTALL UPGRADING
199 %attr(0755,root,root) /usr/bin/ssh-keygen
200 %attr(0755,root,root) /usr/bin/scp
201 %attr(0644,root,root) /usr/man/man1/ssh-keygen.1
202 %attr(0644,root,root) /usr/man/man1/scp.1
203 %attr(0755,root,root) %dir /etc/ssh
204
205 %files clients
206 %defattr(-,root,root)
207 %attr(4755,root,root) /usr/bin/ssh
208 %attr(0755,root,root) /usr/bin/ssh-agent
209 %attr(0755,root,root) /usr/bin/ssh-add
210 %attr(0644,root,root) /usr/man/man1/ssh.1
211 %attr(0644,root,root) /usr/man/man1/ssh-agent.1
212 %attr(0644,root,root) /usr/man/man1/ssh-add.1
213 %attr(0644,root,root) %config(noreplace) /etc/ssh/ssh_config
214 %attr(-,root,root) /usr/bin/slogin
215 %attr(-,root,root) /usr/man/man1/slogin.1
216 %attr(0755,root,root) %dir /usr/libexec/ssh
217
218 %files server
219 %defattr(-,root,root)
220 %attr(0755,root,root) /usr/sbin/sshd
221 %attr(0644,root,root) /usr/man/man8/sshd.8
222 %attr(0600,root,root) %config(noreplace) /etc/ssh/sshd_config
223 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
224 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
225
226 %files askpass
227 %defattr(-,root,root)
228 %attr(0755,root,root) /usr/libexec/ssh/ssh-askpass
229 %attr(0755,root,root) /usr/libexec/ssh/x11-ssh-askpass
230
231 %files askpass-gnome
232 %defattr(-,root,root)
233 %attr(0755,root,root) /usr/libexec/ssh/gnome-ssh-askpass
This page took 0.060159 seconds and 5 git commands to generate.