]> andersk Git - openssh.git/blob - openssh.spec
Renamed open* -> * at request of Theo de Raadt <deraadt@cvs.openbsd.org>
[openssh.git] / openssh.spec
1 Summary: OpenSSH free Secure Shell (SSH) implementation
2 Name: openssh
3 Version: 1.2pre5
4 Release: 1
5 Packager: Damien Miller <djm@ibs.com.au>
6 Source0: openssh-%{version}-linux.tar.gz
7 Copyright: BSD
8 Group: Applications/Internet
9 BuildRoot: /tmp/openssh-%{version}-buildroot
10
11 %description
12 Ssh (Secure Shell) a program for logging into a remote machine and for
13 executing commands in a remote machine.  It is intended to replace
14 rlogin and rsh, and provide secure encrypted communications between
15 two untrusted hosts over an insecure network.  X11 connections and
16 arbitrary TCP/IP ports can also be forwarded over the secure channel.
17
18 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
19 up to date in terms of security and features, as well as removing all 
20 patented algorithms to seperate libraries (OpenSSL).
21
22 %changelog
23 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
24 - Use autoconf
25 - New binary names
26 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
27 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
28
29 %prep
30
31 %setup -n openssh
32
33 %build
34
35 ./configure --prefix=/usr --sysconfdir=/etc/ssh
36 make OPT_FLAGS="$RPM_OPT_FLAGS"
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 mkdir -p $RPM_BUILD_ROOT/usr/bin 
41 mkdir -p $RPM_BUILD_ROOT/usr/sbin 
42 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
43 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
44 mkdir -p $RPM_BUILD_ROOT/etc/ssh
45 mkdir -p $RPM_BUILD_ROOT/usr/man/man1
46 mkdir -p $RPM_BUILD_ROOT/usr/man/man8
47
48 install -m644 sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
49 install -m755 sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
50 install -m600 ssh_config $RPM_BUILD_ROOT/etc/ssh/ssh_config
51 install -m600 sshd_config $RPM_BUILD_ROOT/etc/ssh/sshd_config
52
53 install -s -m755 bin/sshd $RPM_BUILD_ROOT/usr/sbin
54 install -s -m755 bin/ssh $RPM_BUILD_ROOT/usr/bin
55 install -s -m755 bin/scp $RPM_BUILD_ROOT/usr/bin
56 install -s -m755 bin/ssh-agent $RPM_BUILD_ROOT/usr/bin
57 install -s -m755 bin/ssh-add $RPM_BUILD_ROOT/usr/bin
58 install -s -m755 bin/ssh-keygen $RPM_BUILD_ROOT/usr/bin
59
60 install -m644 sshd.8 $RPM_BUILD_ROOT/usr/man/man8
61 install -m644 ssh.1 $RPM_BUILD_ROOT/usr/man/man1
62 install -m644 scp.1 $RPM_BUILD_ROOT/usr/man/man1
63 install -m644 ssh-agent.1 $RPM_BUILD_ROOT/usr/man/man1
64 install -m644 ssh-add.1 $RPM_BUILD_ROOT/usr/man/man1
65 install -m644 ssh-keygen.1 $RPM_BUILD_ROOT/usr/man/man1
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 /sbin/chkconfig --add sshd
72 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
73         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
74 fi
75 if test -r /var/run/sshd.pid
76 then
77         /etc/rc.d/init.d/sshd restart >&2
78 fi
79
80 %preun
81 if [ "$1" = 0 ]
82 then
83         /etc/rc.d/init.d/sshd stop >&2
84         /sbin/chkconfig --del sshd
85 fi
86
87 %files
88 %defattr(-,root,root)
89 %doc COPYING.Ylonen ChangeLog ChangeLog.Ylonen OVERVIEW 
90 %doc README README.openssh
91 %attr(0755,root,root) /usr/sbin/sshd
92 %attr(0755,root,root) /usr/bin/ssh
93 %attr(0755,root,root) /usr/bin/ssh-agent
94 %attr(0755,root,root) /usr/bin/ssh-keygen
95 %attr(0755,root,root) /usr/bin/ssh-add
96 %attr(0755,root,root) /usr/bin/scp
97
98 %attr(0755,root,root) /usr/man/man8/sshd.8
99 %attr(0755,root,root) /usr/man/man1/ssh.1
100 %attr(0755,root,root) /usr/man/man1/ssh-agent.1
101 %attr(0755,root,root) /usr/man/man1/ssh-keygen.1
102 %attr(0755,root,root) /usr/man/man1/ssh-add.1
103 %attr(0755,root,root) /usr/man/man1/scp.1
104
105 %attr(0600,root,root) %config /etc/ssh/sshd_config
106 %attr(0600,root,root) %config /etc/pam.d/sshd
107 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
108 %attr(0644,root,root) %config /etc/ssh/ssh_config
109
This page took 0.044933 seconds and 5 git commands to generate.