]> andersk Git - openssh.git/blob - contrib/redhat/openssh.spec
- guenther@cvs.openbsd.org 2010/01/15 00:05:22
[openssh.git] / contrib / redhat / openssh.spec
1 %define ver 5.3p1
2 %define rel 1
3
4 # OpenSSH privilege separation requires a user & group ID
5 %define sshd_uid    74
6 %define sshd_gid    74
7
8 # Version of ssh-askpass
9 %define aversion 1.2.4.1
10
11 # Do we want to disable building of x11-askpass? (1=yes 0=no)
12 %define no_x11_askpass 0
13
14 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
15 %define no_gnome_askpass 0
16
17 # Do we want to link against a static libcrypto? (1=yes 0=no)
18 %define static_libcrypto 0
19
20 # Do we want smartcard support (1=yes 0=no)
21 %define scard 0
22
23 # Use GTK2 instead of GNOME in gnome-ssh-askpass
24 %define gtk2 1
25
26 # Is this build for RHL 6.x?
27 %define build6x 0
28
29 # Do we want kerberos5 support (1=yes 0=no)
30 %define kerberos5 1
31
32 # Reserve options to override askpass settings with:
33 # rpm -ba|--rebuild --define 'skip_xxx 1'
34 %{?skip_x11_askpass:%define no_x11_askpass 1}
35 %{?skip_gnome_askpass:%define no_gnome_askpass 1}
36
37 # Add option to build without GTK2 for older platforms with only GTK+.
38 # RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
39 # rpm -ba|--rebuild --define 'no_gtk2 1'
40 %{?no_gtk2:%define gtk2 0}
41
42 # Is this a build for RHL 6.x or earlier?
43 %{?build_6x:%define build6x 1}
44
45 # If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
46 %if %{build6x}
47 %define _sysconfdir /etc
48 %endif
49
50 # Options for static OpenSSL link:
51 # rpm -ba|--rebuild --define "static_openssl 1"
52 %{?static_openssl:%define static_libcrypto 1}
53
54 # Options for Smartcard support: (needs libsectok and openssl-engine)
55 # rpm -ba|--rebuild --define "smartcard 1"
56 %{?smartcard:%define scard 1}
57
58 # Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
59 %define rescue 0
60 %{?build_rescue:%define rescue 1}
61
62 # Turn off some stuff for resuce builds
63 %if %{rescue}
64 %define kerberos5 0
65 %endif
66
67 Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
68 Name: openssh
69 Version: %{ver}
70 %if %{rescue}
71 Release: %{rel}rescue
72 %else
73 Release: %{rel}
74 %endif
75 URL: http://www.openssh.com/portable.html
76 Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
77 %if ! %{skip_x11_askpass}
78 Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
79 %endif
80 License: BSD
81 Group: Applications/Internet
82 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
83 Obsoletes: ssh
84 %if %{build6x}
85 PreReq: initscripts >= 5.00
86 %else
87 PreReq: initscripts >= 5.20
88 %endif
89 BuildPreReq: perl, openssl-devel, tcp_wrappers
90 BuildPreReq: /bin/login
91 %if ! %{build6x}
92 BuildPreReq: glibc-devel, pam
93 %else
94 BuildPreReq: /usr/include/security/pam_appl.h
95 %endif
96 %if ! %{no_x11_askpass}
97 BuildPreReq: XFree86-devel
98 %endif
99 %if ! %{no_gnome_askpass}
100 BuildPreReq: pkgconfig
101 %endif
102 %if %{kerberos5}
103 BuildPreReq: krb5-devel
104 BuildPreReq: krb5-libs
105 %endif
106
107 %package clients
108 Summary: OpenSSH clients.
109 Requires: openssh = %{version}-%{release}
110 Group: Applications/Internet
111 Obsoletes: ssh-clients
112
113 %package server
114 Summary: The OpenSSH server daemon.
115 Group: System Environment/Daemons
116 Obsoletes: ssh-server
117 PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
118 %if ! %{build6x}
119 Requires: /etc/pam.d/system-auth
120 %endif
121
122 %package askpass
123 Summary: A passphrase dialog for OpenSSH and X.
124 Group: Applications/Internet
125 Requires: openssh = %{version}-%{release}
126 Obsoletes: ssh-extras
127
128 %package askpass-gnome
129 Summary: A passphrase dialog for OpenSSH, X, and GNOME.
130 Group: Applications/Internet
131 Requires: openssh = %{version}-%{release}
132 Obsoletes: ssh-extras
133
134 %description
135 SSH (Secure SHell) is a program for logging into and executing
136 commands on a remote machine. SSH is intended to replace rlogin and
137 rsh, and to provide secure encrypted communications between two
138 untrusted hosts over an insecure network. X11 connections and
139 arbitrary TCP/IP ports can also be forwarded over the secure channel.
140
141 OpenSSH is OpenBSD's version of the last free version of SSH, bringing
142 it up to date in terms of security and features, as well as removing
143 all patented algorithms to separate libraries.
144
145 This package includes the core files necessary for both the OpenSSH
146 client and server. To make this package useful, you should also
147 install openssh-clients, openssh-server, or both.
148
149 %description clients
150 OpenSSH is a free version of SSH (Secure SHell), a program for logging
151 into and executing commands on a remote machine. This package includes
152 the clients necessary to make encrypted connections to SSH servers.
153 You'll also need to install the openssh package on OpenSSH clients.
154
155 %description server
156 OpenSSH is a free version of SSH (Secure SHell), a program for logging
157 into and executing commands on a remote machine. This package contains
158 the secure shell daemon (sshd). The sshd daemon allows SSH clients to
159 securely connect to your SSH server. You also need to have the openssh
160 package installed.
161
162 %description askpass
163 OpenSSH is a free version of SSH (Secure SHell), a program for logging
164 into and executing commands on a remote machine. This package contains
165 an X11 passphrase dialog for OpenSSH.
166
167 %description askpass-gnome
168 OpenSSH is a free version of SSH (Secure SHell), a program for logging
169 into and executing commands on a remote machine. This package contains
170 an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
171 environment.
172
173 %prep
174
175 %if ! %{no_x11_askpass}
176 %setup -q -a 1
177 %else
178 %setup -q
179 %endif
180
181 %build
182 %if %{rescue}
183 CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
184 %endif
185
186 %if %{kerberos5}
187 K5DIR=`rpm -ql krb5-devel | grep include/krb5.h | sed 's,\/include\/krb5.h,,'`
188 echo K5DIR=$K5DIR
189 %endif
190
191 %configure \
192         --sysconfdir=%{_sysconfdir}/ssh \
193         --libexecdir=%{_libexecdir}/openssh \
194         --datadir=%{_datadir}/openssh \
195         --with-tcp-wrappers \
196         --with-rsh=%{_bindir}/rsh \
197         --with-default-path=/usr/local/bin:/bin:/usr/bin \
198         --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
199         --with-privsep-path=%{_var}/empty/sshd \
200         --with-md5-passwords \
201 %if %{scard}
202         --with-smartcard \
203 %endif
204 %if %{rescue}
205         --without-pam \
206 %else
207         --with-pam \
208 %endif
209 %if %{kerberos5}
210          --with-kerberos5=$K5DIR \
211 %endif
212
213
214 %if %{static_libcrypto}
215 perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
216 %endif
217
218 make
219
220 %if ! %{no_x11_askpass}
221 pushd x11-ssh-askpass-%{aversion}
222 %configure --libexecdir=%{_libexecdir}/openssh
223 xmkmf -a
224 make
225 popd
226 %endif
227
228 # Define a variable to toggle gnome1/gtk2 building.  This is necessary
229 # because RPM doesn't handle nested %if statements.
230 %if %{gtk2}
231         gtk2=yes
232 %else
233         gtk2=no
234 %endif
235
236 %if ! %{no_gnome_askpass}
237 pushd contrib
238 if [ $gtk2 = yes ] ; then
239         make gnome-ssh-askpass2
240         mv gnome-ssh-askpass2 gnome-ssh-askpass
241 else
242         make gnome-ssh-askpass1
243         mv gnome-ssh-askpass1 gnome-ssh-askpass
244 fi
245 popd
246 %endif
247
248 %install
249 rm -rf $RPM_BUILD_ROOT
250 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
251 mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
252 mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
253
254 make install DESTDIR=$RPM_BUILD_ROOT
255
256 install -d $RPM_BUILD_ROOT/etc/pam.d/
257 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
258 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
259 %if %{build6x}
260 install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
261 %else
262 install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
263 %endif
264 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
265
266 %if ! %{no_x11_askpass}
267 install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
268 ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
269 %endif
270
271 %if ! %{no_gnome_askpass}
272 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
273 %endif
274
275 %if ! %{scard}
276          rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
277 %endif
278
279 %if ! %{no_gnome_askpass}
280 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
281 install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
282 install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
283 %endif
284
285 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
286
287 %clean
288 rm -rf $RPM_BUILD_ROOT
289
290 %triggerun server -- ssh-server
291 if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
292         touch /var/run/sshd.restart
293 fi
294
295 %triggerun server -- openssh-server < 2.5.0p1
296 # Count the number of HostKey and HostDsaKey statements we have.
297 gawk    'BEGIN {IGNORECASE=1}
298          /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
299          END {exit sawhostkey}' /etc/ssh/sshd_config
300 # And if we only found one, we know the client was relying on the old default
301 # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
302 # specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
303 # one nullifies the default, which would have loaded both.
304 if [ $? -eq 1 ] ; then
305         echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
306         echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
307 fi
308
309 %triggerpostun server -- ssh-server
310 if [ "$1" != 0 ] ; then
311         /sbin/chkconfig --add sshd
312         if test -f /var/run/sshd.restart ; then
313                 rm -f /var/run/sshd.restart
314                 /sbin/service sshd start > /dev/null 2>&1 || :
315         fi
316 fi
317
318 %pre server
319 %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
320 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
321         -g sshd -M -r sshd 2>/dev/null || :
322
323 %post server
324 /sbin/chkconfig --add sshd
325
326 %postun server
327 /sbin/service sshd condrestart > /dev/null 2>&1 || :
328
329 %preun server
330 if [ "$1" = 0 ]
331 then
332         /sbin/service sshd stop > /dev/null 2>&1 || :
333         /sbin/chkconfig --del sshd
334 fi
335
336 %files
337 %defattr(-,root,root)
338 %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO WARNING*
339 %attr(0755,root,root) %{_bindir}/scp
340 %attr(0644,root,root) %{_mandir}/man1/scp.1*
341 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
342 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
343 %if ! %{rescue}
344 %attr(0755,root,root) %{_bindir}/ssh-keygen
345 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
346 %attr(0755,root,root) %dir %{_libexecdir}/openssh
347 %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
348 %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
349 %endif
350 %if %{scard}
351 %attr(0755,root,root) %dir %{_datadir}/openssh
352 %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
353 %endif
354
355 %files clients
356 %defattr(-,root,root)
357 %attr(0755,root,root) %{_bindir}/ssh
358 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
359 %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
360 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
361 %attr(-,root,root) %{_bindir}/slogin
362 %attr(-,root,root) %{_mandir}/man1/slogin.1*
363 %if ! %{rescue}
364 %attr(2755,root,nobody) %{_bindir}/ssh-agent
365 %attr(0755,root,root) %{_bindir}/ssh-add
366 %attr(0755,root,root) %{_bindir}/ssh-keyscan
367 %attr(0755,root,root) %{_bindir}/sftp
368 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
369 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
370 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
371 %attr(0644,root,root) %{_mandir}/man1/sftp.1*
372 %endif
373
374 %if ! %{rescue}
375 %files server
376 %defattr(-,root,root)
377 %dir %attr(0111,root,root) %{_var}/empty/sshd
378 %attr(0755,root,root) %{_sbindir}/sshd
379 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
380 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
381 %attr(0644,root,root) %{_mandir}/man5/moduli.5*
382 %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
383 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
384 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
385 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
386 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
387 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
388 %endif
389
390 %if ! %{no_x11_askpass}
391 %files askpass
392 %defattr(-,root,root)
393 %doc x11-ssh-askpass-%{aversion}/README
394 %doc x11-ssh-askpass-%{aversion}/ChangeLog
395 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
396 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
397 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
398 %endif
399
400 %if ! %{no_gnome_askpass}
401 %files askpass-gnome
402 %defattr(-,root,root)
403 %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
404 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
405 %endif
406
407 %changelog
408 * Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
409 - Remove noip6 option. This may be controlled at run-time in client config
410   file using new AddressFamily directive
411
412 * Mon May 12 2003 Damien Miller <djm@mindrot.org>
413 - Don't install profile.d scripts when not building with GNOME/GTK askpass
414   (patch from bet@rahul.net)
415
416 * Wed Oct 01 2002 Damien Miller <djm@mindrot.org>
417 - Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
418
419 * Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
420 - Use contrib/ Makefile for building askpass programs
421
422 * Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
423 - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
424 - Add new {ssh,sshd}_config.5 manpages
425 - Add new ssh-keysign program and remove setuid from ssh client
426
427 * Fri May 10 2002 Damien Miller <djm@mindrot.org>
428 - Merge in spec changes from RedHat, reorgansie a little
429 - Add Privsep user, group and directory
430
431 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
432 - bump and grind (through the build system)
433
434 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
435 - require sharutils for building (mindrot #137)
436 - require db1-devel only when building for 6.x (#55105), which probably won't
437   work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
438 - require pam-devel by file (not by package name) again
439 - add Markus's patch to compile with OpenSSL 0.9.5a (from
440   http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
441   building for 6.x
442
443 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
444 - update to 3.1p1
445
446 * Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
447 - update to SNAP-20020305
448 - drop debug patch, fixed upstream
449
450 * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
451 - update to SNAP-20020220 for testing purposes (you've been warned, if there's
452   anything to be warned about, gss patches won't apply, I don't mind)
453
454 * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
455 - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
456   exchange, authentication, and named key support
457
458 * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
459 - remove dependency on db1-devel, which has just been swallowed up whole
460   by gnome-libs-devel
461
462 * Sun Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
463 - adjust build dependencies so that build6x actually works right (fix
464   from Hugo van der Kooij)
465
466 * Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
467 - update to 3.0.2p1
468
469 * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
470 - update to 3.0.1p1
471
472 * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
473 - update to current CVS (not for use in distribution)
474
475 * Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
476 - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
477   3.0p1 spec file and init script
478
479 * Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
480 - update to 3.0p1
481 - update to x11-ssh-askpass 1.2.4.1
482 - change build dependency on a file from pam-devel to the pam-devel package
483 - replace primes with moduli
484
485 * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
486 - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
487
488 * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
489 - Merge changes to rescue build from current sysadmin survival cd
490
491 * Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
492 - fix scp's server's reporting of file sizes, and build with the proper
493   preprocessor define to get large-file capable open(), stat(), etc.
494   (sftp has been doing this correctly all along) (#51827)
495 - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
496 - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
497 - mark profile.d scriptlets as config files (#42337)
498 - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
499 - change a couple of log() statements to debug() statements (#50751)
500 - pull cvs patch to add -t flag to sshd (#28611)
501 - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
502
503 * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
504 - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
505
506 * Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
507 - pull cvs patch to fix remote port forwarding with protocol 2
508
509 * Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
510 - pull cvs patch to add session initialization to no-pty sessions
511 - pull cvs patch to not cut off challengeresponse auth needlessly
512 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
513   it by default on a system that doesn't have X installed (#49263)
514
515 * Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
516 - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
517
518 * Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
519 - pass OPTIONS correctly to initlog (#50151)
520
521 * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
522 - switch to x11-ssh-askpass 1.2.2
523
524 * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
525 - rebuild in new environment
526
527 * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
528 - disable the gssapi patch
529
530 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
531 - update to 2.9p2
532 - refresh to a new version of the gssapi patch
533
534 * Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
535 - change Copyright: BSD to License: BSD
536 - add Markus Friedl's unverified patch for the cookie file deletion problem
537   so that we can verify it
538 - drop patch to check if xauth is present (was folded into cookie patch)
539 - don't apply gssapi patches for the errata candidate
540 - clear supplemental groups list at startup
541
542 * Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
543 - fix an error parsing the new default sshd_config
544 - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
545   dealing with comments right
546
547 * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
548 - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
549   to be removed before the next beta cycle because it's a big departure
550   from the upstream version
551
552 * Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
553 - finish marking strings in the init script for translation
554 - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
555   at startup (change merged from openssh.com init script, originally by
556   Pekka Savola)
557 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
558   it by default on a system that doesn't have X installed
559
560 * Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
561 - update to 2.9
562 - drop various patches that came from or went upstream or to or from CVS
563
564 * Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
565 - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
566
567 * Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
568 - remove explicit openssl requirement, fixes builddistro issue
569 - make initscript stop() function wait until sshd really dead to avoid
570   races in condrestart
571
572 * Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
573 - mention that challengereponse supports PAM, so disabling password doesn't
574   limit users to pubkey and rsa auth (#34378)
575 - bypass the daemon() function in the init script and call initlog directly,
576   because daemon() won't start a daemon it detects is already running (like
577   open connections)
578 - require the version of openssl we had when we were built
579
580 * Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
581 - make do_pam_setcred() smart enough to know when to establish creds and
582   when to reinitialize them
583 - add in a couple of other fixes from Damien for inclusion in the errata
584
585 * Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
586 - update to 2.5.2p2
587 - call setcred() again after initgroups, because the "creds" could actually
588   be group memberships
589
590 * Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
591 - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
592 - don't enable challenge-response by default until we find a way to not
593   have too many userauth requests (we may make up to six pubkey and up to
594   three password attempts as it is)
595 - remove build dependency on rsh to match openssh.com's packages more closely
596
597 * Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
598 - remove dependency on openssl -- would need to be too precise
599
600 * Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
601 - rebuild in new environment
602
603 * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
604 - Revert the patch to move pam_open_session.
605 - Init script and spec file changes from Pekka Savola. (#28750)
606 - Patch sftp to recognize '-o protocol' arguments. (#29540)
607
608 * Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
609 - Chuck the closing patch.
610 - Add a trigger to add host keys for protocol 2 to the config file, now that
611   configuration file syntax requires us to specify it with HostKey if we
612   specify any other HostKey values, which we do.
613
614 * Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
615 - Redo patch to move pam_open_session after the server setuid()s to the user.
616 - Rework the nopam patch to use be picked up by autoconf.
617
618 * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
619 - Update for 2.5.1p1.
620 - Add init script mods from Pekka Savola.
621 - Tweak the init script to match the CVS contrib script more closely.
622 - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
623   adding id_rsa.
624
625 * Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
626 - Update for 2.5.0p1.
627 - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
628 - Resync with parts of Damien Miller's openssh.spec from CVS, including
629   update of x11 askpass to 1.2.0.
630 - Only require openssl (don't prereq) because we generate keys in the init
631   script now.
632
633 * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
634 - Don't open a PAM session until we've forked and become the user (#25690).
635 - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
636   host the user is attempting a login from.
637 - Resync with parts of Damien Miller's openssh.spec from CVS.
638 - Don't expose KbdInt responses in debug messages (from CVS).
639 - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
640
641 * Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
642 - i18n-tweak to initscript.
643
644 * Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
645 - More gettextizing.
646 - Close all files after going into daemon mode (needs more testing).
647 - Extract patch from CVS to handle auth banners (in the client).
648 - Extract patch from CVS to handle compat weirdness.
649
650 * Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
651 - Finish with the gettextizing.
652
653 * Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
654 - Fix a bug in auth2-pam.c (#23877)
655 - Gettextize the init script.
656
657 * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
658 - Incorporate a switch for using PAM configs for 6.x, just in case.
659
660 * Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
661 - Incorporate Bero's changes for a build specifically for rescue CDs.
662
663 * Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
664 - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
665   succeeded, to allow public-key authentication after a failure with "none"
666   authentication.  (#21268)
667
668 * Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
669 - Update to x11-askpass 1.1.1. (#21301)
670 - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
671
672 * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
673 - Merge multiple PAM text messages into subsequent prompts when possible when
674   doing keyboard-interactive authentication.
675
676 * Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
677 - Disable the built-in MD5 password support.  We're using PAM.
678 - Take a crack at doing keyboard-interactive authentication with PAM, and
679   enable use of it in the default client configuration so that the client
680   will try it when the server disallows password authentication.
681 - Build with debugging flags.  Build root policies strip all binaries anyway.
682
683 * Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
684 - Use DESTDIR instead of %%makeinstall.
685 - Remove /usr/X11R6/bin from the path-fixing patch.
686
687 * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
688 - Add the primes file from the latest snapshot to the main package (#20884).
689 - Add the dev package to the prereq list (#19984).
690 - Remove the default path and mimic login's behavior in the server itself.
691
692 * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
693 - Resync with conditional options in Damien Miller's .spec file for an errata.
694 - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
695
696 * Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
697 - Update to OpenSSH 2.3.0p1.
698 - Update to x11-askpass 1.1.0.
699 - Enable keyboard-interactive authentication.
700
701 * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
702 - Update to ssh-askpass-x11 1.0.3.
703 - Change authentication related messages to be private (#19966).
704
705 * Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
706 - Patch ssh-keygen to be able to list signatures for DSA public key files
707   it generates.
708
709 * Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
710 - Add BuildPreReq on /usr/include/security/pam_appl.h to be sure we always
711   build PAM authentication in.
712 - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
713 - Clean out no-longer-used patches.
714 - Patch ssh-add to try to add both identity and id_dsa, and to error only
715   when neither exists.
716
717 * Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
718 - Update x11-askpass to 1.0.2. (#17835)
719 - Add BuildPreReqs for /bin/login and /usr/bin/rsh so that configure will
720   always find them in the right place. (#17909)
721 - Set the default path to be the same as the one supplied by /bin/login, but
722   add /usr/X11R6/bin. (#17909)
723 - Try to handle obsoletion of ssh-server more cleanly.  Package names
724   are different, but init script name isn't. (#17865)
725
726 * Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
727 - Update to 2.2.0p1. (#17835)
728 - Tweak the init script to allow proper restarting. (#18023)
729
730 * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
731 - Update to 20000823 snapshot.
732 - Change subpackage requirements from %%{version} to %%{version}-%%{release}
733 - Back out the pipe patch.
734
735 * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
736 - Update to 2.1.1p4, which includes fixes for config file parsing problems.
737 - Move the init script back.
738 - Add Damien's quick fix for wackiness.
739
740 * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
741 - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
742
743 * Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
744 - Move condrestart to server postun.
745 - Move key generation to init script.
746 - Actually use the right patch for moving the key generation to the init script.
747 - Clean up the init script a bit.
748
749 * Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
750 - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
751
752 * Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
753 - Update to 2.1.1p2.
754 - Use of strtok() considered harmful.
755
756 * Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
757 - Get the build root out of the man pages.
758
759 * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
760 - Add and use condrestart support in the init script.
761 - Add newer initscripts as a prereq.
762
763 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
764 - Build in new environment (release 2)
765 - Move -clients subpackage to Applications/Internet group
766
767 * Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
768 - Update to 2.2.1p1
769
770 * Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
771 - Patch to build with neither RSA nor RSAref.
772 - Miscellaneous FHS-compliance tweaks.
773 - Fix for possibly-compressed man pages.
774
775 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
776 - Updated for new location
777 - Updated for new gnome-ssh-askpass build
778
779 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
780 - Added Jim Knoble's <jmknoble@pobox.com> askpass
781
782 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
783 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
784
785 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
786 - Added 'Obsoletes' directives
787
788 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
789 - Use make install
790 - Subpackages
791
792 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
793 - Added links for slogin
794 - Fixed perms on manpages
795
796 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
797 - Renamed init script
798
799 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
800 - Back to old binary names
801
802 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
803 - Use autoconf
804 - New binary names
805
806 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
807 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
This page took 0.270777 seconds and 5 git commands to generate.