]> andersk Git - openssh.git/blob - contrib/redhat/openssh.spec
Jim Knoble has changed his email address
[openssh.git] / contrib / redhat / openssh.spec
1 # Version of OpenSSH
2 %define oversion 2.3.0p2
3
4 # Version of ssh-askpass
5 %define aversion 1.1.1
6
7 # Do we want to disable building of x11-askpass? (1=yes 0=no)
8 %define no_x11_askpass 0
9
10 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
11 %define no_gnome_askpass 0
12
13 Summary: OpenSSH free Secure Shell (SSH) implementation
14 Name: openssh
15 Version: %{oversion}
16 Release: 1
17 Packager: Damien Miller <djm@mindrot.org>
18 URL: http://www.openssh.com/
19 Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{oversion}.tar.gz
20 %if ! %{no_x11_askpass}
21 Source1: http://www.jmknoble.cx/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz 
22 %endif
23 Copyright: BSD
24 Group: Applications/Internet
25 BuildRoot: /tmp/openssh-%{version}-buildroot
26 Obsoletes: ssh
27 PreReq: openssl >= 0.9.5a
28 Requires: openssl >= 0.9.5a
29 BuildPreReq: perl, openssl-devel, tcp_wrappers
30 BuildPreReq: /bin/login, /usr/bin/rsh, /usr/include/security/pam_appl.h
31 %if ! %{no_gnome_askpass}
32 BuildPreReq: gnome-libs-devel
33 %endif
34
35 %package clients
36 Summary: OpenSSH Secure Shell protocol clients
37 Requires: openssh = %{version}-%{release}
38 Group: Applications/Internet
39 Obsoletes: ssh-clients
40
41 %package server
42 Summary: OpenSSH Secure Shell protocol server (sshd)
43 Group: System Environment/Daemons
44 Obsoletes: ssh-server
45 PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
46 Requires: initscripts >= 4.16
47
48 %package askpass
49 Summary: OpenSSH X11 passphrase dialog
50 Group: Applications/Internet
51 Requires: openssh = %{version}-%{release}
52 Obsoletes: ssh-extras
53
54 %package askpass-gnome
55 Summary: OpenSSH GNOME passphrase dialog
56 Group: Applications/Internet
57 Requires: openssh = %{version}-%{release}
58 Obsoletes: ssh-extras
59
60 %description
61 Ssh (Secure Shell) a program for logging into a remote machine and for
62 executing commands in a remote machine.  It is intended to replace
63 rlogin and rsh, and provide secure encrypted communications between
64 two untrusted hosts over an insecure network.  X11 connections and
65 arbitrary TCP/IP ports can also be forwarded over the secure channel.
66
67 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
68 up to date in terms of security and features, as well as removing all 
69 patented algorithms to separate libraries (OpenSSL).
70
71 This package includes the core files necessary for both the OpenSSH
72 client and server.  To make this package useful, you should also
73 install openssh-clients, openssh-server, or both.
74
75 %description clients
76 Ssh (Secure Shell) a program for logging into a remote machine and for
77 executing commands in a remote machine.  It is intended to replace
78 rlogin and rsh, and provide secure encrypted communications between
79 two untrusted hosts over an insecure network.  X11 connections and
80 arbitrary TCP/IP ports can also be forwarded over the secure channel.
81
82 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
83 up to date in terms of security and features, as well as removing all 
84 patented algorithms to separate libraries (OpenSSL).
85
86 This package includes the clients necessary to make encrypted connections
87 to SSH servers.
88
89 %description server
90 Ssh (Secure Shell) a program for logging into a remote machine and for
91 executing commands in a remote machine.  It is intended to replace
92 rlogin and rsh, and provide secure encrypted communications between
93 two untrusted hosts over an insecure network.  X11 connections and
94 arbitrary TCP/IP ports can also be forwarded over the secure channel.
95
96 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
97 up to date in terms of security and features, as well as removing all 
98 patented algorithms to separate libraries (OpenSSL).
99
100 This package contains the secure shell daemon. The sshd is the server 
101 part of the secure shell protocol and allows ssh clients to connect to 
102 your host.
103
104 %description askpass
105 Ssh (Secure Shell) a program for logging into a remote machine and for
106 executing commands in a remote machine.  It is intended to replace
107 rlogin and rsh, and provide secure encrypted communications between
108 two untrusted hosts over an insecure network.  X11 connections and
109 arbitrary TCP/IP ports can also be forwarded over the secure channel.
110
111 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
112 up to date in terms of security and features, as well as removing all 
113 patented algorithms to separate libraries (OpenSSL).
114
115 This package contains Jim Knoble's <jmknoble@jmknoble.cx> X11 passphrase 
116 dialog.
117
118 %description askpass-gnome
119 Ssh (Secure Shell) a program for logging into a remote machine and for
120 executing commands in a remote machine.  It is intended to replace
121 rlogin and rsh, and provide secure encrypted communications between
122 two untrusted hosts over an insecure network.  X11 connections and
123 arbitrary TCP/IP ports can also be forwarded over the secure channel.
124
125 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
126 up to date in terms of security and features, as well as removing all 
127 patented algorithms to separate libraries (OpenSSL).
128
129 This package contains the GNOME passphrase dialog.
130
131 %prep
132
133 %if ! %{no_x11_askpass}
134 %setup -q -a 1
135 %else
136 %setup -q
137 %endif
138
139 %build
140
141 %define _sysconfdir /etc/ssh
142
143 %configure \
144         --libexecdir=%{_libexecdir}/openssh \
145         --with-tcp-wrappers \
146         --with-ipv4-default \
147         --with-rsh=/usr/bin/rsh \
148         --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin
149
150 make
151
152 %if ! %{no_x11_askpass}
153 pushd x11-ssh-askpass-%{aversion}
154 xmkmf -a
155 make
156 popd
157 %endif
158
159 %if ! %{no_gnome_askpass}
160 pushd contrib
161 gcc -O -g `gnome-config --cflags gnome gnomeui` \
162         gnome-ssh-askpass.c -o gnome-ssh-askpass \
163         `gnome-config --libs gnome gnomeui`
164 popd
165 %endif
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 %{makeinstall} \
170         libexecdir=$RPM_BUILD_ROOT%{_libexecdir}/openssh \
171         DESTDIR=/ # Hack to disable key generation
172
173
174 install -d $RPM_BUILD_ROOT/etc/pam.d/
175 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
176 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
177 install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
178 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
179
180 %if ! %{no_x11_askpass}
181 install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/openssh/x11-ssh-askpass
182 ln -s /usr/libexec/openssh/x11-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/openssh/ssh-askpass
183 %endif
184
185 %if ! %{no_gnome_askpass}
186 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/openssh/gnome-ssh-askpass
187 %endif
188
189 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %post server
195 /sbin/chkconfig --add sshd
196 if test -r /var/run/sshd.pid ; then
197         /etc/rc.d/init.d/sshd restart >&2
198 fi
199
200 %preun server
201 if [ "$1" = 0 ] ; then
202         /etc/rc.d/init.d/sshd stop >&2
203         /sbin/chkconfig --del sshd
204 fi
205
206 %files
207 %defattr(-,root,root)
208 %doc ChangeLog OVERVIEW README* INSTALL 
209 %doc CREDITS LICENCE
210 %attr(0755,root,root) %{_bindir}/ssh-keygen
211 %attr(0755,root,root) %{_bindir}/scp
212 %attr(0755,root,root) %{_bindir}/ssh-keyscan
213 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
214 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
215 %attr(0644,root,root) %{_mandir}/man1/scp.1*
216 %attr(0755,root,root) %dir %{_sysconfdir}
217 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/primes
218 %attr(0755,root,root) %dir %{_libexecdir}/openssh
219
220 %files clients
221 %defattr(-,root,root)
222 %attr(4755,root,root) %{_bindir}/ssh
223 %attr(0755,root,root) %{_bindir}/ssh-agent
224 %attr(0755,root,root) %{_bindir}/ssh-add
225 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
226 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
227 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
228 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh_config
229 %attr(-,root,root) %{_bindir}/slogin
230 %attr(-,root,root) %{_mandir}/man1/slogin.1*
231
232 %files server
233 %defattr(-,root,root)
234 %attr(0755,root,root) %{_sbindir}/sshd
235 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
236 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
237 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
238 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sshd_config
239 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
240 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
241
242 %if ! %{no_x11_askpass}
243 %files askpass
244 %defattr(-,root,root)
245 %doc x11-ssh-askpass-%{aversion}/README
246 %doc x11-ssh-askpass-%{aversion}/ChangeLog
247 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
248 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
249 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
250 %endif
251
252 %if ! %{no_gnome_askpass}
253 %files askpass-gnome
254 %defattr(-,root,root)
255 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
256 %endif
257
258 %changelog
259 * Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
260 - Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the 
261   Redhat 7.0 spec file
262 * Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
263 - Use RPM configure macro
264 * Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
265 - Some surgery to sshd.init (generate keys at runtime)
266 - Cleanup of groups and removal of keygen calls
267 * Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
268 - Make building of X11-askpass and gnome-askpass optional
269 * Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
270 - Glob manpages to catch compressed files
271 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
272 - Updated for new location
273 - Updated for new gnome-ssh-askpass build
274 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
275 - Added Jim Knoble's <jmknoble@pobox.com> askpass
276 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
277 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
278 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
279 - Added 'Obsoletes' directives
280 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
281 - Use make install
282 - Subpackages
283 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
284 - Added links for slogin
285 - Fixed perms on manpages
286 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
287 - Renamed init script
288 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
289 - Back to old binary names
290 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
291 - Use autoconf
292 - New binary names
293 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
294 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
295
This page took 0.06408 seconds and 5 git commands to generate.