]> andersk Git - openssh.git/blob - contrib/redhat/openssh.spec
- (djm) Redhat spec: Don't install profile.d scripts when not
[openssh.git] / contrib / redhat / openssh.spec
1 %define ver 3.6.1p2
2 %define rel 2
3
4 # OpenSSH privilege separation requires a user & group ID
5 %define sshd_uid    74
6 %define sshd_gid    74
7
8 # Version of ssh-askpass
9 %define aversion 1.2.4.1
10
11 # Do we want to disable building of x11-askpass? (1=yes 0=no)
12 %define no_x11_askpass 0
13
14 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
15 %define no_gnome_askpass 0
16
17 # Do we want to link against a static libcrypto? (1=yes 0=no)
18 %define static_libcrypto 0
19
20 # Do we want smartcard support (1=yes 0=no)
21 %define scard 0
22
23 # Use GTK2 instead of GNOME in gnome-ssh-askpass
24 %define gtk2 1
25
26 # Is this build for RHL 6.x?
27 %define build6x 0
28
29 # Disable IPv6 (avoids DNS hangs on some glibc versions)
30 %define noip6 0
31
32 # Do we want kerberos5 support (1=yes 0=no)
33 %define kerberos5 1
34
35 # Reserve options to override askpass settings with:
36 # rpm -ba|--rebuild --define 'skip_xxx 1'
37 %{?skip_x11_askpass:%define no_x11_askpass 1}
38 %{?skip_gnome_askpass:%define no_gnome_askpass 1}
39
40 # Is this a build for RHL 6.x or earlier?
41 %{?build_6x:%define build6x 1}
42
43 # If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
44 %if %{build6x}
45 %define _sysconfdir /etc
46 %define noip6 1
47 %endif
48
49 # Options for static OpenSSL link:
50 # rpm -ba|--rebuild --define "static_openssl 1"
51 %{?static_openssl:%define static_libcrypto 1}
52
53 # Options for Smartcard support: (needs libsectok and openssl-engine)
54 # rpm -ba|--rebuild --define "smartcard 1"
55 %{?smartcard:%define scard 1}
56
57 # Option to disable ipv6
58 # rpm -ba|--rebuild --define "noipv6 1"
59 %{?noipv6:%define noip6 1}
60
61 # Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
62 %define rescue 0
63 %{?build_rescue:%define rescue 1}
64
65 # Turn off some stuff for resuce builds
66 %if %{rescue}
67 %define kerberos5 0
68 %endif
69
70 Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
71 Name: openssh
72 Version: %{ver}
73 %if %{rescue}
74 Release: %{rel}rescue
75 %else
76 Release: %{rel}
77 %endif
78 URL: http://www.openssh.com/portable.html
79 Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
80 Source1: http://www.pobox.com/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
81 License: BSD
82 Group: Applications/Internet
83 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
84 Obsoletes: ssh
85 %if %{build6x}
86 PreReq: initscripts >= 5.00
87 %else
88 PreReq: initscripts >= 5.20
89 %endif
90 BuildPreReq: perl, openssl-devel, tcp_wrappers
91 BuildPreReq: /bin/login
92 %if ! %{build6x}
93 BuildPreReq: glibc-devel, pam
94 %else
95 BuildPreReq: db1-devel, /usr/include/security/pam_appl.h
96 %endif
97 %if ! %{no_x11_askpass}
98 BuildPreReq: XFree86-devel
99 %endif
100 %if ! %{no_gnome_askpass}
101 BuildPreReq: pkgconfig
102 %endif
103 %if %{kerberos5}
104 BuildPreReq: krb5-devel
105 BuildPreReq: krb5-libs
106 %endif
107
108 %package clients
109 Summary: OpenSSH clients.
110 Requires: openssh = %{version}-%{release}
111 Group: Applications/Internet
112 Obsoletes: ssh-clients
113
114 %package server
115 Summary: The OpenSSH server daemon.
116 Group: System Environment/Daemons
117 Obsoletes: ssh-server
118 PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
119 %if ! %{build6x}
120 Requires: /etc/pam.d/system-auth
121 %endif
122
123 %package askpass
124 Summary: A passphrase dialog for OpenSSH and X.
125 Group: Applications/Internet
126 Requires: openssh = %{version}-%{release}
127 Obsoletes: ssh-extras
128
129 %package askpass-gnome
130 Summary: A passphrase dialog for OpenSSH, X, and GNOME.
131 Group: Applications/Internet
132 Requires: openssh = %{version}-%{release}
133 Obsoletes: ssh-extras
134
135 %description
136 SSH (Secure SHell) is a program for logging into and executing
137 commands on a remote machine. SSH is intended to replace rlogin and
138 rsh, and to provide secure encrypted communications between two
139 untrusted hosts over an insecure network. X11 connections and
140 arbitrary TCP/IP ports can also be forwarded over the secure channel.
141
142 OpenSSH is OpenBSD's version of the last free version of SSH, bringing
143 it up to date in terms of security and features, as well as removing
144 all patented algorithms to separate libraries.
145
146 This package includes the core files necessary for both the OpenSSH
147 client and server. To make this package useful, you should also
148 install openssh-clients, openssh-server, or both.
149
150 %description clients
151 OpenSSH is a free version of SSH (Secure SHell), a program for logging
152 into and executing commands on a remote machine. This package includes
153 the clients necessary to make encrypted connections to SSH servers.
154 You'll also need to install the openssh package on OpenSSH clients.
155
156 %description server
157 OpenSSH is a free version of SSH (Secure SHell), a program for logging
158 into and executing commands on a remote machine. This package contains
159 the secure shell daemon (sshd). The sshd daemon allows SSH clients to
160 securely connect to your SSH server. You also need to have the openssh
161 package installed.
162
163 %description askpass
164 OpenSSH is a free version of SSH (Secure SHell), a program for logging
165 into and executing commands on a remote machine. This package contains
166 an X11 passphrase dialog for OpenSSH.
167
168 %description askpass-gnome
169 OpenSSH is a free version of SSH (Secure SHell), a program for logging
170 into and executing commands on a remote machine. This package contains
171 an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
172 environment.
173
174 %prep
175
176 %if ! %{no_x11_askpass}
177 %setup -q -a 1
178 %else
179 %setup -q
180 %endif
181
182 %build
183 %if %{rescue}
184 CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
185 %endif
186
187 %configure \
188         --sysconfdir=%{_sysconfdir}/ssh \
189         --libexecdir=%{_libexecdir}/openssh \
190         --datadir=%{_datadir}/openssh \
191         --with-tcp-wrappers \
192         --with-rsh=%{_bindir}/rsh \
193         --with-default-path=/usr/local/bin:/bin:/usr/bin \
194         --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
195         --with-privsep-path=%{_var}/empty/sshd \
196 %if %{scard}
197         --with-smartcard \
198 %endif
199 %if %{noip6}
200         --with-ipv4-default \
201 %endif
202 %if %{rescue}
203         --without-pam --with-md5-passwords \
204 %else
205         --with-pam \
206 %endif
207 %if %{kerberos5}
208          --with-kerberos5=/usr/kerberos \
209 %endif
210
211
212 %if %{static_libcrypto}
213 perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
214 %endif
215
216 make
217
218 %if ! %{no_x11_askpass}
219 pushd x11-ssh-askpass-%{aversion}
220 %configure --libexecdir=%{_libexecdir}/openssh
221 xmkmf -a
222 make
223 popd
224 %endif
225
226 # Define a variable to toggle gnome1/gtk2 building.  This is necessary
227 # because RPM doesn't handle nested %if statements.
228 %if %{gtk2}
229         gtk2=yes
230 %else
231         gtk2=no
232 %endif
233
234 %if ! %{no_gnome_askpass}
235 pushd contrib
236 if [ $gtk2 = yes ] ; then
237         make gnome-ssh-askpass2
238         mv gnome-ssh-askpass2 gnome-ssh-askpass
239 else
240         make gnome-ssh-askpass1
241         mv gnome-ssh-askpass1 gnome-ssh-askpass
242 fi
243 popd
244 %endif
245
246 %install
247 rm -rf $RPM_BUILD_ROOT
248 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
249 mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
250 mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
251
252 make install DESTDIR=$RPM_BUILD_ROOT
253
254 install -d $RPM_BUILD_ROOT/etc/pam.d/
255 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
256 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
257 %if %{build6x}
258 install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
259 %else
260 install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
261 %endif
262 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
263
264 %if ! %{no_x11_askpass}
265 install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
266 ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
267 %endif
268
269 %if ! %{no_gnome_askpass}
270 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
271 %endif
272
273 %if ! %{scard}
274          rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
275 %endif
276
277 %if ! %{no_gnome_askpass}
278 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
279 install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
280 install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
281 %endif
282
283 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
284
285 %clean
286 rm -rf $RPM_BUILD_ROOT
287
288 %triggerun server -- ssh-server
289 if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
290         touch /var/run/sshd.restart
291 fi
292
293 %triggerun server -- openssh-server < 2.5.0p1
294 # Count the number of HostKey and HostDsaKey statements we have.
295 gawk    'BEGIN {IGNORECASE=1}
296          /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
297          END {exit sawhostkey}' /etc/ssh/sshd_config
298 # And if we only found one, we know the client was relying on the old default
299 # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
300 # specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
301 # one nullifies the default, which would have loaded both.
302 if [ $? -eq 1 ] ; then
303         echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
304         echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
305 fi
306
307 %triggerpostun server -- ssh-server
308 if [ "$1" != 0 ] ; then
309         /sbin/chkconfig --add sshd
310         if test -f /var/run/sshd.restart ; then
311                 rm -f /var/run/sshd.restart
312                 /sbin/service sshd start > /dev/null 2>&1 || :
313         fi
314 fi
315
316 %pre server
317 %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
318 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
319         -g sshd -M -r sshd 2>/dev/null || :
320
321 %post server
322 /sbin/chkconfig --add sshd
323
324 %postun server
325 /sbin/service sshd condrestart > /dev/null 2>&1 || :
326
327 %preun server
328 if [ "$1" = 0 ]
329 then
330         /sbin/service sshd stop > /dev/null 2>&1 || :
331         /sbin/chkconfig --del sshd
332 fi
333
334 %files
335 %defattr(-,root,root)
336 %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
337 %attr(0755,root,root) %{_bindir}/scp
338 %attr(0644,root,root) %{_mandir}/man1/scp.1*
339 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
340 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
341 %if ! %{rescue}
342 %attr(0755,root,root) %{_bindir}/ssh-keygen
343 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
344 %attr(0755,root,root) %dir %{_libexecdir}/openssh
345 %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
346 %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
347 %endif
348 %if %{scard}
349 %attr(0755,root,root) %dir %{_datadir}/openssh
350 %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
351 %endif
352
353 %files clients
354 %defattr(-,root,root)
355 %attr(0755,root,root) %{_bindir}/ssh
356 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
357 %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
358 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
359 %attr(-,root,root) %{_bindir}/slogin
360 %attr(-,root,root) %{_mandir}/man1/slogin.1*
361 %if ! %{rescue}
362 %attr(2755,root,nobody) %{_bindir}/ssh-agent
363 %attr(0755,root,root) %{_bindir}/ssh-add
364 %attr(0755,root,root) %{_bindir}/ssh-keyscan
365 %attr(0755,root,root) %{_bindir}/sftp
366 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
367 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
368 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
369 %attr(0644,root,root) %{_mandir}/man1/sftp.1*
370 %endif
371
372 %if ! %{rescue}
373 %files server
374 %defattr(-,root,root)
375 %dir %attr(0111,root,root) %{_var}/empty/sshd
376 %attr(0755,root,root) %{_sbindir}/sshd
377 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
378 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
379 %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
380 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
381 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
382 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
383 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
384 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
385 %endif
386
387 %if ! %{no_x11_askpass}
388 %files askpass
389 %defattr(-,root,root)
390 %doc x11-ssh-askpass-%{aversion}/README
391 %doc x11-ssh-askpass-%{aversion}/ChangeLog
392 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
393 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
394 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
395 %endif
396
397 %if ! %{no_gnome_askpass}
398 %files askpass-gnome
399 %defattr(-,root,root)
400 %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
401 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
402 %endif
403
404 %changelog
405 * Mon May 12 2003 Damien Miller <djm@mindrot.org>
406 - Don't install profile.d scripts when not building with GNOME/GTK askpass
407   (patch from bet@rahul.net)
408
409 * Wed Oct 01 2002 Damien Miller <djm@mindrot.org>
410 - Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
411
412 * Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
413 - Use contrib/ Makefile for building askpass programs
414
415 * Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
416 - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
417 - Add new {ssh,sshd}_config.5 manpages
418 - Add new ssh-keysign program and remove setuid from ssh client
419
420 * Fri May 10 2002 Damien Miller <djm@mindrot.org>
421 - Merge in spec changes from RedHat, reorgansie a little
422 - Add Privsep user, group and directory
423
424 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
425 - bump and grind (through the build system)
426
427 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
428 - require sharutils for building (mindrot #137)
429 - require db1-devel only when building for 6.x (#55105), which probably won't
430   work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
431 - require pam-devel by file (not by package name) again
432 - add Markus's patch to compile with OpenSSL 0.9.5a (from
433   http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
434   building for 6.x
435
436 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
437 - update to 3.1p1
438
439 * Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
440 - update to SNAP-20020305
441 - drop debug patch, fixed upstream
442
443 * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
444 - update to SNAP-20020220 for testing purposes (you've been warned, if there's
445   anything to be warned about, gss patches won't apply, I don't mind)
446
447 * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
448 - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
449   exchange, authentication, and named key support
450
451 * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
452 - remove dependency on db1-devel, which has just been swallowed up whole
453   by gnome-libs-devel
454
455 * Sun Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
456 - adjust build dependencies so that build6x actually works right (fix
457   from Hugo van der Kooij)
458
459 * Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
460 - update to 3.0.2p1
461
462 * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
463 - update to 3.0.1p1
464
465 * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
466 - update to current CVS (not for use in distribution)
467
468 * Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
469 - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
470   3.0p1 spec file and init script
471
472 * Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
473 - update to 3.0p1
474 - update to x11-ssh-askpass 1.2.4.1
475 - change build dependency on a file from pam-devel to the pam-devel package
476 - replace primes with moduli
477
478 * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
479 - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
480
481 * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
482 - Merge changes to rescue build from current sysadmin survival cd
483
484 * Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
485 - fix scp's server's reporting of file sizes, and build with the proper
486   preprocessor define to get large-file capable open(), stat(), etc.
487   (sftp has been doing this correctly all along) (#51827)
488 - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
489 - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
490 - mark profile.d scriptlets as config files (#42337)
491 - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
492 - change a couple of log() statements to debug() statements (#50751)
493 - pull cvs patch to add -t flag to sshd (#28611)
494 - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
495
496 * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
497 - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
498
499 * Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
500 - pull cvs patch to fix remote port forwarding with protocol 2
501
502 * Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
503 - pull cvs patch to add session initialization to no-pty sessions
504 - pull cvs patch to not cut off challengeresponse auth needlessly
505 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
506   it by default on a system that doesn't have X installed (#49263)
507
508 * Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
509 - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
510
511 * Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
512 - pass OPTIONS correctly to initlog (#50151)
513
514 * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
515 - switch to x11-ssh-askpass 1.2.2
516
517 * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
518 - rebuild in new environment
519
520 * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
521 - disable the gssapi patch
522
523 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
524 - update to 2.9p2
525 - refresh to a new version of the gssapi patch
526
527 * Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
528 - change Copyright: BSD to License: BSD
529 - add Markus Friedl's unverified patch for the cookie file deletion problem
530   so that we can verify it
531 - drop patch to check if xauth is present (was folded into cookie patch)
532 - don't apply gssapi patches for the errata candidate
533 - clear supplemental groups list at startup
534
535 * Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
536 - fix an error parsing the new default sshd_config
537 - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
538   dealing with comments right
539
540 * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
541 - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
542   to be removed before the next beta cycle because it's a big departure
543   from the upstream version
544
545 * Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
546 - finish marking strings in the init script for translation
547 - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
548   at startup (change merged from openssh.com init script, originally by
549   Pekka Savola)
550 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
551   it by default on a system that doesn't have X installed
552
553 * Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
554 - update to 2.9
555 - drop various patches that came from or went upstream or to or from CVS
556
557 * Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
558 - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
559
560 * Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
561 - remove explicit openssl requirement, fixes builddistro issue
562 - make initscript stop() function wait until sshd really dead to avoid 
563   races in condrestart
564
565 * Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
566 - mention that challengereponse supports PAM, so disabling password doesn't
567   limit users to pubkey and rsa auth (#34378)
568 - bypass the daemon() function in the init script and call initlog directly,
569   because daemon() won't start a daemon it detects is already running (like
570   open connections)
571 - require the version of openssl we had when we were built
572
573 * Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
574 - make do_pam_setcred() smart enough to know when to establish creds and
575   when to reinitialize them
576 - add in a couple of other fixes from Damien for inclusion in the errata
577
578 * Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
579 - update to 2.5.2p2
580 - call setcred() again after initgroups, because the "creds" could actually
581   be group memberships
582
583 * Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
584 - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
585 - don't enable challenge-response by default until we find a way to not
586   have too many userauth requests (we may make up to six pubkey and up to
587   three password attempts as it is)
588 - remove build dependency on rsh to match openssh.com's packages more closely
589
590 * Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
591 - remove dependency on openssl -- would need to be too precise
592
593 * Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
594 - rebuild in new environment
595
596 * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
597 - Revert the patch to move pam_open_session.
598 - Init script and spec file changes from Pekka Savola. (#28750)
599 - Patch sftp to recognize '-o protocol' arguments. (#29540)
600
601 * Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
602 - Chuck the closing patch.
603 - Add a trigger to add host keys for protocol 2 to the config file, now that
604   configuration file syntax requires us to specify it with HostKey if we
605   specify any other HostKey values, which we do.
606
607 * Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
608 - Redo patch to move pam_open_session after the server setuid()s to the user.
609 - Rework the nopam patch to use be picked up by autoconf.
610
611 * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
612 - Update for 2.5.1p1.
613 - Add init script mods from Pekka Savola.
614 - Tweak the init script to match the CVS contrib script more closely.
615 - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
616   adding id_rsa.
617
618 * Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
619 - Update for 2.5.0p1.
620 - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
621 - Resync with parts of Damien Miller's openssh.spec from CVS, including
622   update of x11 askpass to 1.2.0.
623 - Only require openssl (don't prereq) because we generate keys in the init
624   script now.
625
626 * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
627 - Don't open a PAM session until we've forked and become the user (#25690).
628 - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
629   host the user is attempting a login from.
630 - Resync with parts of Damien Miller's openssh.spec from CVS.
631 - Don't expose KbdInt responses in debug messages (from CVS).
632 - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
633
634 * Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
635 - i18n-tweak to initscript.
636
637 * Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
638 - More gettextizing.
639 - Close all files after going into daemon mode (needs more testing).
640 - Extract patch from CVS to handle auth banners (in the client).
641 - Extract patch from CVS to handle compat weirdness.
642
643 * Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
644 - Finish with the gettextizing.
645
646 * Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
647 - Fix a bug in auth2-pam.c (#23877)
648 - Gettextize the init script.
649
650 * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
651 - Incorporate a switch for using PAM configs for 6.x, just in case.
652
653 * Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
654 - Incorporate Bero's changes for a build specifically for rescue CDs.
655
656 * Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
657 - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
658   succeeded, to allow public-key authentication after a failure with "none"
659   authentication.  (#21268)
660
661 * Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
662 - Update to x11-askpass 1.1.1. (#21301)
663 - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
664
665 * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
666 - Merge multiple PAM text messages into subsequent prompts when possible when
667   doing keyboard-interactive authentication.
668
669 * Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
670 - Disable the built-in MD5 password support.  We're using PAM.
671 - Take a crack at doing keyboard-interactive authentication with PAM, and
672   enable use of it in the default client configuration so that the client
673   will try it when the server disallows password authentication.
674 - Build with debugging flags.  Build root policies strip all binaries anyway.
675
676 * Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
677 - Use DESTDIR instead of %%makeinstall.
678 - Remove /usr/X11R6/bin from the path-fixing patch.
679
680 * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
681 - Add the primes file from the latest snapshot to the main package (#20884).
682 - Add the dev package to the prereq list (#19984).
683 - Remove the default path and mimic login's behavior in the server itself.
684
685 * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
686 - Resync with conditional options in Damien Miller's .spec file for an errata.
687 - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
688
689 * Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
690 - Update to OpenSSH 2.3.0p1.
691 - Update to x11-askpass 1.1.0.
692 - Enable keyboard-interactive authentication.
693
694 * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
695 - Update to ssh-askpass-x11 1.0.3.
696 - Change authentication related messages to be private (#19966).
697
698 * Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
699 - Patch ssh-keygen to be able to list signatures for DSA public key files
700   it generates.
701
702 * Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
703 - Add BuildPreReq on /usr/include/security/pam_appl.h to be sure we always
704   build PAM authentication in.
705 - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
706 - Clean out no-longer-used patches.
707 - Patch ssh-add to try to add both identity and id_dsa, and to error only
708   when neither exists.
709
710 * Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
711 - Update x11-askpass to 1.0.2. (#17835)
712 - Add BuildPreReqs for /bin/login and /usr/bin/rsh so that configure will
713   always find them in the right place. (#17909)
714 - Set the default path to be the same as the one supplied by /bin/login, but
715   add /usr/X11R6/bin. (#17909)
716 - Try to handle obsoletion of ssh-server more cleanly.  Package names
717   are different, but init script name isn't. (#17865)
718
719 * Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
720 - Update to 2.2.0p1. (#17835)
721 - Tweak the init script to allow proper restarting. (#18023)
722
723 * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
724 - Update to 20000823 snapshot.
725 - Change subpackage requirements from %%{version} to %%{version}-%%{release}
726 - Back out the pipe patch.
727
728 * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
729 - Update to 2.1.1p4, which includes fixes for config file parsing problems.
730 - Move the init script back.
731 - Add Damien's quick fix for wackiness.
732
733 * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
734 - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
735
736 * Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
737 - Move condrestart to server postun.
738 - Move key generation to init script.
739 - Actually use the right patch for moving the key generation to the init script.
740 - Clean up the init script a bit.
741
742 * Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
743 - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
744
745 * Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
746 - Update to 2.1.1p2.
747 - Use of strtok() considered harmful.
748
749 * Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
750 - Get the build root out of the man pages.
751
752 * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
753 - Add and use condrestart support in the init script.
754 - Add newer initscripts as a prereq.
755
756 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
757 - Build in new environment (release 2)
758 - Move -clients subpackage to Applications/Internet group
759
760 * Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
761 - Update to 2.2.1p1
762
763 * Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
764 - Patch to build with neither RSA nor RSAref.
765 - Miscellaneous FHS-compliance tweaks.
766 - Fix for possibly-compressed man pages.
767
768 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
769 - Updated for new location
770 - Updated for new gnome-ssh-askpass build
771
772 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
773 - Added Jim Knoble's <jmknoble@pobox.com> askpass
774
775 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
776 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
777
778 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
779 - Added 'Obsoletes' directives
780
781 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
782 - Use make install
783 - Subpackages
784
785 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
786 - Added links for slogin
787 - Fixed perms on manpages
788
789 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
790 - Renamed init script
791
792 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
793 - Back to old binary names
794
795 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
796 - Use autoconf
797 - New binary names
798
799 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
800 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
This page took 0.106428 seconds and 5 git commands to generate.