]> andersk Git - openssh.git/blob - openssh.spec
Fix path typo
[openssh.git] / openssh.spec
1 Summary: OpenSSH free Secure Shell (SSH) implementation
2 Name: openssh
3 Version: 1.2pre8
4 Release: 1
5 Packager: Damien Miller <djm@ibs.com.au>
6 Source0: openssh-%{version}-linux.tar.gz
7 Copyright: BSD
8 Group: Applications/Internet
9 BuildRoot: /tmp/openssh-%{version}-buildroot
10
11 %description
12 Ssh (Secure Shell) a program for logging into a remote machine and for
13 executing commands in a remote machine.  It is intended to replace
14 rlogin and rsh, and provide secure encrypted communications between
15 two untrusted hosts over an insecure network.  X11 connections and
16 arbitrary TCP/IP ports can also be forwarded over the secure channel.
17
18 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
19 up to date in terms of security and features, as well as removing all 
20 patented algorithms to seperate libraries (OpenSSL).
21
22 %changelog
23 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
24 - Added links for slogin
25 - Fixed perms on manpages
26 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
27 - Renamed init script
28 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
29 - Back to old binary names
30 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
31 - Use autoconf
32 - New binary names
33 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
34 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
35
36 %prep
37
38 %setup -n openssh
39
40 %build
41
42 ./configure --prefix=/usr --sysconfdir=/etc/ssh
43 make OPT_FLAGS="$RPM_OPT_FLAGS"
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 mkdir -p $RPM_BUILD_ROOT/usr/bin 
48 mkdir -p $RPM_BUILD_ROOT/usr/sbin 
49 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
50 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
51 mkdir -p $RPM_BUILD_ROOT/etc/ssh
52 mkdir -p $RPM_BUILD_ROOT/usr/man/man1
53 mkdir -p $RPM_BUILD_ROOT/usr/man/man8
54
55 install -m644 sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
56 install -m755 sshd.init.redhat $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
57 install -m600 ssh_config $RPM_BUILD_ROOT/etc/ssh/ssh_config
58 install -m600 sshd_config $RPM_BUILD_ROOT/etc/ssh/sshd_config
59
60 install -s -m755 sshd $RPM_BUILD_ROOT/usr/sbin
61 install -s -m755 ssh $RPM_BUILD_ROOT/usr/bin
62 install -s -m755 scp $RPM_BUILD_ROOT/usr/bin
63 install -s -m755 ssh-agent $RPM_BUILD_ROOT/usr/bin
64 install -s -m755 ssh-add $RPM_BUILD_ROOT/usr/bin
65 install -s -m755 ssh-keygen $RPM_BUILD_ROOT/usr/bin
66 ln -s ssh $RPM_BUILD_ROOT/usr/bin/slogin
67
68 install -m644 sshd.8 $RPM_BUILD_ROOT/usr/man/man8
69 install -m644 ssh.1 $RPM_BUILD_ROOT/usr/man/man1
70 install -m644 scp.1 $RPM_BUILD_ROOT/usr/man/man1
71 install -m644 ssh-agent.1 $RPM_BUILD_ROOT/usr/man/man1
72 install -m644 ssh-add.1 $RPM_BUILD_ROOT/usr/man/man1
73 install -m644 ssh-keygen.1 $RPM_BUILD_ROOT/usr/man/man1
74 ln -s ssh.1 $RPM_BUILD_ROOT/usr/man/man1/slogin.1
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post
80 /sbin/chkconfig --add sshd
81 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
82         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
83 fi
84 if test -r /var/run/sshd.pid
85 then
86         /etc/rc.d/init.d/sshd restart >&2
87 fi
88
89 %preun
90 if [ "$1" = 0 ]
91 then
92         /etc/rc.d/init.d/sshd stop >&2
93         /sbin/chkconfig --del sshd
94 fi
95
96 %files
97 %defattr(-,root,root)
98 %doc COPYING.Ylonen ChangeLog ChangeLog.Ylonen OVERVIEW 
99 %doc README README.Ylonen
100 %attr(0755,root,root) /usr/sbin/sshd
101 %attr(0755,root,root) /usr/bin/ssh
102 %attr(0755,root,root) /usr/bin/ssh-agent
103 %attr(0755,root,root) /usr/bin/ssh-keygen
104 %attr(0755,root,root) /usr/bin/ssh-add
105 %attr(0755,root,root) /usr/bin/scp
106 %attr(0755,root,root) /usr/bin/slogin
107
108 %attr(0644,root,root) /usr/man/man8/sshd.8
109 %attr(0644,root,root) /usr/man/man1/ssh.1
110 %attr(0644,root,root) /usr/man/man1/ssh-agent.1
111 %attr(0644,root,root) /usr/man/man1/ssh-keygen.1
112 %attr(0644,root,root) /usr/man/man1/ssh-add.1
113 %attr(0644,root,root) /usr/man/man1/scp.1
114 %attr(0644,root,root) /usr/man/man1/slogin.1
115
116 %attr(0600,root,root) %config /etc/ssh/sshd_config
117 %attr(0600,root,root) %config /etc/pam.d/sshd
118 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
119 %attr(0644,root,root) %config /etc/ssh/ssh_config
120
This page took 0.047556 seconds and 5 git commands to generate.