]> andersk Git - openssh.git/blob - packages/redhat/openssh.spec
- Make IPv4 use the default in RPM packages
[openssh.git] / packages / redhat / openssh.spec
1 # Version of OpenSSH
2 %define oversion 1.2.1pre27
3
4 # Version of ssh-askpass
5 %define aversion 0.99
6
7 Summary: OpenSSH free Secure Shell (SSH) implementation
8 Name: openssh
9 Version: %{oversion}
10 Release: 1
11 Packager: Damien Miller <djm@ibs.com.au>
12 Source0: http://violet.ibs.com.au/openssh/files/openssh-%{oversion}.tar.gz
13 Source1: http://www.pobox.com/~jmknoble/jmk/x11-ssh-askpass-%{aversion}.tar.gz
14 Copyright: BSD
15 Group: Applications/Internet
16 BuildRoot: /tmp/openssh-%{version}-buildroot
17 Obsoletes: ssh
18 PreReq: openssl
19 Requires: openssl
20 BuildPreReq: perl
21 BuildPreReq: openssl-devel
22 BuildPreReq: tcp_wrappers
23 BuildPreReq: gnome-libs-devel
24
25 %package clients
26 Summary: OpenSSH Secure Shell protocol clients
27 Requires: openssh
28 Group: System Environment/Daemons
29 Obsoletes: ssh-clients
30
31 %package server
32 Summary: OpenSSH Secure Shell protocol server (sshd)
33 Group: System Environment/Daemons
34 Obsoletes: ssh-server
35 PreReq: openssh chkconfig >= 0.9
36
37 %package askpass
38 Summary: OpenSSH X11 passphrase dialog
39 Group: Applications/Internet
40 Requires: openssh
41 Obsoletes: ssh-extras
42
43 %package askpass-gnome
44 Summary: OpenSSH GNOME passphrase dialog
45 Group: Applications/Internet
46 Requires: openssh
47 Obsoletes: ssh-extras
48
49 %description
50 Ssh (Secure Shell) a program for logging into a remote machine and for
51 executing commands in a remote machine.  It is intended to replace
52 rlogin and rsh, and provide secure encrypted communications between
53 two untrusted hosts over an insecure network.  X11 connections and
54 arbitrary TCP/IP ports can also be forwarded over the secure channel.
55
56 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
57 up to date in terms of security and features, as well as removing all 
58 patented algorithms to seperate libraries (OpenSSL).
59
60 This package includes the core files necessary for both the OpenSSH
61 client and server.  To make this package useful, you should also
62 install openssh-clients, openssh-server, or both.
63
64 %description clients
65 Ssh (Secure Shell) a program for logging into a remote machine and for
66 executing commands in a remote machine.  It is intended to replace
67 rlogin and rsh, and provide secure encrypted communications between
68 two untrusted hosts over an insecure network.  X11 connections and
69 arbitrary TCP/IP ports can also be forwarded over the secure channel.
70
71 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
72 up to date in terms of security and features, as well as removing all 
73 patented algorithms to seperate libraries (OpenSSL).
74
75 This package includes the clients necessary to make encrypted connections
76 to SSH servers.
77
78 %description server
79 Ssh (Secure Shell) a program for logging into a remote machine and for
80 executing commands in a remote machine.  It is intended to replace
81 rlogin and rsh, and provide secure encrypted communications between
82 two untrusted hosts over an insecure network.  X11 connections and
83 arbitrary TCP/IP ports can also be forwarded over the secure channel.
84
85 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
86 up to date in terms of security and features, as well as removing all 
87 patented algorithms to seperate libraries (OpenSSL).
88
89 This package contains the secure shell daemon. The sshd is the server 
90 part of the secure shell protocol and allows ssh clients to connect to 
91 your host.
92
93 %description askpass
94 Ssh (Secure Shell) a program for logging into a remote machine and for
95 executing commands in a remote machine.  It is intended to replace
96 rlogin and rsh, and provide secure encrypted communications between
97 two untrusted hosts over an insecure network.  X11 connections and
98 arbitrary TCP/IP ports can also be forwarded over the secure channel.
99
100 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
101 up to date in terms of security and features, as well as removing all 
102 patented algorithms to seperate libraries (OpenSSL).
103
104 This package contains Jim Knoble's <jmknoble@pobox.com> X11 passphrase 
105 dialog.
106
107 %description askpass-gnome
108 Ssh (Secure Shell) a program for logging into a remote machine and for
109 executing commands in a remote machine.  It is intended to replace
110 rlogin and rsh, and provide secure encrypted communications between
111 two untrusted hosts over an insecure network.  X11 connections and
112 arbitrary TCP/IP ports can also be forwarded over the secure channel.
113
114 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
115 up to date in terms of security and features, as well as removing all 
116 patented algorithms to seperate libraries (OpenSSL).
117
118 This package contains the GNOME passphrase dialog.
119
120 %changelog
121 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
122 - Added Jim Knoble's <jmknoble@pobox.com> askpass
123 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
124 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
125 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
126 - Added 'Obsoletes' directives
127 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
128 - Use make install
129 - Subpackages
130 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
131 - Added links for slogin
132 - Fixed perms on manpages
133 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
134 - Renamed init script
135 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
136 - Back to old binary names
137 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
138 - Use autoconf
139 - New binary names
140 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
141 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
142
143 %prep
144
145 %setup -a 1
146
147 %build
148
149 CFLAGS="$RPM_OPT_FLAGS" \
150         ./configure --prefix=/usr --sysconfdir=/etc/ssh \
151                     --with-gnome-askpass --with-tcp-wrappers \
152                     --with-ipv4-default
153
154 make
155
156 cd x11-ssh-askpass-%{aversion}
157 xmkmf -a
158 make
159 cd ..
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 make install prefix="$RPM_BUILD_ROOT/usr" sysconfdir="$RPM_BUILD_ROOT/etc/ssh"
164
165 install -d $RPM_BUILD_ROOT/etc/ssh
166 install -d $RPM_BUILD_ROOT/etc/pam.d/
167 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
168 install -m644 packages/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
169 install -m755 packages/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
170
171 install -s x11-ssh-askpass-%{aversion}/ssh-askpass $RPM_BUILD_ROOT/usr/libexec/ssh/x11-ssh-askpass
172 ln -s /usr/libexec/ssh/x11-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/ssh/ssh-askpass
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post server
178 /sbin/chkconfig --add sshd
179 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
180         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
181 fi
182 if test -r /var/run/sshd.pid
183 then
184         /etc/rc.d/init.d/sshd restart >&2
185 fi
186
187 %preun server
188 if [ "$1" = 0 ]
189 then
190         /etc/rc.d/init.d/sshd stop >&2
191         /sbin/chkconfig --del sshd
192 fi
193
194 %files
195 %defattr(-,root,root)
196 %doc ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen INSTALL 
197 %doc CREDITS UPGRADING
198 %attr(0755,root,root) /usr/bin/ssh-keygen
199 %attr(0755,root,root) /usr/bin/scp
200 %attr(0644,root,root) /usr/man/man1/ssh-keygen.1
201 %attr(0644,root,root) /usr/man/man1/scp.1
202 %attr(0755,root,root) %dir /etc/ssh
203 %attr(0755,root,root) %dir /usr/libexec/ssh
204
205 %files clients
206 %defattr(-,root,root)
207 %attr(4755,root,root) /usr/bin/ssh
208 %attr(0755,root,root) /usr/bin/ssh-agent
209 %attr(0755,root,root) /usr/bin/ssh-add
210 %attr(0644,root,root) /usr/man/man1/ssh.1
211 %attr(0644,root,root) /usr/man/man1/ssh-agent.1
212 %attr(0644,root,root) /usr/man/man1/ssh-add.1
213 %attr(0644,root,root) %config(noreplace) /etc/ssh/ssh_config
214 %attr(-,root,root) /usr/bin/slogin
215 %attr(-,root,root) /usr/man/man1/slogin.1
216
217 %files server
218 %defattr(-,root,root)
219 %attr(0755,root,root) /usr/sbin/sshd
220 %attr(0644,root,root) /usr/man/man8/sshd.8
221 %attr(0600,root,root) %config(noreplace) /etc/ssh/sshd_config
222 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
223 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
224
225 %files askpass
226 %defattr(-,root,root)
227 %doc x11-ssh-askpass-%{aversion}/README
228 %doc x11-ssh-askpass-%{aversion}/ChangeLog
229 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
230 %attr(0755,root,root) /usr/libexec/ssh/ssh-askpass
231 %attr(0755,root,root) /usr/libexec/ssh/x11-ssh-askpass
232
233 %files askpass-gnome
234 %defattr(-,root,root)
235 %attr(0755,root,root) /usr/libexec/ssh/gnome-ssh-askpass
This page took 0.134086 seconds and 5 git commands to generate.