]> andersk Git - openssh.git/blob - contrib/suse/openssh.spec
- (djm) Crank RPM spec versions
[openssh.git] / contrib / suse / openssh.spec
1 Summary: OpenSSH, a free Secure Shell (SSH) protocol implementation
2 Name: openssh
3 Version: 3.8p1
4 URL: http://www.openssh.com/
5 Release: 1
6 Source0: openssh-%{version}.tar.gz
7 Copyright: BSD
8 Group: Applications/Internet
9 BuildRoot: /tmp/openssh-%{version}-buildroot
10 PreReq: openssl
11 Obsoletes: ssh
12 #
13 # (Build[ing] Prereq[uisites] only work for RPM 2.95 and newer.)
14 # building prerequisites -- stuff for
15 #   OpenSSL (openssl-devel),
16 #   TCP Wrappers (nkitb),
17 #   and Gnome (glibdev, gtkdev, and gnlibsd)
18 #
19 BuildPrereq: openssl
20 BuildPrereq: nkitb
21 BuildPrereq: glibdev
22 BuildPrereq: gtkdev
23 BuildPrereq: gnlibsd
24
25 %description
26 Ssh (Secure Shell) a program for logging into a remote machine and for
27 executing commands in a remote machine.  It is intended to replace
28 rlogin and rsh, and provide secure encrypted communications between
29 two untrusted hosts over an insecure network.  X11 connections and
30 arbitrary TCP/IP ports can also be forwarded over the secure channel.
31
32 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
33 up to date in terms of security and features, as well as removing all
34 patented algorithms to seperate libraries (OpenSSL).
35
36 This package includes all files necessary for both the OpenSSH
37 client and server. Additionally, this package contains the GNOME
38 passphrase dialog.
39
40 %changelog
41 * Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
42 - Glob manpages to catch compressed files
43 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
44 - Updated for new location
45 - Updated for new gnome-ssh-askpass build
46 * Sun Dec 26 1999 Chris Saia <csaia@wtower.com>
47 - Made symlink to gnome-ssh-askpass called ssh-askpass
48 * Wed Nov 24 1999 Chris Saia <csaia@wtower.com>
49 - Removed patches that included /etc/pam.d/sshd, /sbin/init.d/rc.sshd, and
50   /var/adm/fillup-templates/rc.config.sshd, since Damien merged these into
51   his released tarfile
52 - Changed permissions on ssh_config in the install procedure to 644 from 600
53   even though it was correct in the %files section and thus right in the RPMs
54 - Postinstall script for the server now only prints "Generating SSH host
55   key..." if we need to actually do this, in order to eliminate a confusing
56   message if an SSH host key is already in place
57 - Marked all manual pages as %doc(umentation)
58 * Mon Nov 22 1999 Chris Saia <csaia@wtower.com>
59 - Added flag to configure daemon with TCP Wrappers support
60 - Added building prerequisites (works in RPM 3.0 and newer)
61 * Thu Nov 18 1999 Chris Saia <csaia@wtower.com>
62 - Made this package correct for SuSE.
63 - Changed instances of pam_pwdb.so to pam_unix.so, since it works more properly
64   with SuSE, and lib_pwdb.so isn't installed by default.
65 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
66 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
67 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
68 - Added 'Obsoletes' directives
69 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
70 - Use make install
71 - Subpackages
72 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
73 - Added links for slogin
74 - Fixed perms on manpages
75 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
76 - Renamed init script
77 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
78 - Back to old binary names
79 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
80 - Use autoconf
81 - New binary names
82 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
83 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
84
85 %prep
86
87 %setup -q
88
89 %build
90 CFLAGS="$RPM_OPT_FLAGS" \
91 ./configure     --prefix=/usr \
92                 --sysconfdir=/etc/ssh \
93                 --datadir=/usr/share/openssh \
94                 --with-pam \
95                 --with-gnome-askpass \
96                 --with-tcp-wrappers \
97                 --with-ipv4-default \
98                 --libexecdir=/usr/lib/ssh
99 make
100
101 cd contrib
102 gcc -O -g `gnome-config --cflags gnome gnomeui` \
103         gnome-ssh-askpass.c -o gnome-ssh-askpass \
104         `gnome-config --libs gnome gnomeui`
105 cd ..
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 make install DESTDIR=$RPM_BUILD_ROOT/
110 install -d $RPM_BUILD_ROOT/etc/ssh/
111 install -d $RPM_BUILD_ROOT/etc/pam.d/
112 install -d $RPM_BUILD_ROOT/sbin/init.d/
113 install -d $RPM_BUILD_ROOT/var/adm/fillup-templates
114 install -d $RPM_BUILD_ROOT/usr/lib/ssh
115 install -m644 contrib/sshd.pam.generic $RPM_BUILD_ROOT/etc/pam.d/sshd
116 install -m744 contrib/suse/rc.sshd $RPM_BUILD_ROOT/sbin/init.d/sshd
117 ln -s ../../sbin/init.d/sshd $RPM_BUILD_ROOT/usr/sbin/rcsshd
118 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT/usr/lib/ssh/gnome-ssh-askpass
119 ln -s gnome-ssh-askpass $RPM_BUILD_ROOT/usr/lib/ssh/ssh-askpass
120 install -m744 contrib/suse/rc.config.sshd \
121    $RPM_BUILD_ROOT/var/adm/fillup-templates
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 if [ "$1" = 1 ]; then
128   echo "Creating SSH stop/start scripts in the rc directories..."
129   ln -s ../sshd /sbin/init.d/rc2.d/K20sshd
130   ln -s ../sshd /sbin/init.d/rc2.d/S20sshd
131   ln -s ../sshd /sbin/init.d/rc3.d/K20sshd
132   ln -s ../sshd /sbin/init.d/rc3.d/S20sshd
133 fi
134 echo "Updating /etc/rc.config..."
135 if [ -x /bin/fillup ] ; then
136   /bin/fillup -q -d = etc/rc.config var/adm/fillup-templates/rc.config.sshd
137 else
138   echo "ERROR: fillup not found.  This should NOT happen in SuSE Linux."
139   echo "Update /etc/rc.config by hand from the following template file:"
140   echo "  /var/adm/fillup-templates/rc.config.sshd"
141 fi
142 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
143         echo "Generating SSH host key..."
144         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
145 fi
146 if [ ! -f /etc/ssh/ssh_host_dsa_key -o ! -s /etc/ssh/ssh_host_dsa_key ]; then
147         echo "Generating SSH DSA host key..."
148         /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N '' >&2
149 fi
150 if test -r /var/run/sshd.pid
151 then
152         echo "Restarting the running SSH daemon..."
153         /usr/sbin/rcsshd restart >&2
154 fi
155
156 %preun
157 if [ "$1" = 0 ]
158 then
159         echo "Stopping the SSH daemon..."
160         /usr/sbin/rcsshd stop >&2
161         echo "Removing SSH stop/start scripts from the rc directories..."
162         rm /sbin/init.d/rc2.d/K20sshd
163         rm /sbin/init.d/rc2.d/S20sshd
164         rm /sbin/init.d/rc3.d/K20sshd
165         rm /sbin/init.d/rc3.d/S20sshd
166 fi
167
168 %files
169 %defattr(-,root,root)
170 %doc ChangeLog OVERVIEW README*
171 %doc RFC.nroff TODO CREDITS LICENCE
172 %attr(0755,root,root) %dir /etc/ssh
173 %attr(0644,root,root) %config /etc/ssh/ssh_config
174 %attr(0600,root,root) %config /etc/ssh/sshd_config
175 %attr(0600,root,root) %config /etc/ssh/moduli
176 %attr(0644,root,root) %config /etc/pam.d/sshd
177 %attr(0755,root,root) %config /sbin/init.d/sshd
178 %attr(0755,root,root) /usr/bin/ssh-keygen
179 %attr(0755,root,root) /usr/bin/scp
180 %attr(4755,root,root) /usr/bin/ssh
181 %attr(-,root,root) /usr/bin/slogin
182 %attr(0755,root,root) /usr/bin/ssh-agent
183 %attr(0755,root,root) /usr/bin/ssh-add
184 %attr(0755,root,root) /usr/bin/ssh-keyscan
185 %attr(0755,root,root) /usr/bin/sftp
186 %attr(0755,root,root) /usr/sbin/sshd
187 %attr(-,root,root) /usr/sbin/rcsshd
188 %attr(0755,root,root) %dir /usr/lib/ssh
189 %attr(0755,root,root) /usr/lib/ssh/ssh-askpass
190 %attr(0755,root,root) /usr/lib/ssh/gnome-ssh-askpass
191 %attr(0644,root,root) %doc /usr/man/man1/scp.1*
192 %attr(0644,root,root) %doc /usr/man/man1/ssh.1*
193 %attr(-,root,root) %doc /usr/man/man1/slogin.1*
194 %attr(0644,root,root) %doc /usr/man/man1/ssh-agent.1*
195 %attr(0644,root,root) %doc /usr/man/man1/ssh-add.1*
196 %attr(0644,root,root) %doc /usr/man/man1/ssh-keygen.1*
197 %attr(0644,root,root) %doc /usr/man/man8/sshd.8*
198 %attr(0644,root,root) /var/adm/fillup-templates/rc.config.sshd
199
This page took 0.060515 seconds and 5 git commands to generate.