]> andersk Git - openssh.git/blob - packages/redhat/openssh.spec
Prepare for pre24
[openssh.git] / packages / redhat / openssh.spec
1 # Version of OpenSSH
2 %define oversion 1.2.1pre24
3
4 # Version of ssh-askpass
5 %define aversion 0.99
6
7 Summary: OpenSSH free Secure Shell (SSH) implementation
8 Name: openssh
9 Version: %{oversion}
10 Release: 1
11 Packager: Damien Miller <djm@ibs.com.au>
12 Source0: http://violet.ibs.com.au/openssh/files/openssh-%{oversion}.tar.gz
13 Source1: http://www.pobox.com/~jmknoble/jmk/x11-ssh-askpass-%{aversion}.tar.gz
14 Copyright: BSD
15 Group: Applications/Internet
16 BuildRoot: /tmp/openssh-%{version}-buildroot
17 Obsoletes: ssh
18 Requires: openssl
19 BuildPreReq: perl
20 BuildPreReq: openssl-devel
21 BuildPreReq: tcp_wrappers
22 BuildPreReq: gnome-libs-devel
23
24 %package clients
25 Summary: OpenSSH Secure Shell protocol clients
26 Requires: openssh
27 Group: System Environment/Daemons
28 Obsoletes: ssh-clients
29
30 %package server
31 Summary: OpenSSH Secure Shell protocol server (sshd)
32 Group: System Environment/Daemons
33 Obsoletes: ssh-server
34 PreReq: openssh chkconfig >= 0.9
35
36 %package askpass
37 Summary: OpenSSH X11 passphrase dialog
38 Group: Applications/Internet
39 Requires: openssh
40 Obsoletes: ssh-extras
41
42 %package askpass-gnome
43 Summary: OpenSSH GNOME passphrase dialog
44 Group: Applications/Internet
45 Requires: openssh
46 Obsoletes: ssh-extras
47
48 %description
49 Ssh (Secure Shell) a program for logging into a remote machine and for
50 executing commands in a remote machine.  It is intended to replace
51 rlogin and rsh, and provide secure encrypted communications between
52 two untrusted hosts over an insecure network.  X11 connections and
53 arbitrary TCP/IP ports can also be forwarded over the secure channel.
54
55 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
56 up to date in terms of security and features, as well as removing all 
57 patented algorithms to seperate libraries (OpenSSL).
58
59 This package includes the core files necessary for both the OpenSSH
60 client and server.  To make this package useful, you should also
61 install openssh-clients, openssh-server, or both.
62
63 %description clients
64 Ssh (Secure Shell) a program for logging into a remote machine and for
65 executing commands in a remote machine.  It is intended to replace
66 rlogin and rsh, and provide secure encrypted communications between
67 two untrusted hosts over an insecure network.  X11 connections and
68 arbitrary TCP/IP ports can also be forwarded over the secure channel.
69
70 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
71 up to date in terms of security and features, as well as removing all 
72 patented algorithms to seperate libraries (OpenSSL).
73
74 This package includes the clients necessary to make encrypted connections
75 to SSH servers.
76
77 %description server
78 Ssh (Secure Shell) a program for logging into a remote machine and for
79 executing commands in a remote machine.  It is intended to replace
80 rlogin and rsh, and provide secure encrypted communications between
81 two untrusted hosts over an insecure network.  X11 connections and
82 arbitrary TCP/IP ports can also be forwarded over the secure channel.
83
84 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
85 up to date in terms of security and features, as well as removing all 
86 patented algorithms to seperate libraries (OpenSSL).
87
88 This package contains the secure shell daemon. The sshd is the server 
89 part of the secure shell protocol and allows ssh clients to connect to 
90 your host.
91
92 %description askpass
93 Ssh (Secure Shell) a program for logging into a remote machine and for
94 executing commands in a remote machine.  It is intended to replace
95 rlogin and rsh, and provide secure encrypted communications between
96 two untrusted hosts over an insecure network.  X11 connections and
97 arbitrary TCP/IP ports can also be forwarded over the secure channel.
98
99 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
100 up to date in terms of security and features, as well as removing all 
101 patented algorithms to seperate libraries (OpenSSL).
102
103 This package contains Jim Knoble's <jmknoble@pobox.com> X11 passphrase 
104 dialog.
105
106 %description askpass-gnome
107 Ssh (Secure Shell) a program for logging into a remote machine and for
108 executing commands in a remote machine.  It is intended to replace
109 rlogin and rsh, and provide secure encrypted communications between
110 two untrusted hosts over an insecure network.  X11 connections and
111 arbitrary TCP/IP ports can also be forwarded over the secure channel.
112
113 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
114 up to date in terms of security and features, as well as removing all 
115 patented algorithms to seperate libraries (OpenSSL).
116
117 This package contains the GNOME passphrase dialog.
118
119 %changelog
120 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
121 - Added Jim Knoble's <jmknoble@pobox.com> askpass
122 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
123 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
124 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
125 - Added 'Obsoletes' directives
126 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
127 - Use make install
128 - Subpackages
129 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
130 - Added links for slogin
131 - Fixed perms on manpages
132 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
133 - Renamed init script
134 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
135 - Back to old binary names
136 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
137 - Use autoconf
138 - New binary names
139 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
140 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
141
142 %prep
143
144 %setup -a 1
145
146 %build
147
148 CFLAGS="$RPM_OPT_FLAGS" \
149         ./configure --prefix=/usr --sysconfdir=/etc/ssh \
150                     --with-gnome-askpass --with-tcp-wrappers
151
152 make
153
154 cd x11-ssh-askpass-%{aversion}
155 xmkmf -a
156 make
157 cd ..
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 make install prefix="$RPM_BUILD_ROOT/usr"
162
163 install -d $RPM_BUILD_ROOT/etc/ssh
164 install -d $RPM_BUILD_ROOT/etc/pam.d/
165 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
166 install -m644 packages/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
167 install -m755 packages/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
168 install -m600 ssh_config $RPM_BUILD_ROOT/etc/ssh/ssh_config
169 install -m600 sshd_config $RPM_BUILD_ROOT/etc/ssh/sshd_config
170
171 install -s x11-ssh-askpass-%{aversion}/ssh-askpass $RPM_BUILD_ROOT/usr/libexec/ssh/x11-ssh-askpass
172 ln -s /usr/libexec/ssh/x11-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/ssh/ssh-askpass
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post server
178 /sbin/chkconfig --add sshd
179 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
180         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
181 fi
182 if test -r /var/run/sshd.pid
183 then
184         /etc/rc.d/init.d/sshd restart >&2
185 fi
186
187 %preun server
188 if [ "$1" = 0 ]
189 then
190         /etc/rc.d/init.d/sshd stop >&2
191         /sbin/chkconfig --del sshd
192 fi
193
194 %files
195 %defattr(-,root,root)
196 %doc ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen INSTALL 
197 %doc CREDITS UPGRADING
198 %attr(0755,root,root) /usr/bin/ssh-keygen
199 %attr(0755,root,root) /usr/bin/scp
200 %attr(0644,root,root) /usr/man/man1/ssh-keygen.1
201 %attr(0644,root,root) /usr/man/man1/scp.1
202 %attr(0755,root,root) %dir /etc/ssh
203 %attr(0755,root,root) %dir /usr/libexec/ssh
204
205 %files clients
206 %defattr(-,root,root)
207 %attr(4755,root,root) /usr/bin/ssh
208 %attr(0755,root,root) /usr/bin/ssh-agent
209 %attr(0755,root,root) /usr/bin/ssh-add
210 %attr(0644,root,root) /usr/man/man1/ssh.1
211 %attr(0644,root,root) /usr/man/man1/ssh-agent.1
212 %attr(0644,root,root) /usr/man/man1/ssh-add.1
213 %attr(0644,root,root) %config(noreplace) /etc/ssh/ssh_config
214 %attr(-,root,root) /usr/bin/slogin
215 %attr(-,root,root) /usr/man/man1/slogin.1
216
217 %files server
218 %defattr(-,root,root)
219 %attr(0755,root,root) /usr/sbin/sshd
220 %attr(0644,root,root) /usr/man/man8/sshd.8
221 %attr(0600,root,root) %config(noreplace) /etc/ssh/sshd_config
222 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
223 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
224
225 %files askpass
226 %defattr(-,root,root)
227 %doc x11-ssh-askpass-%{aversion}/README
228 %doc x11-ssh-askpass-%{aversion}/ChangeLog
229 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
230 %attr(0755,root,root) /usr/libexec/ssh/ssh-askpass
231 %attr(0755,root,root) /usr/libexec/ssh/x11-ssh-askpass
232
233 %files askpass-gnome
234 %defattr(-,root,root)
235 %attr(0755,root,root) /usr/libexec/ssh/gnome-ssh-askpass
This page took 0.119557 seconds and 5 git commands to generate.