]> andersk Git - openssh.git/blob - contrib/redhat/openssh.spec
NB: big update - may break stuff. Please test!
[openssh.git] / contrib / redhat / openssh.spec
1 # Version of OpenSSH
2 %define oversion 2.3.1p1
3
4 # Version of ssh-askpass
5 %define aversion 1.1.1
6
7 # Do we want to disable building of x11-askpass? (1=yes 0=no)
8 %define no_x11_askpass 0
9
10 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
11 %define no_gnome_askpass 0
12
13 Summary: OpenSSH free Secure Shell (SSH) implementation
14 Name: openssh
15 Version: %{oversion}
16 Release: 1
17 Packager: Damien Miller <djm@mindrot.org>
18 URL: http://www.openssh.com/
19 Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{oversion}.tar.gz
20 %if ! %{no_x11_askpass}
21 Source1: http://www.jmknoble.cx/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz 
22 %endif
23 Copyright: BSD
24 Group: Applications/Internet
25 BuildRoot: /tmp/openssh-%{version}-buildroot
26 Obsoletes: ssh
27 PreReq: openssl >= 0.9.5a
28 Requires: openssl >= 0.9.5a
29 BuildPreReq: perl, openssl-devel, tcp_wrappers
30 BuildPreReq: /bin/login, /usr/bin/rsh, /usr/include/security/pam_appl.h
31 %if ! %{no_gnome_askpass}
32 BuildPreReq: gnome-libs-devel
33 %endif
34
35 %package clients
36 Summary: OpenSSH Secure Shell protocol clients
37 Requires: openssh = %{version}-%{release}
38 Group: Applications/Internet
39 Obsoletes: ssh-clients
40
41 %package server
42 Summary: OpenSSH Secure Shell protocol server (sshd)
43 Group: System Environment/Daemons
44 Obsoletes: ssh-server
45 PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
46 Requires: initscripts >= 4.16
47
48 %package askpass
49 Summary: OpenSSH X11 passphrase dialog
50 Group: Applications/Internet
51 Requires: openssh = %{version}-%{release}
52 Obsoletes: ssh-extras
53
54 %package askpass-gnome
55 Summary: OpenSSH GNOME passphrase dialog
56 Group: Applications/Internet
57 Requires: openssh = %{version}-%{release}
58 Obsoletes: ssh-extras
59
60 %description
61 Ssh (Secure Shell) a program for logging into a remote machine and for
62 executing commands in a remote machine.  It is intended to replace
63 rlogin and rsh, and provide secure encrypted communications between
64 two untrusted hosts over an insecure network.  X11 connections and
65 arbitrary TCP/IP ports can also be forwarded over the secure channel.
66
67 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
68 up to date in terms of security and features, as well as removing all 
69 patented algorithms to separate libraries (OpenSSL).
70
71 This package includes the core files necessary for both the OpenSSH
72 client and server.  To make this package useful, you should also
73 install openssh-clients, openssh-server, or both.
74
75 %description clients
76 Ssh (Secure Shell) a program for logging into a remote machine and for
77 executing commands in a remote machine.  It is intended to replace
78 rlogin and rsh, and provide secure encrypted communications between
79 two untrusted hosts over an insecure network.  X11 connections and
80 arbitrary TCP/IP ports can also be forwarded over the secure channel.
81
82 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
83 up to date in terms of security and features, as well as removing all 
84 patented algorithms to separate libraries (OpenSSL).
85
86 This package includes the clients necessary to make encrypted connections
87 to SSH servers.
88
89 %description server
90 Ssh (Secure Shell) a program for logging into a remote machine and for
91 executing commands in a remote machine.  It is intended to replace
92 rlogin and rsh, and provide secure encrypted communications between
93 two untrusted hosts over an insecure network.  X11 connections and
94 arbitrary TCP/IP ports can also be forwarded over the secure channel.
95
96 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
97 up to date in terms of security and features, as well as removing all 
98 patented algorithms to separate libraries (OpenSSL).
99
100 This package contains the secure shell daemon. The sshd is the server 
101 part of the secure shell protocol and allows ssh clients to connect to 
102 your host.
103
104 %description askpass
105 Ssh (Secure Shell) a program for logging into a remote machine and for
106 executing commands in a remote machine.  It is intended to replace
107 rlogin and rsh, and provide secure encrypted communications between
108 two untrusted hosts over an insecure network.  X11 connections and
109 arbitrary TCP/IP ports can also be forwarded over the secure channel.
110
111 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
112 up to date in terms of security and features, as well as removing all 
113 patented algorithms to separate libraries (OpenSSL).
114
115 This package contains Jim Knoble's <jmknoble@jmknoble.cx> X11 passphrase 
116 dialog.
117
118 %description askpass-gnome
119 Ssh (Secure Shell) a program for logging into a remote machine and for
120 executing commands in a remote machine.  It is intended to replace
121 rlogin and rsh, and provide secure encrypted communications between
122 two untrusted hosts over an insecure network.  X11 connections and
123 arbitrary TCP/IP ports can also be forwarded over the secure channel.
124
125 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
126 up to date in terms of security and features, as well as removing all 
127 patented algorithms to separate libraries (OpenSSL).
128
129 This package contains the GNOME passphrase dialog.
130
131 %prep
132
133 %if ! %{no_x11_askpass}
134 %setup -q -a 1
135 %else
136 %setup -q
137 %endif
138
139 %build
140
141 %define _sysconfdir /etc/ssh
142
143 %configure \
144         --libexecdir=%{_libexecdir}/openssh \
145         --with-pam \
146         --with-tcp-wrappers \
147         --with-ipv4-default \
148         --with-rsh=/usr/bin/rsh \
149         --with-default-path=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
150
151 make
152
153 %if ! %{no_x11_askpass}
154 pushd x11-ssh-askpass-%{aversion}
155 xmkmf -a
156 make
157 popd
158 %endif
159
160 %if ! %{no_gnome_askpass}
161 pushd contrib
162 gcc -O -g `gnome-config --cflags gnome gnomeui` \
163         gnome-ssh-askpass.c -o gnome-ssh-askpass \
164         `gnome-config --libs gnome gnomeui`
165 popd
166 %endif
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 %{makeinstall} \
171         libexecdir=$RPM_BUILD_ROOT%{_libexecdir}/openssh \
172         DESTDIR=/ # Hack to disable key generation
173
174
175 install -d $RPM_BUILD_ROOT/etc/pam.d/
176 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
177 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
178 install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
179 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
180
181 %if ! %{no_x11_askpass}
182 install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/openssh/x11-ssh-askpass
183 ln -s /usr/libexec/openssh/x11-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/openssh/ssh-askpass
184 %endif
185
186 %if ! %{no_gnome_askpass}
187 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/openssh/gnome-ssh-askpass
188 %endif
189
190 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post server
196 /sbin/chkconfig --add sshd
197 if test -r /var/run/sshd.pid ; then
198         /etc/rc.d/init.d/sshd restart >&2
199 fi
200
201 %preun server
202 if [ "$1" = 0 ] ; then
203         /etc/rc.d/init.d/sshd stop >&2
204         /sbin/chkconfig --del sshd
205 fi
206
207 %files
208 %defattr(-,root,root)
209 %doc ChangeLog OVERVIEW README* INSTALL 
210 %doc CREDITS LICENCE
211 %attr(0755,root,root) %{_bindir}/ssh-keygen
212 %attr(0755,root,root) %{_bindir}/scp
213 %attr(0755,root,root) %{_bindir}/ssh-keyscan
214 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
215 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
216 %attr(0644,root,root) %{_mandir}/man1/scp.1*
217 %attr(0755,root,root) %dir %{_sysconfdir}
218 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/primes
219 %attr(0755,root,root) %dir %{_libexecdir}/openssh
220
221 %files clients
222 %defattr(-,root,root)
223 %attr(4755,root,root) %{_bindir}/ssh
224 %attr(0755,root,root) %{_bindir}/ssh-agent
225 %attr(0755,root,root) %{_bindir}/ssh-add
226 %attr(0755,root,root) %{_bindir}/ssh-keyscan
227 %attr(0755,root,root) %{_bindir}/sftp
228 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
229 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
230 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
231 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
232 %attr(0644,root,root) %{_mandir}/man1/sftp.1*
233 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh_config
234 %attr(-,root,root) %{_bindir}/slogin
235 %attr(-,root,root) %{_mandir}/man1/slogin.1*
236
237 %files server
238 %defattr(-,root,root)
239 %attr(0755,root,root) %{_sbindir}/sshd
240 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
241 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
242 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
243 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sshd_config
244 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
245 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
246
247 %if ! %{no_x11_askpass}
248 %files askpass
249 %defattr(-,root,root)
250 %doc x11-ssh-askpass-%{aversion}/README
251 %doc x11-ssh-askpass-%{aversion}/ChangeLog
252 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
253 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
254 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
255 %endif
256
257 %if ! %{no_gnome_askpass}
258 %files askpass-gnome
259 %defattr(-,root,root)
260 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
261 %endif
262
263 %changelog
264 * Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
265 - Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the 
266   Redhat 7.0 spec file
267 * Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
268 - Use RPM configure macro
269 * Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
270 - Some surgery to sshd.init (generate keys at runtime)
271 - Cleanup of groups and removal of keygen calls
272 * Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
273 - Make building of X11-askpass and gnome-askpass optional
274 * Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
275 - Glob manpages to catch compressed files
276 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
277 - Updated for new location
278 - Updated for new gnome-ssh-askpass build
279 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
280 - Added Jim Knoble's <jmknoble@pobox.com> askpass
281 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
282 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
283 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
284 - Added 'Obsoletes' directives
285 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
286 - Use make install
287 - Subpackages
288 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
289 - Added links for slogin
290 - Fixed perms on manpages
291 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
292 - Renamed init script
293 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
294 - Back to old binary names
295 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
296 - Use autoconf
297 - New binary names
298 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
299 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
300
This page took 0.185047 seconds and 5 git commands to generate.