]> andersk Git - openssh.git/blob - packages/redhat/openssh.spec
Prepare for 1.2.1pre18
[openssh.git] / packages / redhat / openssh.spec
1 Summary: OpenSSH free Secure Shell (SSH) implementation
2 Name: openssh
3 Version: 1.2.1pre18
4 Release: 1
5 Packager: Damien Miller <djm@ibs.com.au>
6 Source0: openssh-%{version}.tar.gz
7 Copyright: BSD
8 Group: Applications/Internet
9 BuildRoot: /tmp/openssh-%{version}-buildroot
10 Obsoletes: ssh
11 PreReq: openssl
12 BuildPreReq: openssl
13 BuildPreReq: tcp_wrappers
14 BuildPreReq: gnome-libs
15
16 %package clients
17 Summary: OpenSSH Secure Shell protocol clients
18 Requires: openssh
19 Group: System Environment/Daemons
20 Obsoletes: ssh-clients
21
22 %package server
23 Summary: OpenSSH Secure Shell protocol server (sshd)
24 Requires: openssh chkconfig >= 0.9
25 Group: System Environment/Daemons
26 Obsoletes: ssh-server
27
28 %package askpass
29 Summary: OpenSSH GNOME passphrase dialog
30 Group: Applications/Internet
31 Requires: openssh
32 Obsoletes: ssh-extras
33 Obsoletes: ssh-askpass
34
35 %description
36 Ssh (Secure Shell) a program for logging into a remote machine and for
37 executing commands in a remote machine.  It is intended to replace
38 rlogin and rsh, and provide secure encrypted communications between
39 two untrusted hosts over an insecure network.  X11 connections and
40 arbitrary TCP/IP ports can also be forwarded over the secure channel.
41
42 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
43 up to date in terms of security and features, as well as removing all 
44 patented algorithms to seperate libraries (OpenSSL).
45
46 This package includes the core files necessary for both the OpenSSH
47 client and server.  To make this package useful, you should also
48 install openssh-clients, openssh-server, or both.
49
50 %description clients
51 Ssh (Secure Shell) a program for logging into a remote machine and for
52 executing commands in a remote machine.  It is intended to replace
53 rlogin and rsh, and provide secure encrypted communications between
54 two untrusted hosts over an insecure network.  X11 connections and
55 arbitrary TCP/IP ports can also be forwarded over the secure channel.
56
57 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
58 up to date in terms of security and features, as well as removing all 
59 patented algorithms to seperate libraries (OpenSSL).
60
61 This package includes the clients necessary to make encrypted connections
62 to SSH servers.
63
64 %description server
65 Ssh (Secure Shell) a program for logging into a remote machine and for
66 executing commands in a remote machine.  It is intended to replace
67 rlogin and rsh, and provide secure encrypted communications between
68 two untrusted hosts over an insecure network.  X11 connections and
69 arbitrary TCP/IP ports can also be forwarded over the secure channel.
70
71 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
72 up to date in terms of security and features, as well as removing all 
73 patented algorithms to seperate libraries (OpenSSL).
74
75 This package contains the secure shell daemon. The sshd is the server 
76 part of the secure shell protocol and allows ssh clients to connect to 
77 your host.
78
79 %description askpass
80 Ssh (Secure Shell) a program for logging into a remote machine and for
81 executing commands in a remote machine.  It is intended to replace
82 rlogin and rsh, and provide secure encrypted communications between
83 two untrusted hosts over an insecure network.  X11 connections and
84 arbitrary TCP/IP ports can also be forwarded over the secure channel.
85
86 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
87 up to date in terms of security and features, as well as removing all 
88 patented algorithms to seperate libraries (OpenSSL).
89
90 This package contains the GNOME passphrase dialog.
91
92 %changelog
93 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
94 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
95 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
96 - Added 'Obsoletes' directives
97 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
98 - Use make install
99 - Subpackages
100 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
101 - Added links for slogin
102 - Fixed perms on manpages
103 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
104 - Renamed init script
105 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
106 - Back to old binary names
107 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
108 - Use autoconf
109 - New binary names
110 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
111 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
112
113 %prep
114
115 %setup -q
116
117 %build
118
119 CFLAGS="$RPM_OPT_FLAGS" \
120         ./configure --prefix=/usr --sysconfdir=/etc/ssh \
121                     --with-gnome-askpass --with-tcp-wrappers
122
123 make
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 make install prefix="$RPM_BUILD_ROOT/usr"
128
129 install -d $RPM_BUILD_ROOT/etc/ssh
130 install -d $RPM_BUILD_ROOT/etc/pam.d/
131 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
132 install -m644 packages/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
133 install -m755 packages/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
134 install -m600 ssh_config $RPM_BUILD_ROOT/etc/ssh/ssh_config
135 install -m600 sshd_config $RPM_BUILD_ROOT/etc/ssh/sshd_config
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post server
141 /sbin/chkconfig --add sshd
142 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
143         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
144 fi
145 if test -r /var/run/sshd.pid
146 then
147         /etc/rc.d/init.d/sshd restart >&2
148 fi
149
150 %preun server
151 if [ "$1" = 0 ]
152 then
153         /etc/rc.d/init.d/sshd stop >&2
154         /sbin/chkconfig --del sshd
155 fi
156
157 %files
158 %defattr(-,root,root)
159 %doc ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen INSTALL UPGRADING
160 %attr(0755,root,root) /usr/bin/ssh-keygen
161 %attr(0755,root,root) /usr/bin/scp
162 %attr(0644,root,root) /usr/man/man1/ssh-keygen.1
163 %attr(0644,root,root) /usr/man/man1/scp.1
164 %attr(0755,root,root) %dir /etc/ssh
165
166 %files clients
167 %defattr(-,root,root)
168 %attr(4755,root,root) /usr/bin/ssh
169 %attr(0755,root,root) /usr/bin/ssh-agent
170 %attr(0755,root,root) /usr/bin/ssh-add
171 %attr(0644,root,root) /usr/man/man1/ssh.1
172 %attr(0644,root,root) /usr/man/man1/ssh-agent.1
173 %attr(0644,root,root) /usr/man/man1/ssh-add.1
174 %attr(0644,root,root) %config(noreplace) /etc/ssh/ssh_config
175 %attr(-,root,root) /usr/bin/slogin
176 %attr(-,root,root) /usr/man/man1/slogin.1
177
178 %files server
179 %defattr(-,root,root)
180 %attr(0755,root,root) /usr/sbin/sshd
181 %attr(0644,root,root) /usr/man/man8/sshd.8
182 %attr(0600,root,root) %config(noreplace) /etc/ssh/sshd_config
183 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
184 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
185
186 %files askpass
187 %defattr(-,root,root)
188 %attr(0755,root,root) /usr/libexec/ssh/ssh-askpass
189 %attr(0755,root,root) %dir /usr/libexec/ssh
190
This page took 0.299452 seconds and 5 git commands to generate.