]> andersk Git - openssh.git/blob - openssh.spec
Doc and spec updates
[openssh.git] / openssh.spec
1 Summary: OpenSSH free Secure Shell (SSH) implementation
2 Name: openssh
3 Version: 1.2pre10
4 Release: 1
5 Packager: Damien Miller <djm@ibs.com.au>
6 Source0: openssh-%{version}.tar.gz
7 Copyright: BSD
8 Group: Applications/Internet
9 BuildRoot: /tmp/openssh-%{version}-buildroot
10
11 %package server
12 Summary: Secure Shell protocol server (sshd)
13 Requires: openssh chkconfig >= 0.9
14 Group: System Environment/Daemons
15
16 %package askpass
17 Summary: GNOME passphrase dialog
18 Group: Applications/Internet
19 Requires: openssh
20
21 %description
22 Ssh (Secure Shell) a program for logging into a remote machine and for
23 executing commands in a remote machine.  It is intended to replace
24 rlogin and rsh, and provide secure encrypted communications between
25 two untrusted hosts over an insecure network.  X11 connections and
26 arbitrary TCP/IP ports can also be forwarded over the secure channel.
27
28 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
29 up to date in terms of security and features, as well as removing all 
30 patented algorithms to seperate libraries (OpenSSL).
31
32 This package includes the clients necessary to make encrypted connections
33 to SSH servers.
34
35 %description server
36 Ssh (Secure Shell) a program for logging into a remote machine and for
37 executing commands in a remote machine.  It is intended to replace
38 rlogin and rsh, and provide secure encrypted communications between
39 two untrusted hosts over an insecure network.  X11 connections and
40 arbitrary TCP/IP ports can also be forwarded over the secure channel.
41
42 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
43 up to date in terms of security and features, as well as removing all 
44 patented algorithms to seperate libraries (OpenSSL).
45
46 This package contains the secure shell daemon and its documentation.
47 The sshd is the server part of the secure shell protocol and allows
48 ssh clients to connect to your host.
49
50 %description askpass
51 Ssh (Secure Shell) a program for logging into a remote machine and for
52 executing commands in a remote machine.  It is intended to replace
53 rlogin and rsh, and provide secure encrypted communications between
54 two untrusted hosts over an insecure network.  X11 connections and
55 arbitrary TCP/IP ports can also be forwarded over the secure channel.
56
57 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
58 up to date in terms of security and features, as well as removing all 
59 patented algorithms to seperate libraries (OpenSSL).
60
61 This package contains the GNOME passphrase dialog.
62
63 %changelog
64 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
65 - Use make install
66 - Subpackages
67 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
68 - Added links for slogin
69 - Fixed perms on manpages
70 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
71 - Renamed init script
72 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
73 - Back to old binary names
74 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
75 - Use autoconf
76 - New binary names
77 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
78 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
79
80 %prep
81
82 %setup -n openssh
83
84 %build
85
86 CFLAGS="$RPM_OPT_FLAGS" \
87         ./configure --prefix=/usr --sysconfdir=/etc/ssh --with-gnome-askpass
88
89 make
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 make install prefix="$RPM_BUILD_ROOT/usr"
94
95 install -d $RPM_BUILD_ROOT/etc/ssh
96 install -d $RPM_BUILD_ROOT/etc/pam.d/
97 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
98 install -m644 sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
99 install -m755 sshd.init.redhat $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
100 install -m600 ssh_config $RPM_BUILD_ROOT/etc/ssh/ssh_config
101 install -m600 sshd_config $RPM_BUILD_ROOT/etc/ssh/sshd_config
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post server
107 /sbin/chkconfig --add sshd
108 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
109         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
110 fi
111 if test -r /var/run/sshd.pid
112 then
113         /etc/rc.d/init.d/sshd restart >&2
114 fi
115
116 %preun server
117 if [ "$1" = 0 ]
118 then
119         /etc/rc.d/init.d/sshd stop >&2
120         /sbin/chkconfig --del sshd
121 fi
122
123 %files
124 %defattr(-,root,root)
125 %doc COPYING.Ylonen ChangeLog ChangeLog.Ylonen OVERVIEW 
126 %doc README README.Ylonen
127 %attr(4755,root,root) /usr/bin/ssh
128 %attr(0755,root,root) /usr/bin/ssh-agent
129 %attr(0755,root,root) /usr/bin/ssh-keygen
130 %attr(0755,root,root) /usr/bin/ssh-add
131 %attr(0755,root,root) /usr/bin/scp
132 %attr(-,root,root) /usr/bin/slogin
133 %attr(0644,root,root) /usr/man/man1/ssh.1
134 %attr(0644,root,root) /usr/man/man1/ssh-agent.1
135 %attr(0644,root,root) /usr/man/man1/ssh-keygen.1
136 %attr(0644,root,root) /usr/man/man1/ssh-add.1
137 %attr(0644,root,root) /usr/man/man1/scp.1
138 %attr(-,root,root) /usr/man/man1/slogin.1
139 %attr(0644,root,root) %config /etc/ssh/ssh_config
140
141 %files server
142 %defattr(-,root,root)
143 %attr(0755,root,root) /usr/sbin/sshd
144 %attr(0644,root,root) /usr/man/man8/sshd.8
145 %attr(0600,root,root) %config /etc/ssh/sshd_config
146 %attr(0600,root,root) %config /etc/pam.d/sshd
147 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
148
149 %files askpass
150 %defattr(-,root,root)
151 %attr(0755,root,root) /usr/lib/ssh/ssh-askpass
This page took 0.047066 seconds and 5 git commands to generate.