]> andersk Git - openssh.git/blob - openssh.spec
Updated COPYING file with usage of RC4
[openssh.git] / openssh.spec
1 Summary: OpenSSH free Secure Shell (SSH) implementation
2 Name: openssh
3 Version: 1.2pre7
4 Release: 1
5 Packager: Damien Miller <djm@ibs.com.au>
6 Source0: openssh-%{version}-linux.tar.gz
7 Copyright: BSD
8 Group: Applications/Internet
9 BuildRoot: /tmp/openssh-%{version}-buildroot
10
11 %description
12 Ssh (Secure Shell) a program for logging into a remote machine and for
13 executing commands in a remote machine.  It is intended to replace
14 rlogin and rsh, and provide secure encrypted communications between
15 two untrusted hosts over an insecure network.  X11 connections and
16 arbitrary TCP/IP ports can also be forwarded over the secure channel.
17
18 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
19 up to date in terms of security and features, as well as removing all 
20 patented algorithms to seperate libraries (OpenSSL).
21
22 %changelog
23 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
24 - Renamed init script
25 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
26 - Back to old binary names
27 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
28 - Use autoconf
29 - New binary names
30 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
31 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
32
33 %prep
34
35 %setup -n openssh
36
37 %build
38
39 ./configure --prefix=/usr --sysconfdir=/etc/ssh
40 make OPT_FLAGS="$RPM_OPT_FLAGS"
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 mkdir -p $RPM_BUILD_ROOT/usr/bin 
45 mkdir -p $RPM_BUILD_ROOT/usr/sbin 
46 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
47 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
48 mkdir -p $RPM_BUILD_ROOT/etc/ssh
49 mkdir -p $RPM_BUILD_ROOT/usr/man/man1
50 mkdir -p $RPM_BUILD_ROOT/usr/man/man8
51
52 install -m644 sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
53 install -m755 sshd.init.redhat $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
54 install -m600 ssh_config $RPM_BUILD_ROOT/etc/ssh/ssh_config
55 install -m600 sshd_config $RPM_BUILD_ROOT/etc/ssh/sshd_config
56
57 install -s -m755 sshd $RPM_BUILD_ROOT/usr/sbin
58 install -s -m755 ssh $RPM_BUILD_ROOT/usr/bin
59 install -s -m755 scp $RPM_BUILD_ROOT/usr/bin
60 install -s -m755 ssh-agent $RPM_BUILD_ROOT/usr/bin
61 install -s -m755 ssh-add $RPM_BUILD_ROOT/usr/bin
62 install -s -m755 ssh-keygen $RPM_BUILD_ROOT/usr/bin
63
64 install -m644 sshd.8 $RPM_BUILD_ROOT/usr/man/man8
65 install -m644 ssh.1 $RPM_BUILD_ROOT/usr/man/man1
66 install -m644 scp.1 $RPM_BUILD_ROOT/usr/man/man1
67 install -m644 ssh-agent.1 $RPM_BUILD_ROOT/usr/man/man1
68 install -m644 ssh-add.1 $RPM_BUILD_ROOT/usr/man/man1
69 install -m644 ssh-keygen.1 $RPM_BUILD_ROOT/usr/man/man1
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 /sbin/chkconfig --add sshd
76 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
77         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
78 fi
79 if test -r /var/run/sshd.pid
80 then
81         /etc/rc.d/init.d/sshd restart >&2
82 fi
83
84 %preun
85 if [ "$1" = 0 ]
86 then
87         /etc/rc.d/init.d/sshd stop >&2
88         /sbin/chkconfig --del sshd
89 fi
90
91 %files
92 %defattr(-,root,root)
93 %doc COPYING.Ylonen ChangeLog ChangeLog.Ylonen OVERVIEW 
94 %doc README README.openssh
95 %attr(0755,root,root) /usr/sbin/sshd
96 %attr(0755,root,root) /usr/bin/ssh
97 %attr(0755,root,root) /usr/bin/ssh-agent
98 %attr(0755,root,root) /usr/bin/ssh-keygen
99 %attr(0755,root,root) /usr/bin/ssh-add
100 %attr(0755,root,root) /usr/bin/scp
101
102 %attr(0755,root,root) /usr/man/man8/sshd.8
103 %attr(0755,root,root) /usr/man/man1/ssh.1
104 %attr(0755,root,root) /usr/man/man1/ssh-agent.1
105 %attr(0755,root,root) /usr/man/man1/ssh-keygen.1
106 %attr(0755,root,root) /usr/man/man1/ssh-add.1
107 %attr(0755,root,root) /usr/man/man1/scp.1
108
109 %attr(0600,root,root) %config /etc/ssh/sshd_config
110 %attr(0600,root,root) %config /etc/pam.d/sshd
111 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
112 %attr(0644,root,root) %config /etc/ssh/ssh_config
113
This page took 0.099984 seconds and 5 git commands to generate.