]> andersk Git - openssh.git/blob - openssh.spec
Added obseletes lines to spec
[openssh.git] / openssh.spec
1 Summary: OpenSSH free Secure Shell (SSH) implementation
2 Name: openssh
3 Version: 1.2pre12
4 Release: 1
5 Packager: Damien Miller <djm@ibs.com.au>
6 Source0: openssh-%{version}.tar.gz
7 Copyright: BSD
8 Group: Applications/Internet
9 BuildRoot: /tmp/openssh-%{version}-buildroot
10 Obseletes: ssh
11 Obseletes: ssh-clients
12 Obseletes: ssh-extras
13
14 %package server
15 Summary: Secure Shell protocol server (sshd)
16 Requires: openssh chkconfig >= 0.9
17 Group: System Environment/Daemons
18 Obseletes: ssh-server
19
20 %package askpass
21 Summary: GNOME passphrase dialog
22 Group: Applications/Internet
23 Requires: openssh
24 Obseletes: ssh-askpass
25
26 %description
27 Ssh (Secure Shell) a program for logging into a remote machine and for
28 executing commands in a remote machine.  It is intended to replace
29 rlogin and rsh, and provide secure encrypted communications between
30 two untrusted hosts over an insecure network.  X11 connections and
31 arbitrary TCP/IP ports can also be forwarded over the secure channel.
32
33 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
34 up to date in terms of security and features, as well as removing all 
35 patented algorithms to seperate libraries (OpenSSL).
36
37 This package includes the clients necessary to make encrypted connections
38 to SSH servers.
39
40 %description server
41 Ssh (Secure Shell) a program for logging into a remote machine and for
42 executing commands in a remote machine.  It is intended to replace
43 rlogin and rsh, and provide secure encrypted communications between
44 two untrusted hosts over an insecure network.  X11 connections and
45 arbitrary TCP/IP ports can also be forwarded over the secure channel.
46
47 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
48 up to date in terms of security and features, as well as removing all 
49 patented algorithms to seperate libraries (OpenSSL).
50
51 This package contains the secure shell daemon and its documentation.
52 The sshd is the server part of the secure shell protocol and allows
53 ssh clients to connect to your host.
54
55 %description askpass
56 Ssh (Secure Shell) a program for logging into a remote machine and for
57 executing commands in a remote machine.  It is intended to replace
58 rlogin and rsh, and provide secure encrypted communications between
59 two untrusted hosts over an insecure network.  X11 connections and
60 arbitrary TCP/IP ports can also be forwarded over the secure channel.
61
62 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
63 up to date in terms of security and features, as well as removing all 
64 patented algorithms to seperate libraries (OpenSSL).
65
66 This package contains the GNOME passphrase dialog.
67
68 %changelog
69 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
70 - Added 'Obseletes' directives
71 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
72 - Use make install
73 - Subpackages
74 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
75 - Added links for slogin
76 - Fixed perms on manpages
77 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
78 - Renamed init script
79 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
80 - Back to old binary names
81 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
82 - Use autoconf
83 - New binary names
84 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
85 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
86
87 %prep
88
89 %setup
90
91 %build
92
93 CFLAGS="$RPM_OPT_FLAGS" \
94         ./configure --prefix=/usr --sysconfdir=/etc/ssh --with-gnome-askpass
95
96 make
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 make install prefix="$RPM_BUILD_ROOT/usr"
101
102 install -d $RPM_BUILD_ROOT/etc/ssh
103 install -d $RPM_BUILD_ROOT/etc/pam.d/
104 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
105 install -m644 sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
106 install -m755 sshd.init.redhat $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
107 install -m600 ssh_config $RPM_BUILD_ROOT/etc/ssh/ssh_config
108 install -m600 sshd_config $RPM_BUILD_ROOT/etc/ssh/sshd_config
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post server
114 /sbin/chkconfig --add sshd
115 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
116         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
117 fi
118 if test -r /var/run/sshd.pid
119 then
120         /etc/rc.d/init.d/sshd restart >&2
121 fi
122
123 %preun server
124 if [ "$1" = 0 ]
125 then
126         /etc/rc.d/init.d/sshd stop >&2
127         /sbin/chkconfig --del sshd
128 fi
129
130 %files
131 %defattr(-,root,root)
132 %doc COPYING.Ylonen ChangeLog ChangeLog.Ylonen OVERVIEW 
133 %doc README README.Ylonen
134 %attr(4755,root,root) /usr/bin/ssh
135 %attr(0755,root,root) /usr/bin/ssh-agent
136 %attr(0755,root,root) /usr/bin/ssh-keygen
137 %attr(0755,root,root) /usr/bin/ssh-add
138 %attr(0755,root,root) /usr/bin/scp
139 %attr(-,root,root) /usr/bin/slogin
140 %attr(0644,root,root) /usr/man/man1/ssh.1
141 %attr(0644,root,root) /usr/man/man1/ssh-agent.1
142 %attr(0644,root,root) /usr/man/man1/ssh-keygen.1
143 %attr(0644,root,root) /usr/man/man1/ssh-add.1
144 %attr(0644,root,root) /usr/man/man1/scp.1
145 %attr(-,root,root) /usr/man/man1/slogin.1
146 %attr(0644,root,root) %config /etc/ssh/ssh_config
147
148 %files server
149 %defattr(-,root,root)
150 %attr(0755,root,root) /usr/sbin/sshd
151 %attr(0644,root,root) /usr/man/man8/sshd.8
152 %attr(0600,root,root) %config /etc/ssh/sshd_config
153 %attr(0600,root,root) %config /etc/pam.d/sshd
154 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
155
156 %files askpass
157 %defattr(-,root,root)
158 %attr(0755,root,root) /usr/lib/ssh/ssh-askpass
This page took 0.082796 seconds and 5 git commands to generate.