]> andersk Git - nss_nonlocal.git/blob - debian/rules
Update build flags for biarch packages.
[nss_nonlocal.git] / debian / rules
1 #!/usr/bin/make -f
2
3 DEB_AUTO_UPDATE_AUTOCONF = 2.50
4 DEB_AUTO_UPDATE_AUTOHEADER = 2.50
5 DEB_AUTO_UPDATE_AUTOMAKE = 1.9
6 DEB_AUTO_UPDATE_ACLOCAL = 1.9
7 DEB_AUTO_UPDATE_LIBTOOL = pre
8
9 include /usr/share/cdbs/1/rules/debhelper.mk
10 include /usr/share/cdbs/1/class/autotools.mk
11
12 DEB_DESTDIR = $(CURDIR)/debian/tmp/
13 DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
14 DEB_CONFIGURE_PREFIX = /
15
16 IS_UBUNTU := $(if $(filter Ubuntu, $(shell lsb_release -is)), y)
17 LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
18 libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y)
19
20 ifeq ($(call libc6_ge, 2.8+20080809), y)
21     DEB_DH_SHLIBDEPS_ARGS = -- -xglibc-private
22 endif
23
24 debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing
25
26 debian/stamp-autotools-files: aclocal.m4
27 aclocal.m4:
28         touch $@
29
30 DEB_BUILDDIR = $(or $(DEB_BUILDDIR_$(cdbs_curpkg)),debian/build)
31
32 REAL_DEB_HOST_GNU_TYPE := $(DEB_HOST_GNU_TYPE)
33
34 DEB_BUILDDIR_lib32nss-nonlocal = debian/build_32
35 cleanbuilddir/lib32nss-nonlocal:: clean/lib32nss-nonlocal
36 # i386_configure_target in eglibc/debian/sysdeps/amd64.mk
37 ifeq ($(or $(IS_UBUNTU), $(call libc6_ge, 2.8+20080809)), y)
38 configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i686-linux
39 else
40 configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i486-linux
41 endif
42 # i386_CC in eglibc/debian/sysdeps/amd64.mk
43 configure/lib32nss-nonlocal:: CC += -m32
44 # i386_slibdir in eglibc/debian/sysdeps/amd64.mk
45 ifeq ($(or $(IS_UBUNTU), $(call libc6_ge, 2.9-14~)), y)
46 configure/lib32nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib32"
47 else
48 configure/lib32nss-nonlocal:: DEB_CONFIGURE_PREFIX = /emul/ia32-linux
49 endif
50
51 DEB_BUILDDIR_lib64nss-nonlocal = debian/build_64
52 cleanbuilddir/lib64nss-nonlocal:: clean/lib64nss-nonlocal
53 # amd64_configure_target in eglibc/debian/sysdeps/i386.mk
54 configure/lib64nss-nonlocal:: DEB_BUILD_GNU_TYPE = x86_64-linux
55 # amd64_CC in eglibc/debian/sysdeps/i386.mk
56 configure/lib64nss-nonlocal:: CC += -m64 -D__x86_64__
57 # amd64_slibdir in eglibc/debian/sysdeps/i386.mk
58 configure/lib64nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib64"
59
60 configure/lib32nss-nonlocal configure/lib64nss-nonlocal::
61         $(DEB_CONFIGURE_INVOKE) $(cdbs_configure_flags) $(DEB_CONFIGURE_EXTRA_FLAGS) $(DEB_CONFIGURE_USER_FLAGS)
62
63 build/lib32nss-nonlocal build/lib64nss-nonlocal::
64         +$(DEB_MAKE_INVOKE) $(DEB_MAKE_BUILD_TARGET)
65
66 install/lib32nss-nonlocal install/lib64nss-nonlocal::
67         +$(DEB_MAKE_INVOKE) $(DEB_MAKE_INSTALL_TARGET)
68
69 clean/lib32nss-nonlocal clean/lib64nss-nonlocal::
70         +-$(DEB_MAKE_INVOKE) -k $(DEB_MAKE_CLEAN_TARGET)
71
72 clean::
73         rm -f aclocal.m4 config.guess config.sub install-sh ltmain.sh \
74             configure config.h.in missing depcomp Makefile.in
This page took 0.037877 seconds and 5 git commands to generate.