]> andersk Git - nss_nonlocal.git/blob - debian/rules
Only exclude glibc-private for new enough libc6.
[nss_nonlocal.git] / debian / rules
1 #!/usr/bin/make -f
2
3 DEB_AUTO_UPDATE_AUTOCONF = 2.50
4 DEB_AUTO_UPDATE_AUTOHEADER = 2.50
5 DEB_AUTO_UPDATE_AUTOMAKE = 1.9
6 DEB_AUTO_UPDATE_ACLOCAL = 1.9
7 DEB_AUTO_UPDATE_LIBTOOL = pre
8
9 include /usr/share/cdbs/1/rules/debhelper.mk
10 include /usr/share/cdbs/1/class/autotools.mk
11
12 DEB_CONFIGURE_PREFIX = /
13
14 LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
15 ifeq ($(shell dpkg --compare-versions '$(LIBC6_VERSION)' '>=' '2.8+20080809' && echo y),y)
16     DEB_DH_SHLIBDEPS_ARGS = -- -xglibc-private
17 endif
18
19 debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing
20
21 debian/stamp-autotools-files: aclocal.m4
22 aclocal.m4:
23         touch $@
24
25 clean::
26         rm -f aclocal.m4 config.guess config.sub install-sh ltmain.sh \
27             configure config.h.in missing depcomp Makefile.in
This page took 0.029325 seconds and 5 git commands to generate.