]> andersk Git - mod-vhost-ldap.git/blob - debian/rules
Change DH_COMPAT to 4
[mod-vhost-ldap.git] / debian / rules
1 #!/usr/bin/make -f
2
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6 # This is the debhelper compatibility version to use.
7 export DH_COMPAT=4
8
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
13
14 CFLAGS = -Wall -g
15
16 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17         CFLAGS += -O0
18 else
19         CFLAGS += -O2
20 endif
21 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
22         INSTALL_PROGRAM += -s
23 endif
24
25 AP2_MAKE_DEFS=top_dir=/usr/share/apache2 \
26         APXS=apxs2 APACHECTL=apachectl2 \
27         LIBTOOL=libtool SH_LIBTOOL=libtool \
28         INCLUDES="-I/usr/include/apache2 -I /usr/include/apr-0"
29
30 DEST=$(CURDIR)/debian/libapache2-mod-vhost-ldap
31
32 configure: configure-stamp
33 configure-stamp:
34         dh_testdir
35         touch configure-stamp
36
37 binary: binary-indep binary-arch
38
39 binary-indep:
40
41 binary-arch: build install
42         dh_testdir
43         dh_testroot
44         dh_installdocs
45         dh_installexamples
46         dh_installman
47         dh_link
48         dh_strip
49         dh_compress
50         dh_installdeb
51         dh_shlibdeps
52         dh_gencontrol
53         dh_md5sums
54         dh_builddeb
55
56 build: build-stamp
57 build-stamp: configure-stamp
58         dh_testdir
59         $(MAKE) $(AP2_MAKE_DEFS)
60         touch build-stamp-20
61
62 clean:
63         dh_testdir
64         dh_testroot
65         rm -f build-stamp-* configure-stamp-*
66         $(MAKE) clean
67         rm -rf build-tree
68         dh_clean
69
70 install: build
71         dh_testdir
72         dh_testroot
73         dh_clean -k
74         dh_installdirs
75         dh_installdocs
76         dh_installchangelogs ChangeLog
77         mkdir -p $(DEST)/usr/lib/apache2/modules
78         install -m 644 .libs/mod_vhost_ldap.so $(DEST)/usr/lib/apache2/modules
79         mkdir -p $(DEST)/etc/apache2/mods-available
80         install -m 644 debian/vhost_ldap.load $(DEST)/etc/apache2/mods-available
81         install -m 644 debian/vhost_ldap.conf $(DEST)/etc/apache2/mods-available
82
83 .PHONY: binary binary-arch binary-indep clean build install
This page took 0.483969 seconds and 5 git commands to generate.