]> andersk Git - libyaml.git/blob - debian/patches/CVE-2014-9130.patch
Fix CVE-2014-9130 assertion failure caused by wrapped strings
[libyaml.git] / debian / patches / CVE-2014-9130.patch
1 From: Kirill Simonov <xi@resolvent.net>
2 Subject: Removed invalid simple key assertion (thank to Jonathan Gray).
3 Origin: upstream, https://bitbucket.org/xi/libyaml/commits/2b9156756423e967cfd09a61d125d883fca6f4f2
4 Bug: https://bitbucket.org/xi/libyaml/issue/10
5 Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=771366
6 Last-Update: 2014-11-28
7
8 ---
9  src/scanner.c | 7 -------
10  1 file changed, 7 deletions(-)
11
12 diff --git a/src/scanner.c b/src/scanner.c
13 index 88d4fa5..5ec0be0 100644
14 --- a/src/scanner.c
15 +++ b/src/scanner.c
16 @@ -1106,13 +1106,6 @@ yaml_parser_save_simple_key(yaml_parser_t *parser)
17              && parser->indent == (ptrdiff_t)parser->mark.column);
18  
19      /*
20 -     * A simple key is required only when it is the first token in the current
21 -     * line.  Therefore it is always allowed.  But we add a check anyway.
22 -     */
23 -
24 -    assert(parser->simple_key_allowed || !required);    /* Impossible. */
25 -
26 -    /*
27       * If the current position may start a simple key, save it.
28       */
29  
30 -- 
31 2.2.0
32
This page took 0.032915 seconds and 5 git commands to generate.