]> andersk Git - gssapi-openssh.git/blob - openssh/contrib/redhat/openssh.spec
Import of OpenSSH 3.3p1
[gssapi-openssh.git] / openssh / contrib / redhat / openssh.spec
1 %define ver 3.3p1
2 %define rel 1
3
4 # OpenSSH privilege separation requires a user & group ID
5 %define sshd_uid    74
6 %define sshd_gid    74
7
8 # Version of ssh-askpass
9 %define aversion 1.2.4.1
10
11 # Do we want to disable building of x11-askpass? (1=yes 0=no)
12 %define no_x11_askpass 0
13
14 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
15 %define no_gnome_askpass 0
16
17 # Do we want to link against a static libcrypto? (1=yes 0=no)
18 %define static_libcrypto 0
19
20 # Do we want smartcard support (1=yes 0=no)
21 %define scard 0
22
23 # Is this build for RHL 6.x?
24 %define build6x 0
25
26 # Disable IPv6 (avoids DNS hangs on some glibc versions)
27 %define noip6 0
28
29 # Do we want kerberos5 support (1=yes 0=no)
30 %define kerberos5 1
31
32 # Reserve options to override askpass settings with:
33 # rpm -ba|--rebuild --define 'skip_xxx 1'
34 %{?skip_x11_askpass:%define no_x11_askpass 1}
35 %{?skip_gnome_askpass:%define no_gnome_askpass 1}
36
37 # Is this a build for RHL 6.x or earlier?
38 %{?build_6x:%define build6x 1}
39
40 # If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
41 %if %{build6x}
42 %define _sysconfdir /etc
43 %define noip6 1
44 %endif
45
46 # Options for static OpenSSL link:
47 # rpm -ba|--rebuild --define "static_openssl 1"
48 %{?static_openssl:%define static_libcrypto 1}
49
50 # Options for Smartcard support: (needs libsectok and openssl-engine)
51 # rpm -ba|--rebuild --define "smartcard 1"
52 %{?smartcard:%define scard 1}
53
54 # Option to disable ipv6
55 # rpm -ba|--rebuild --define "noipv6 1"
56 %{?noipv6:%define noip6 1}
57
58 # Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
59 %define rescue 0
60 %{?build_rescue:%define rescue 1}
61
62 # Turn off some stuff for resuce builds
63 %if %{rescue}
64 %define kerberos5 0
65 %endif
66
67 Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
68 Name: openssh
69 Version: %{ver}
70 %if %{rescue}
71 Release: %{rel}rescue
72 %else
73 Release: %{rel}
74 %endif
75 URL: http://www.openssh.com/portable.html
76 Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
77 Source1: http://www.pobox.com/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
78 License: BSD
79 Group: Applications/Internet
80 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
81 Obsoletes: ssh
82 %if %{build6x}
83 PreReq: initscripts >= 5.00
84 %else
85 PreReq: initscripts >= 5.20
86 %endif
87 BuildPreReq: perl, openssl-devel, sharutils, tcp_wrappers
88 BuildPreReq: /bin/login
89 %if %{build6x}
90 BuildPreReq: glibc-devel, pam
91 %else
92 BuildPreReq: db1-devel, /usr/include/security/pam_appl.h
93 %endif
94 %if ! %{no_x11_askpass}
95 BuildPreReq: XFree86-devel
96 %endif
97 %if ! %{no_gnome_askpass}
98 BuildPreReq: gnome-libs-devel
99 %endif
100
101 %package clients
102 Summary: OpenSSH clients.
103 Requires: openssh = %{version}-%{release}
104 Group: Applications/Internet
105 Obsoletes: ssh-clients
106
107 %package server
108 Summary: The OpenSSH server daemon.
109 Group: System Environment/Daemons
110 Obsoletes: ssh-server
111 PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
112 %if ! %{build6x}
113 Requires: /etc/pam.d/system-auth
114 %endif
115
116 %package askpass
117 Summary: A passphrase dialog for OpenSSH and X.
118 Group: Applications/Internet
119 Requires: openssh = %{version}-%{release}
120 Obsoletes: ssh-extras
121
122 %package askpass-gnome
123 Summary: A passphrase dialog for OpenSSH, X, and GNOME.
124 Group: Applications/Internet
125 Requires: openssh = %{version}-%{release}
126 Obsoletes: ssh-extras
127
128 %description
129 SSH (Secure SHell) is a program for logging into and executing
130 commands on a remote machine. SSH is intended to replace rlogin and
131 rsh, and to provide secure encrypted communications between two
132 untrusted hosts over an insecure network. X11 connections and
133 arbitrary TCP/IP ports can also be forwarded over the secure channel.
134
135 OpenSSH is OpenBSD's version of the last free version of SSH, bringing
136 it up to date in terms of security and features, as well as removing
137 all patented algorithms to separate libraries.
138
139 This package includes the core files necessary for both the OpenSSH
140 client and server. To make this package useful, you should also
141 install openssh-clients, openssh-server, or both.
142
143 %description clients
144 OpenSSH is a free version of SSH (Secure SHell), a program for logging
145 into and executing commands on a remote machine. This package includes
146 the clients necessary to make encrypted connections to SSH servers.
147 You'll also need to install the openssh package on OpenSSH clients.
148
149 %description server
150 OpenSSH is a free version of SSH (Secure SHell), a program for logging
151 into and executing commands on a remote machine. This package contains
152 the secure shell daemon (sshd). The sshd daemon allows SSH clients to
153 securely connect to your SSH server. You also need to have the openssh
154 package installed.
155
156 %description askpass
157 OpenSSH is a free version of SSH (Secure SHell), a program for logging
158 into and executing commands on a remote machine. This package contains
159 an X11 passphrase dialog for OpenSSH.
160
161 %description askpass-gnome
162 OpenSSH is a free version of SSH (Secure SHell), a program for logging
163 into and executing commands on a remote machine. This package contains
164 an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
165 environment.
166
167 %prep
168
169 %if ! %{no_x11_askpass}
170 %setup -q -a 1
171 %else
172 %setup -q
173 %endif
174
175 %build
176 %if %{rescue}
177 CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
178 %endif
179
180 %configure \
181         --sysconfdir=%{_sysconfdir}/ssh \
182         --libexecdir=%{_libexecdir}/openssh \
183         --datadir=%{_datadir}/openssh \
184         --with-tcp-wrappers \
185         --with-rsh=%{_bindir}/rsh \
186         --with-default-path=/usr/local/bin:/bin:/usr/bin \
187         --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
188         --with-privsep-path=%{_var}/empty/sshd \
189 %if %{scard}
190         --with-smartcard \
191 %endif
192 %if %{noip6}
193         --with-ipv4-default \
194 %endif
195 %if %{rescue}
196         --without-pam --with-md5-passwords \
197 %else
198         --with-pam \
199 %endif
200 %if %{kerberos5}
201          --with-kerberos5=/usr/kerberos \
202 %endif
203
204
205 %if %{static_libcrypto}
206 perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
207 %endif
208
209 make
210
211 %if ! %{no_x11_askpass}
212 pushd x11-ssh-askpass-%{aversion}
213 %configure --libexecdir=%{_libexecdir}/openssh
214 xmkmf -a
215 make
216 popd
217 %endif
218
219 %if ! %{no_gnome_askpass}
220 pushd contrib
221 gcc $RPM_OPT_FLAGS `gnome-config --cflags gnome gnomeui` \
222         gnome-ssh-askpass.c -o gnome-ssh-askpass \
223         `gnome-config --libs gnome gnomeui`
224 popd
225 %endif
226
227 %install
228 rm -rf $RPM_BUILD_ROOT
229 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
230 mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
231 mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
232
233 make install DESTDIR=$RPM_BUILD_ROOT
234
235 install -d $RPM_BUILD_ROOT/etc/pam.d/
236 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
237 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
238 %if %{build6x}
239 install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
240 %else
241 install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
242 %endif
243 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
244
245 %if ! %{no_x11_askpass}
246 install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
247 ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
248 %endif
249
250 %if ! %{no_gnome_askpass}
251 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
252 %endif
253
254 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
255 install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
256 install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
257
258 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
259
260 %clean
261 rm -rf $RPM_BUILD_ROOT
262
263 %triggerun server -- ssh-server
264 if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
265         touch /var/run/sshd.restart
266 fi
267
268 %triggerun server -- openssh-server < 2.5.0p1
269 # Count the number of HostKey and HostDsaKey statements we have.
270 gawk    'BEGIN {IGNORECASE=1}
271          /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
272          END {exit sawhostkey}' /etc/ssh/sshd_config
273 # And if we only found one, we know the client was relying on the old default
274 # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
275 # specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
276 # one nullifies the default, which would have loaded both.
277 if [ $? -eq 1 ] ; then
278         echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
279         echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
280 fi
281
282 %triggerpostun server -- ssh-server
283 if [ "$1" != 0 ] ; then
284         /sbin/chkconfig --add sshd
285         if test -f /var/run/sshd.restart ; then
286                 rm -f /var/run/sshd.restart
287                 /sbin/service sshd start > /dev/null 2>&1 || :
288         fi
289 fi
290
291 %pre server
292 %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
293 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
294         -g sshd -M -r sshd 2>/dev/null || :
295
296 %post server
297 /sbin/chkconfig --add sshd
298
299 %postun server
300 /sbin/service sshd condrestart > /dev/null 2>&1 || :
301
302 %preun server
303 if [ "$1" = 0 ]
304 then
305         /sbin/service sshd stop > /dev/null 2>&1 || :
306         /sbin/chkconfig --del sshd
307 fi
308
309 %files
310 %defattr(-,root,root)
311 %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
312 %attr(0755,root,root) %{_bindir}/scp
313 %attr(0644,root,root) %{_mandir}/man1/scp.1*
314 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
315 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
316 %if ! %{rescue}
317 %attr(0755,root,root) %{_bindir}/ssh-keygen
318 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
319 %attr(0755,root,root) %dir %{_libexecdir}/openssh
320 %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
321 %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
322 %endif
323 %if %{scard}
324 %attr(0755,root,root) %dir %{_datadir}/openssh
325 %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
326 %endif
327
328 %files clients
329 %defattr(-,root,root)
330 %attr(0755,root,root) %{_bindir}/ssh
331 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
332 %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
333 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
334 %attr(-,root,root) %{_bindir}/slogin
335 %attr(-,root,root) %{_mandir}/man1/slogin.1*
336 %if ! %{rescue}
337 %attr(0755,root,root) %{_bindir}/ssh-agent
338 %attr(0755,root,root) %{_bindir}/ssh-add
339 %attr(0755,root,root) %{_bindir}/ssh-keyscan
340 %attr(0755,root,root) %{_bindir}/sftp
341 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
342 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
343 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
344 %attr(0644,root,root) %{_mandir}/man1/sftp.1*
345 %endif
346
347 %if ! %{rescue}
348 %files server
349 %defattr(-,root,root)
350 %dir %attr(0111,root,root) %{_var}/empty/sshd
351 %attr(0755,root,root) %{_sbindir}/sshd
352 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
353 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
354 %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
355 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
356 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
357 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
358 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
359 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
360 %endif
361
362 %if ! %{no_x11_askpass}
363 %files askpass
364 %defattr(-,root,root)
365 %doc x11-ssh-askpass-%{aversion}/README
366 %doc x11-ssh-askpass-%{aversion}/ChangeLog
367 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
368 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
369 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
370 %endif
371
372 %if ! %{no_gnome_askpass}
373 %files askpass-gnome
374 %defattr(-,root,root)
375 %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
376 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
377 %endif
378
379 %changelog
380 * Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
381 - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
382 - Add new {ssh,sshd}_config.5 manpages
383 - Add new ssh-keysign program and remove setuid from ssh client
384
385 * Fri May 10 2002 Damien Miller <djm@mindrot.org>
386 - Merge in spec changes from RedHat, reorgansie a little
387 - Add Privsep user, group and directory
388
389 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
390 - bump and grind (through the build system)
391
392 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
393 - require sharutils for building (mindrot #137)
394 - require db1-devel only when building for 6.x (#55105), which probably won't
395   work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
396 - require pam-devel by file (not by package name) again
397 - add Markus's patch to compile with OpenSSL 0.9.5a (from
398   http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
399   building for 6.x
400
401 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
402 - update to 3.1p1
403
404 * Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
405 - update to SNAP-20020305
406 - drop debug patch, fixed upstream
407
408 * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
409 - update to SNAP-20020220 for testing purposes (you've been warned, if there's
410   anything to be warned about, gss patches won't apply, I don't mind)
411
412 * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
413 - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
414   exchange, authentication, and named key support
415
416 * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
417 - remove dependency on db1-devel, which has just been swallowed up whole
418   by gnome-libs-devel
419
420 * Sun Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
421 - adjust build dependencies so that build6x actually works right (fix
422   from Hugo van der Kooij)
423
424 * Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
425 - update to 3.0.2p1
426
427 * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
428 - update to 3.0.1p1
429
430 * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
431 - update to current CVS (not for use in distribution)
432
433 * Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
434 - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
435   3.0p1 spec file and init script
436
437 * Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
438 - update to 3.0p1
439 - update to x11-ssh-askpass 1.2.4.1
440 - change build dependency on a file from pam-devel to the pam-devel package
441 - replace primes with moduli
442
443 * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
444 - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
445
446 * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
447 - Merge changes to rescue build from current sysadmin survival cd
448
449 * Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
450 - fix scp's server's reporting of file sizes, and build with the proper
451   preprocessor define to get large-file capable open(), stat(), etc.
452   (sftp has been doing this correctly all along) (#51827)
453 - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
454 - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
455 - mark profile.d scriptlets as config files (#42337)
456 - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
457 - change a couple of log() statements to debug() statements (#50751)
458 - pull cvs patch to add -t flag to sshd (#28611)
459 - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
460
461 * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
462 - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
463
464 * Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
465 - pull cvs patch to fix remote port forwarding with protocol 2
466
467 * Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
468 - pull cvs patch to add session initialization to no-pty sessions
469 - pull cvs patch to not cut off challengeresponse auth needlessly
470 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
471   it by default on a system that doesn't have X installed (#49263)
472
473 * Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
474 - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
475
476 * Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
477 - pass OPTIONS correctly to initlog (#50151)
478
479 * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
480 - switch to x11-ssh-askpass 1.2.2
481
482 * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
483 - rebuild in new environment
484
485 * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
486 - disable the gssapi patch
487
488 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
489 - update to 2.9p2
490 - refresh to a new version of the gssapi patch
491
492 * Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
493 - change Copyright: BSD to License: BSD
494 - add Markus Friedl's unverified patch for the cookie file deletion problem
495   so that we can verify it
496 - drop patch to check if xauth is present (was folded into cookie patch)
497 - don't apply gssapi patches for the errata candidate
498 - clear supplemental groups list at startup
499
500 * Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
501 - fix an error parsing the new default sshd_config
502 - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
503   dealing with comments right
504
505 * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
506 - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
507   to be removed before the next beta cycle because it's a big departure
508   from the upstream version
509
510 * Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
511 - finish marking strings in the init script for translation
512 - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
513   at startup (change merged from openssh.com init script, originally by
514   Pekka Savola)
515 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
516   it by default on a system that doesn't have X installed
517
518 * Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
519 - update to 2.9
520 - drop various patches that came from or went upstream or to or from CVS
521
522 * Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
523 - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
524
525 * Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
526 - remove explicit openssl requirement, fixes builddistro issue
527 - make initscript stop() function wait until sshd really dead to avoid 
528   races in condrestart
529
530 * Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
531 - mention that challengereponse supports PAM, so disabling password doesn't
532   limit users to pubkey and rsa auth (#34378)
533 - bypass the daemon() function in the init script and call initlog directly,
534   because daemon() won't start a daemon it detects is already running (like
535   open connections)
536 - require the version of openssl we had when we were built
537
538 * Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
539 - make do_pam_setcred() smart enough to know when to establish creds and
540   when to reinitialize them
541 - add in a couple of other fixes from Damien for inclusion in the errata
542
543 * Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
544 - update to 2.5.2p2
545 - call setcred() again after initgroups, because the "creds" could actually
546   be group memberships
547
548 * Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
549 - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
550 - don't enable challenge-response by default until we find a way to not
551   have too many userauth requests (we may make up to six pubkey and up to
552   three password attempts as it is)
553 - remove build dependency on rsh to match openssh.com's packages more closely
554
555 * Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
556 - remove dependency on openssl -- would need to be too precise
557
558 * Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
559 - rebuild in new environment
560
561 * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
562 - Revert the patch to move pam_open_session.
563 - Init script and spec file changes from Pekka Savola. (#28750)
564 - Patch sftp to recognize '-o protocol' arguments. (#29540)
565
566 * Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
567 - Chuck the closing patch.
568 - Add a trigger to add host keys for protocol 2 to the config file, now that
569   configuration file syntax requires us to specify it with HostKey if we
570   specify any other HostKey values, which we do.
571
572 * Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
573 - Redo patch to move pam_open_session after the server setuid()s to the user.
574 - Rework the nopam patch to use be picked up by autoconf.
575
576 * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
577 - Update for 2.5.1p1.
578 - Add init script mods from Pekka Savola.
579 - Tweak the init script to match the CVS contrib script more closely.
580 - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
581   adding id_rsa.
582
583 * Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
584 - Update for 2.5.0p1.
585 - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
586 - Resync with parts of Damien Miller's openssh.spec from CVS, including
587   update of x11 askpass to 1.2.0.
588 - Only require openssl (don't prereq) because we generate keys in the init
589   script now.
590
591 * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
592 - Don't open a PAM session until we've forked and become the user (#25690).
593 - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
594   host the user is attempting a login from.
595 - Resync with parts of Damien Miller's openssh.spec from CVS.
596 - Don't expose KbdInt responses in debug messages (from CVS).
597 - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
598
599 * Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
600 - i18n-tweak to initscript.
601
602 * Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
603 - More gettextizing.
604 - Close all files after going into daemon mode (needs more testing).
605 - Extract patch from CVS to handle auth banners (in the client).
606 - Extract patch from CVS to handle compat weirdness.
607
608 * Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
609 - Finish with the gettextizing.
610
611 * Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
612 - Fix a bug in auth2-pam.c (#23877)
613 - Gettextize the init script.
614
615 * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
616 - Incorporate a switch for using PAM configs for 6.x, just in case.
617
618 * Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
619 - Incorporate Bero's changes for a build specifically for rescue CDs.
620
621 * Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
622 - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
623   succeeded, to allow public-key authentication after a failure with "none"
624   authentication.  (#21268)
625
626 * Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
627 - Update to x11-askpass 1.1.1. (#21301)
628 - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
629
630 * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
631 - Merge multiple PAM text messages into subsequent prompts when possible when
632   doing keyboard-interactive authentication.
633
634 * Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
635 - Disable the built-in MD5 password support.  We're using PAM.
636 - Take a crack at doing keyboard-interactive authentication with PAM, and
637   enable use of it in the default client configuration so that the client
638   will try it when the server disallows password authentication.
639 - Build with debugging flags.  Build root policies strip all binaries anyway.
640
641 * Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
642 - Use DESTDIR instead of %%makeinstall.
643 - Remove /usr/X11R6/bin from the path-fixing patch.
644
645 * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
646 - Add the primes file from the latest snapshot to the main package (#20884).
647 - Add the dev package to the prereq list (#19984).
648 - Remove the default path and mimic login's behavior in the server itself.
649
650 * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
651 - Resync with conditional options in Damien Miller's .spec file for an errata.
652 - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
653
654 * Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
655 - Update to OpenSSH 2.3.0p1.
656 - Update to x11-askpass 1.1.0.
657 - Enable keyboard-interactive authentication.
658
659 * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
660 - Update to ssh-askpass-x11 1.0.3.
661 - Change authentication related messages to be private (#19966).
662
663 * Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
664 - Patch ssh-keygen to be able to list signatures for DSA public key files
665   it generates.
666
667 * Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
668 - Add BuildPreReq on /usr/include/security/pam_appl.h to be sure we always
669   build PAM authentication in.
670 - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
671 - Clean out no-longer-used patches.
672 - Patch ssh-add to try to add both identity and id_dsa, and to error only
673   when neither exists.
674
675 * Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
676 - Update x11-askpass to 1.0.2. (#17835)
677 - Add BuildPreReqs for /bin/login and /usr/bin/rsh so that configure will
678   always find them in the right place. (#17909)
679 - Set the default path to be the same as the one supplied by /bin/login, but
680   add /usr/X11R6/bin. (#17909)
681 - Try to handle obsoletion of ssh-server more cleanly.  Package names
682   are different, but init script name isn't. (#17865)
683
684 * Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
685 - Update to 2.2.0p1. (#17835)
686 - Tweak the init script to allow proper restarting. (#18023)
687
688 * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
689 - Update to 20000823 snapshot.
690 - Change subpackage requirements from %%{version} to %%{version}-%%{release}
691 - Back out the pipe patch.
692
693 * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
694 - Update to 2.1.1p4, which includes fixes for config file parsing problems.
695 - Move the init script back.
696 - Add Damien's quick fix for wackiness.
697
698 * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
699 - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
700
701 * Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
702 - Move condrestart to server postun.
703 - Move key generation to init script.
704 - Actually use the right patch for moving the key generation to the init script.
705 - Clean up the init script a bit.
706
707 * Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
708 - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
709
710 * Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
711 - Update to 2.1.1p2.
712 - Use of strtok() considered harmful.
713
714 * Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
715 - Get the build root out of the man pages.
716
717 * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
718 - Add and use condrestart support in the init script.
719 - Add newer initscripts as a prereq.
720
721 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
722 - Build in new environment (release 2)
723 - Move -clients subpackage to Applications/Internet group
724
725 * Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
726 - Update to 2.2.1p1
727
728 * Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
729 - Patch to build with neither RSA nor RSAref.
730 - Miscellaneous FHS-compliance tweaks.
731 - Fix for possibly-compressed man pages.
732
733 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
734 - Updated for new location
735 - Updated for new gnome-ssh-askpass build
736
737 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
738 - Added Jim Knoble's <jmknoble@pobox.com> askpass
739
740 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
741 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
742
743 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
744 - Added 'Obsoletes' directives
745
746 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
747 - Use make install
748 - Subpackages
749
750 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
751 - Added links for slogin
752 - Fixed perms on manpages
753
754 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
755 - Renamed init script
756
757 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
758 - Back to old binary names
759
760 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
761 - Use autoconf
762 - New binary names
763
764 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
765 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
This page took 0.128554 seconds and 5 git commands to generate.