]> andersk Git - gssapi-openssh.git/blob - openssh/contrib/redhat/openssh.spec
Import of OpenSSH 3.2.3p1
[gssapi-openssh.git] / openssh / contrib / redhat / openssh.spec
1 %define ver 3.2.3p1
2 %define rel 1
3
4 # OpenSSH privilege separation requires a user & group ID
5 %define sshd_uid    74
6 %define sshd_gid    74
7
8 # Version of ssh-askpass
9 %define aversion 1.2.4.1
10
11 # Do we want to disable building of x11-askpass? (1=yes 0=no)
12 %define no_x11_askpass 0
13
14 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
15 %define no_gnome_askpass 0
16
17 # Do we want to link against a static libcrypto? (1=yes 0=no)
18 %define static_libcrypto 0
19
20 # Do we want smartcard support (1=yes 0=no)
21 %define scard 0
22
23 # Is this build for RHL 6.x?
24 %define build6x 0
25
26 # Disable IPv6 (avoids DNS hangs on some glibc versions)
27 %define noip6 0
28
29 # Reserve options to override askpass settings with:
30 # rpm -ba|--rebuild --define 'skip_xxx 1'
31 %{?skip_x11_askpass:%define no_x11_askpass 1}
32 %{?skip_gnome_askpass:%define no_gnome_askpass 1}
33
34 # Is this a build for RHL 6.x or earlier?
35 %{?build_6x:%define build6x 1}
36
37 # If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
38 %if %{build6x}
39 %define _sysconfdir /etc
40 %define noip6 1
41 %endif
42
43 # Options for static OpenSSL link:
44 # rpm -ba|--rebuild --define "static_openssl 1"
45 %{?static_openssl:%define static_libcrypto 1}
46
47 # Options for Smartcard support: (needs libsectok and openssl-engine)
48 # rpm -ba|--rebuild --define "smartcard 1"
49 %{?smartcard:%define scard 1}
50
51 # Option to disable ipv6
52 # rpm -ba|--rebuild --define "noipv6 1"
53 %{?noipv6:%define noip6 1}
54
55 # Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
56 %define rescue 0
57 %{?build_rescue:%define rescue 1}
58
59 Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
60 Name: openssh
61 Version: %{ver}
62 %if %{rescue}
63 Release: %{rel}rescue
64 %else
65 Release: %{rel}
66 %endif
67 URL: http://www.openssh.com/portable.html
68 Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
69 Source1: http://www.pobox.com/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
70 License: BSD
71 Group: Applications/Internet
72 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
73 Obsoletes: ssh
74 %if %{build6x}
75 PreReq: initscripts >= 5.00
76 %else
77 PreReq: initscripts >= 5.20
78 %endif
79 BuildPreReq: perl, openssl-devel, sharutils, tcp_wrappers
80 BuildPreReq: /bin/login
81 %if %{build6x}
82 BuildPreReq: glibc-devel, pam
83 %else
84 BuildPreReq: db1-devel, /usr/include/security/pam_appl.h
85 %endif
86 %if ! %{no_x11_askpass}
87 BuildPreReq: XFree86-devel
88 %endif
89 %if ! %{no_gnome_askpass}
90 BuildPreReq: gnome-libs-devel
91 %endif
92
93 %package clients
94 Summary: OpenSSH clients.
95 Requires: openssh = %{version}-%{release}
96 Group: Applications/Internet
97 Obsoletes: ssh-clients
98
99 %package server
100 Summary: The OpenSSH server daemon.
101 Group: System Environment/Daemons
102 Obsoletes: ssh-server
103 PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
104 %if ! %{build6x}
105 Requires: /etc/pam.d/system-auth
106 %endif
107
108 %package askpass
109 Summary: A passphrase dialog for OpenSSH and X.
110 Group: Applications/Internet
111 Requires: openssh = %{version}-%{release}
112 Obsoletes: ssh-extras
113
114 %package askpass-gnome
115 Summary: A passphrase dialog for OpenSSH, X, and GNOME.
116 Group: Applications/Internet
117 Requires: openssh = %{version}-%{release}
118 Obsoletes: ssh-extras
119
120 %description
121 SSH (Secure SHell) is a program for logging into and executing
122 commands on a remote machine. SSH is intended to replace rlogin and
123 rsh, and to provide secure encrypted communications between two
124 untrusted hosts over an insecure network. X11 connections and
125 arbitrary TCP/IP ports can also be forwarded over the secure channel.
126
127 OpenSSH is OpenBSD's version of the last free version of SSH, bringing
128 it up to date in terms of security and features, as well as removing
129 all patented algorithms to separate libraries.
130
131 This package includes the core files necessary for both the OpenSSH
132 client and server. To make this package useful, you should also
133 install openssh-clients, openssh-server, or both.
134
135 %description clients
136 OpenSSH is a free version of SSH (Secure SHell), a program for logging
137 into and executing commands on a remote machine. This package includes
138 the clients necessary to make encrypted connections to SSH servers.
139 You'll also need to install the openssh package on OpenSSH clients.
140
141 %description server
142 OpenSSH is a free version of SSH (Secure SHell), a program for logging
143 into and executing commands on a remote machine. This package contains
144 the secure shell daemon (sshd). The sshd daemon allows SSH clients to
145 securely connect to your SSH server. You also need to have the openssh
146 package installed.
147
148 %description askpass
149 OpenSSH is a free version of SSH (Secure SHell), a program for logging
150 into and executing commands on a remote machine. This package contains
151 an X11 passphrase dialog for OpenSSH.
152
153 %description askpass-gnome
154 OpenSSH is a free version of SSH (Secure SHell), a program for logging
155 into and executing commands on a remote machine. This package contains
156 an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
157 environment.
158
159 %prep
160
161 %if ! %{no_x11_askpass}
162 %setup -q -a 1
163 %else
164 %setup -q
165 %endif
166
167 %build
168 %if %{rescue}
169 CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
170 %endif
171
172 %configure \
173         --sysconfdir=%{_sysconfdir}/ssh \
174         --libexecdir=%{_libexecdir}/openssh \
175         --datadir=%{_datadir}/openssh \
176         --with-tcp-wrappers \
177         --with-rsh=%{_bindir}/rsh \
178         --with-default-path=/usr/local/bin:/bin:/usr/bin \
179         --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
180         --with-privsep-path=%{_var}/empty/sshd \
181 %if %{scard}
182         --with-smartcard \
183 %endif
184 %if %{noip6}
185         --with-ipv4-default \
186 %endif
187 %if %{rescue}
188         --without-pam --with-md5-passwords
189 %else
190         --with-pam --with-kerberos5=/usr/kerberos
191 %endif
192
193
194 %if %{static_libcrypto}
195 perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
196 %endif
197
198 make
199
200 %if ! %{no_x11_askpass}
201 pushd x11-ssh-askpass-%{aversion}
202 %configure --libexecdir=%{_libexecdir}/openssh
203 xmkmf -a
204 make
205 popd
206 %endif
207
208 %if ! %{no_gnome_askpass}
209 pushd contrib
210 gcc $RPM_OPT_FLAGS `gnome-config --cflags gnome gnomeui` \
211         gnome-ssh-askpass.c -o gnome-ssh-askpass \
212         `gnome-config --libs gnome gnomeui`
213 popd
214 %endif
215
216 %install
217 rm -rf $RPM_BUILD_ROOT
218 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
219 mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
220 mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
221
222 make install DESTDIR=$RPM_BUILD_ROOT
223
224 install -d $RPM_BUILD_ROOT/etc/pam.d/
225 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
226 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
227 %if %{build6x}
228 install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
229 %else
230 install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
231 %endif
232 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
233
234 %if ! %{no_x11_askpass}
235 install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
236 ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
237 %endif
238
239 %if ! %{no_gnome_askpass}
240 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
241 %endif
242
243 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
244 install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
245 install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
246
247 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
248
249 %clean
250 rm -rf $RPM_BUILD_ROOT
251
252 %triggerun server -- ssh-server
253 if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
254         touch /var/run/sshd.restart
255 fi
256
257 %triggerun server -- openssh-server < 2.5.0p1
258 # Count the number of HostKey and HostDsaKey statements we have.
259 gawk    'BEGIN {IGNORECASE=1}
260          /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
261          END {exit sawhostkey}' /etc/ssh/sshd_config
262 # And if we only found one, we know the client was relying on the old default
263 # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
264 # specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
265 # one nullifies the default, which would have loaded both.
266 if [ $? -eq 1 ] ; then
267         echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
268         echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
269 fi
270
271 %triggerpostun server -- ssh-server
272 if [ "$1" != 0 ] ; then
273         /sbin/chkconfig --add sshd
274         if test -f /var/run/sshd.restart ; then
275                 rm -f /var/run/sshd.restart
276                 /sbin/service sshd start > /dev/null 2>&1 || :
277         fi
278 fi
279
280 %pre server
281 %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
282 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
283         -g sshd -M -r sshd 2>/dev/null || :
284
285 %post server
286 /sbin/chkconfig --add sshd
287
288 %postun server
289 /sbin/service sshd condrestart > /dev/null 2>&1 || :
290
291 %preun server
292 if [ "$1" = 0 ]
293 then
294         /sbin/service sshd stop > /dev/null 2>&1 || :
295         /sbin/chkconfig --del sshd
296 fi
297
298 %files
299 %defattr(-,root,root)
300 %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
301 %attr(0755,root,root) %{_bindir}/scp
302 %attr(0644,root,root) %{_mandir}/man1/scp.1*
303 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
304 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
305 %if ! %{rescue}
306 %attr(0755,root,root) %{_bindir}/ssh-keygen
307 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
308 %attr(0755,root,root) %dir %{_libexecdir}/openssh
309 %endif
310 %if %{scard}
311 %attr(0755,root,root) %dir %{_datadir}/openssh
312 %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
313 %endif
314
315 %files clients
316 %defattr(-,root,root)
317 %attr(4755,root,root) %{_bindir}/ssh
318 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
319 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
320 %attr(-,root,root) %{_bindir}/slogin
321 %attr(-,root,root) %{_mandir}/man1/slogin.1*
322 %if ! %{rescue}
323 %attr(0755,root,root) %{_bindir}/ssh-agent
324 %attr(0755,root,root) %{_bindir}/ssh-add
325 %attr(0755,root,root) %{_bindir}/ssh-keyscan
326 %attr(0755,root,root) %{_bindir}/sftp
327 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
328 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
329 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
330 %attr(0644,root,root) %{_mandir}/man1/sftp.1*
331 %endif
332
333 %if ! %{rescue}
334 %files server
335 %defattr(-,root,root)
336 %dir %attr(0111,root,root) %{_var}/empty/sshd
337 %attr(0755,root,root) %{_sbindir}/sshd
338 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
339 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
340 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
341 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
342 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
343 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
344 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
345 %endif
346
347 %if ! %{no_x11_askpass}
348 %files askpass
349 %defattr(-,root,root)
350 %doc x11-ssh-askpass-%{aversion}/README
351 %doc x11-ssh-askpass-%{aversion}/ChangeLog
352 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
353 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
354 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
355 %endif
356
357 %if ! %{no_gnome_askpass}
358 %files askpass-gnome
359 %defattr(-,root,root)
360 %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
361 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
362 %endif
363
364 %changelog
365 * Fri May 10 2002 Damien Miller <djm@mindrot.org>
366 - Merge in spec changes from RedHat, reorgansie a little
367 - Add Privsep user, group and directory
368
369 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
370 - bump and grind (through the build system)
371
372 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
373 - require sharutils for building (mindrot #137)
374 - require db1-devel only when building for 6.x (#55105), which probably won't
375   work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
376 - require pam-devel by file (not by package name) again
377 - add Markus's patch to compile with OpenSSL 0.9.5a (from
378   http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
379   building for 6.x
380
381 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
382 - update to 3.1p1
383
384 * Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
385 - update to SNAP-20020305
386 - drop debug patch, fixed upstream
387
388 * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
389 - update to SNAP-20020220 for testing purposes (you've been warned, if there's
390   anything to be warned about, gss patches won't apply, I don't mind)
391
392 * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
393 - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
394   exchange, authentication, and named key support
395
396 * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
397 - remove dependency on db1-devel, which has just been swallowed up whole
398   by gnome-libs-devel
399
400 * Sun Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
401 - adjust build dependencies so that build6x actually works right (fix
402   from Hugo van der Kooij)
403
404 * Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
405 - update to 3.0.2p1
406
407 * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
408 - update to 3.0.1p1
409
410 * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
411 - update to current CVS (not for use in distribution)
412
413 * Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
414 - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
415   3.0p1 spec file and init script
416
417 * Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
418 - update to 3.0p1
419 - update to x11-ssh-askpass 1.2.4.1
420 - change build dependency on a file from pam-devel to the pam-devel package
421 - replace primes with moduli
422
423 * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
424 - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
425
426 * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
427 - Merge changes to rescue build from current sysadmin survival cd
428
429 * Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
430 - fix scp's server's reporting of file sizes, and build with the proper
431   preprocessor define to get large-file capable open(), stat(), etc.
432   (sftp has been doing this correctly all along) (#51827)
433 - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
434 - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
435 - mark profile.d scriptlets as config files (#42337)
436 - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
437 - change a couple of log() statements to debug() statements (#50751)
438 - pull cvs patch to add -t flag to sshd (#28611)
439 - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
440
441 * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
442 - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
443
444 * Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
445 - pull cvs patch to fix remote port forwarding with protocol 2
446
447 * Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
448 - pull cvs patch to add session initialization to no-pty sessions
449 - pull cvs patch to not cut off challengeresponse auth needlessly
450 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
451   it by default on a system that doesn't have X installed (#49263)
452
453 * Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
454 - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
455
456 * Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
457 - pass OPTIONS correctly to initlog (#50151)
458
459 * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
460 - switch to x11-ssh-askpass 1.2.2
461
462 * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
463 - rebuild in new environment
464
465 * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
466 - disable the gssapi patch
467
468 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
469 - update to 2.9p2
470 - refresh to a new version of the gssapi patch
471
472 * Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
473 - change Copyright: BSD to License: BSD
474 - add Markus Friedl's unverified patch for the cookie file deletion problem
475   so that we can verify it
476 - drop patch to check if xauth is present (was folded into cookie patch)
477 - don't apply gssapi patches for the errata candidate
478 - clear supplemental groups list at startup
479
480 * Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
481 - fix an error parsing the new default sshd_config
482 - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
483   dealing with comments right
484
485 * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
486 - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
487   to be removed before the next beta cycle because it's a big departure
488   from the upstream version
489
490 * Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
491 - finish marking strings in the init script for translation
492 - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
493   at startup (change merged from openssh.com init script, originally by
494   Pekka Savola)
495 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
496   it by default on a system that doesn't have X installed
497
498 * Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
499 - update to 2.9
500 - drop various patches that came from or went upstream or to or from CVS
501
502 * Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
503 - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
504
505 * Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
506 - remove explicit openssl requirement, fixes builddistro issue
507 - make initscript stop() function wait until sshd really dead to avoid 
508   races in condrestart
509
510 * Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
511 - mention that challengereponse supports PAM, so disabling password doesn't
512   limit users to pubkey and rsa auth (#34378)
513 - bypass the daemon() function in the init script and call initlog directly,
514   because daemon() won't start a daemon it detects is already running (like
515   open connections)
516 - require the version of openssl we had when we were built
517
518 * Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
519 - make do_pam_setcred() smart enough to know when to establish creds and
520   when to reinitialize them
521 - add in a couple of other fixes from Damien for inclusion in the errata
522
523 * Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
524 - update to 2.5.2p2
525 - call setcred() again after initgroups, because the "creds" could actually
526   be group memberships
527
528 * Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
529 - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
530 - don't enable challenge-response by default until we find a way to not
531   have too many userauth requests (we may make up to six pubkey and up to
532   three password attempts as it is)
533 - remove build dependency on rsh to match openssh.com's packages more closely
534
535 * Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
536 - remove dependency on openssl -- would need to be too precise
537
538 * Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
539 - rebuild in new environment
540
541 * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
542 - Revert the patch to move pam_open_session.
543 - Init script and spec file changes from Pekka Savola. (#28750)
544 - Patch sftp to recognize '-o protocol' arguments. (#29540)
545
546 * Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
547 - Chuck the closing patch.
548 - Add a trigger to add host keys for protocol 2 to the config file, now that
549   configuration file syntax requires us to specify it with HostKey if we
550   specify any other HostKey values, which we do.
551
552 * Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
553 - Redo patch to move pam_open_session after the server setuid()s to the user.
554 - Rework the nopam patch to use be picked up by autoconf.
555
556 * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
557 - Update for 2.5.1p1.
558 - Add init script mods from Pekka Savola.
559 - Tweak the init script to match the CVS contrib script more closely.
560 - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
561   adding id_rsa.
562
563 * Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
564 - Update for 2.5.0p1.
565 - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
566 - Resync with parts of Damien Miller's openssh.spec from CVS, including
567   update of x11 askpass to 1.2.0.
568 - Only require openssl (don't prereq) because we generate keys in the init
569   script now.
570
571 * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
572 - Don't open a PAM session until we've forked and become the user (#25690).
573 - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
574   host the user is attempting a login from.
575 - Resync with parts of Damien Miller's openssh.spec from CVS.
576 - Don't expose KbdInt responses in debug messages (from CVS).
577 - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
578
579 * Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
580 - i18n-tweak to initscript.
581
582 * Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
583 - More gettextizing.
584 - Close all files after going into daemon mode (needs more testing).
585 - Extract patch from CVS to handle auth banners (in the client).
586 - Extract patch from CVS to handle compat weirdness.
587
588 * Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
589 - Finish with the gettextizing.
590
591 * Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
592 - Fix a bug in auth2-pam.c (#23877)
593 - Gettextize the init script.
594
595 * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
596 - Incorporate a switch for using PAM configs for 6.x, just in case.
597
598 * Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
599 - Incorporate Bero's changes for a build specifically for rescue CDs.
600
601 * Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
602 - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
603   succeeded, to allow public-key authentication after a failure with "none"
604   authentication.  (#21268)
605
606 * Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
607 - Update to x11-askpass 1.1.1. (#21301)
608 - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
609
610 * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
611 - Merge multiple PAM text messages into subsequent prompts when possible when
612   doing keyboard-interactive authentication.
613
614 * Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
615 - Disable the built-in MD5 password support.  We're using PAM.
616 - Take a crack at doing keyboard-interactive authentication with PAM, and
617   enable use of it in the default client configuration so that the client
618   will try it when the server disallows password authentication.
619 - Build with debugging flags.  Build root policies strip all binaries anyway.
620
621 * Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
622 - Use DESTDIR instead of %%makeinstall.
623 - Remove /usr/X11R6/bin from the path-fixing patch.
624
625 * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
626 - Add the primes file from the latest snapshot to the main package (#20884).
627 - Add the dev package to the prereq list (#19984).
628 - Remove the default path and mimic login's behavior in the server itself.
629
630 * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
631 - Resync with conditional options in Damien Miller's .spec file for an errata.
632 - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
633
634 * Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
635 - Update to OpenSSH 2.3.0p1.
636 - Update to x11-askpass 1.1.0.
637 - Enable keyboard-interactive authentication.
638
639 * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
640 - Update to ssh-askpass-x11 1.0.3.
641 - Change authentication related messages to be private (#19966).
642
643 * Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
644 - Patch ssh-keygen to be able to list signatures for DSA public key files
645   it generates.
646
647 * Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
648 - Add BuildPreReq on /usr/include/security/pam_appl.h to be sure we always
649   build PAM authentication in.
650 - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
651 - Clean out no-longer-used patches.
652 - Patch ssh-add to try to add both identity and id_dsa, and to error only
653   when neither exists.
654
655 * Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
656 - Update x11-askpass to 1.0.2. (#17835)
657 - Add BuildPreReqs for /bin/login and /usr/bin/rsh so that configure will
658   always find them in the right place. (#17909)
659 - Set the default path to be the same as the one supplied by /bin/login, but
660   add /usr/X11R6/bin. (#17909)
661 - Try to handle obsoletion of ssh-server more cleanly.  Package names
662   are different, but init script name isn't. (#17865)
663
664 * Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
665 - Update to 2.2.0p1. (#17835)
666 - Tweak the init script to allow proper restarting. (#18023)
667
668 * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
669 - Update to 20000823 snapshot.
670 - Change subpackage requirements from %%{version} to %%{version}-%%{release}
671 - Back out the pipe patch.
672
673 * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
674 - Update to 2.1.1p4, which includes fixes for config file parsing problems.
675 - Move the init script back.
676 - Add Damien's quick fix for wackiness.
677
678 * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
679 - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
680
681 * Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
682 - Move condrestart to server postun.
683 - Move key generation to init script.
684 - Actually use the right patch for moving the key generation to the init script.
685 - Clean up the init script a bit.
686
687 * Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
688 - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
689
690 * Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
691 - Update to 2.1.1p2.
692 - Use of strtok() considered harmful.
693
694 * Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
695 - Get the build root out of the man pages.
696
697 * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
698 - Add and use condrestart support in the init script.
699 - Add newer initscripts as a prereq.
700
701 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
702 - Build in new environment (release 2)
703 - Move -clients subpackage to Applications/Internet group
704
705 * Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
706 - Update to 2.2.1p1
707
708 * Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
709 - Patch to build with neither RSA nor RSAref.
710 - Miscellaneous FHS-compliance tweaks.
711 - Fix for possibly-compressed man pages.
712
713 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
714 - Updated for new location
715 - Updated for new gnome-ssh-askpass build
716
717 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
718 - Added Jim Knoble's <jmknoble@pobox.com> askpass
719
720 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
721 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
722
723 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
724 - Added 'Obsoletes' directives
725
726 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
727 - Use make install
728 - Subpackages
729
730 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
731 - Added links for slogin
732 - Fixed perms on manpages
733
734 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
735 - Renamed init script
736
737 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
738 - Back to old binary names
739
740 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
741 - Use autoconf
742 - New binary names
743
744 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
745 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
This page took 0.090736 seconds and 5 git commands to generate.