]> andersk Git - gssapi-openssh.git/blob - openssh/contrib/caldera/openssh.spec
Import of OpenSSH 3.4p1
[gssapi-openssh.git] / openssh / contrib / caldera / openssh.spec
1
2 # Some of this will need re-evaluation post-LSB.  The SVIdir is there
3 # because the link appeared broken.  The rest is for easy compilation,
4 # the tradeoff open to discussion.  (LC957)
5
6 %define SVIdir          /etc/rc.d/init.d
7 %{!?_defaultdocdir:%define      _defaultdocdir  %{_prefix}/share/doc/packages}
8 %{!?SVIcdir:%define             SVIcdir         /etc/sysconfig/daemons}
9
10 %define _mandir         %{_prefix}/share/man/en
11 %define _sysconfdir     /etc/ssh
12 %define _libexecdir     %{_libdir}/ssh
13
14 # Do we want to disable root_login? (1=yes 0=no)
15 %define no_root_login 0
16
17 #old cvs stuff.  please update before use.  may be deprecated.
18 %define use_stable      1
19 %if %{use_stable}
20   %define version       3.4p1
21   %define cvs           %{nil}
22   %define release       2
23 %else
24   %define version       2.9.9p2
25   %define cvs           cvs20011009
26   %define release       0r1
27 %endif
28 %define xsa             x11-ssh-askpass         
29 %define askpass         %{xsa}-1.2.4.1
30
31 # OpenSSH privilege separation requires a user & group ID
32 %define sshd_uid    67
33 %define sshd_gid    67
34
35 Name            : openssh
36 Version         : %{version}%{cvs}
37 Release         : %{release}
38 Group           : System/Network
39
40 Summary         : OpenSSH free Secure Shell (SSH) implementation.
41 Summary(de)     : OpenSSH - freie Implementation der Secure Shell (SSH).
42 Summary(es)     : OpenSSH implementación libre de Secure Shell (SSH).
43 Summary(fr)     : Implémentation libre du shell sécurisé OpenSSH (SSH).
44 Summary(it)     : Implementazione gratuita OpenSSH della Secure Shell.
45 Summary(pt)     : Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH).
46 Summary(pt_BR)  : Implementação livre OpenSSH do protocolo Secure Shell (SSH).
47
48 Copyright       : BSD
49 Packager        : Raymund Will <ray@caldera.de>
50 URL             : http://www.openssh.com/
51
52 Obsoletes       : ssh, ssh-clients, openssh-clients
53
54 BuildRoot       : /tmp/%{name}-%{version}
55 BuildRequires   : XFree86-imake
56
57 # %{use_stable}==1:     ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable
58 # %{use_stable}==0:     :pserver:cvs@bass.directhit.com:/cvs/openssh_cvs
59 Source0: see-above:/.../openssh-%{version}.tar.gz
60 %if %{use_stable}
61 Source1: see-above:/.../openssh-%{version}.tar.gz.sig
62 %endif
63 Source2: http://www.ntrnet.net/~jmknoble/software/%{xsa}/%{askpass}.tar.gz
64 Source3: http://www.openssh.com/faq.html
65
66 %Package server
67 Group           : System/Network
68 Requires        : openssh = %{version}
69 Obsoletes       : ssh-server
70
71 Summary         : OpenSSH Secure Shell protocol server (sshd).
72 Summary(de)     : OpenSSH Secure Shell Protocol-Server (sshd).
73 Summary(es)     : Servidor del protocolo OpenSSH Secure Shell (sshd).
74 Summary(fr)     : Serveur de protocole du shell sécurisé OpenSSH (sshd).
75 Summary(it)     : Server OpenSSH per il protocollo Secure Shell (sshd).
76 Summary(pt)     : Servidor do protocolo 'Secure Shell' OpenSSH (sshd).
77 Summary(pt_BR)  : Servidor do protocolo Secure Shell OpenSSH (sshd).
78
79
80 %Package askpass
81 Group           : System/Network
82 Requires        : openssh = %{version}
83 URL             : http://www.ntrnet.net/~jmknoble/software/x11-ssh-askpass/
84 Obsoletes       : ssh-extras
85
86 Summary         : OpenSSH X11 pass-phrase dialog.
87 Summary(de)     : OpenSSH X11 Passwort-Dialog.
88 Summary(es)     : Aplicación de petición de frase clave OpenSSH X11.
89 Summary(fr)     : Dialogue pass-phrase X11 d'OpenSSH.
90 Summary(it)     : Finestra di dialogo X11 per la frase segreta di OpenSSH.
91 Summary(pt)     : Diálogo de pedido de senha para X11 do OpenSSH.
92 Summary(pt_BR)  : Diálogo de pedido de senha para X11 do OpenSSH.
93
94
95 %Description
96 OpenSSH (Secure Shell) provides access to a remote system. It replaces
97 telnet, rlogin,  rexec, and rsh, and provides secure encrypted 
98 communications between two untrusted hosts over an insecure network.  
99 X11 connections and arbitrary TCP/IP ports can also be forwarded over 
100 the secure channel.
101
102 %Description -l de
103 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es ersetzt
104 telnet, rlogin, rexec und rsh und stellt eine sichere, verschlüsselte
105 Verbindung zwischen zwei nicht vertrauenswürdigen Hosts über eine unsicheres
106 Netzwerk her. X11 Verbindungen und beliebige andere TCP/IP Ports können ebenso
107 über den sicheren Channel weitergeleitet werden.
108
109 %Description -l es
110 OpenSSH (Secure Shell) proporciona acceso a sistemas remotos. Reemplaza a
111 telnet, rlogin, rexec, y rsh, y proporciona comunicaciones seguras encriptadas
112 entre dos equipos entre los que no se ha establecido confianza a través de una
113 red insegura. Las conexiones X11 y puertos TCP/IP arbitrarios también pueden
114 ser canalizadas sobre el canal seguro.
115
116 %Description -l fr
117 OpenSSH (Secure Shell) fournit un accès à un système distant. Il remplace
118 telnet, rlogin, rexec et rsh, tout en assurant des communications cryptées
119 securisées entre deux hôtes non fiabilisés sur un réseau non sécurisé. Des
120 connexions X11 et des ports TCP/IP arbitraires peuvent également être
121 transmis sur le canal sécurisé.
122
123 %Description -l it
124 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
125 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni sicure
126 e crittate tra due host non fidati su una rete non sicura. Le connessioni
127 X11 ad una porta TCP/IP arbitraria possono essere inoltrate attraverso
128 un canale sicuro.
129
130 %Description -l pt
131 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
132 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e cifradas
133 entre duas máquinas sem confiança mútua sobre uma rede insegura.
134 Ligações X11 e portos TCP/IP arbitrários também poder ser reenviados
135 pelo canal seguro.
136
137 %Description -l pt_BR
138 O OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
139 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e criptografadas
140 entre duas máquinas sem confiança mútua sobre uma rede insegura.
141 Ligações X11 e portas TCP/IP arbitrárias também podem ser reenviadas
142 pelo canal seguro.
143
144 %Description server
145 This package installs the sshd, the server portion of OpenSSH. 
146
147 %Description -l de server
148 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
149
150 %Description -l es server
151 Este paquete instala sshd, la parte servidor de OpenSSH.
152
153 %Description -l fr server
154 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
155
156 %Description -l it server
157 Questo pacchetto installa sshd, il server di OpenSSH.
158
159 %Description -l pt server
160 Este pacote intala o sshd, o servidor do OpenSSH.
161
162 %Description -l pt_BR server
163 Este pacote intala o sshd, o servidor do OpenSSH.
164
165 %Description askpass
166 This package contains an X11-based pass-phrase dialog used per
167 default by ssh-add(1). It is based on %{askpass}
168 by Jim Knoble <jmknoble@pobox.com>.
169
170
171 %Prep
172 %setup %([ -z "%{cvs}" ] || echo "-n %{name}_cvs") -a2
173 %if ! %{use_stable}
174   autoreconf
175 %endif
176
177
178 %Build
179 CFLAGS="$RPM_OPT_FLAGS" \
180 %configure \
181             --with-pam \
182             --with-tcp-wrappers \
183             --with-ipv4-default \
184             --sysconfdir=%{_sysconfdir}/ssh \
185             --libexecdir=%{_libexecdir}/openssh \
186             --with-privsep-path=%{_var}/empty/sshd \
187             #leave this line for easy edits.
188
189 %__make CFLAGS="$RPM_OPT_FLAGS"
190
191 cd %{askpass}
192 %configure \
193             #leave this line for easy edits.
194
195 xmkmf
196 %__make includes
197 %__make
198
199
200 %Install
201 [ %{buildroot} != "/" ] && rm -rf %{buildroot}
202
203 %makeinstall
204 %makeinstall -C %{askpass} \
205     BINDIR=%{_libexecdir} \
206     MANPATH=%{_mandir} \
207     DESTDIR=%{buildroot}
208
209 # OpenLinux specific configuration
210 mkdir -p %{buildroot}{/etc/pam.d,%{SVIcdir},%{SVIdir}}
211 mkdir -p %{buildroot}%{_var}/empty/sshd
212
213 # enabling X11 forwarding on the server is convenient and okay,
214 # on the client side it's a potential security risk!
215 %__perl -pi -e 's:#X11Forwarding no:X11Forwarding yes:g' \
216     %{buildroot}%{_sysconfdir}/sshd_config
217
218 %if %{no_root_login}
219 %__perl -pi -e 's:#PermitRootLogin yes:PermitRootLogin no:g' \
220     %{buildroot}%{_sysconfdir}/sshd_config
221 %endif
222
223 install -m644 contrib/caldera/sshd.pam %{buildroot}/etc/pam.d/sshd
224 # FIXME: disabled, find out why this doesn't work with nis
225 %__perl -pi -e 's:(.*pam_limits.*):#$1:' \
226     %{buildroot}/etc/pam.d/sshd
227
228 install -m 0755 contrib/caldera/sshd.init %{buildroot}%{SVIdir}/sshd
229
230 # the last one is needless, but more future-proof
231 find %{buildroot}%{SVIdir} -type f -exec \
232     %__perl -pi -e 's:\@SVIdir\@:%{SVIdir}:g;\
233                     s:\@sysconfdir\@:%{_sysconfdir}:g; \
234                     s:/usr/sbin:%{_sbindir}:g'\
235     \{\} \;
236
237 cat <<-EoD > %{buildroot}%{SVIcdir}/sshd
238         IDENT=sshd
239         DESCRIPTIVE="OpenSSH secure shell daemon"
240         # This service will be marked as 'skipped' on boot if there
241         # is no host key. Use ssh-host-keygen to generate one
242         ONBOOT="yes"
243         OPTIONS=""
244 EoD
245
246 SKG=%{buildroot}%{_sbindir}/ssh-host-keygen
247 install -m 0755 contrib/caldera/ssh-host-keygen $SKG
248 # Fix up some path names in the keygen toy^Hol
249     %__perl -pi -e 's:\@sysconfdir\@:%{_sysconfdir}:g; \
250                     s:\@sshkeygen\@:%{_bindir}/ssh-keygen:g' \
251         %{buildroot}%{_sbindir}/ssh-host-keygen
252
253 # This looks terrible.  Expect it to change.
254 # install remaining docs
255 DocD="%{buildroot}%{_defaultdocdir}/%{name}-%{version}"
256 mkdir -p $DocD/%{askpass}
257 cp -a CREDITS ChangeLog LICENCE OVERVIEW README* TODO  $DocD
258 install -p -m 0444 %{SOURCE3}  $DocD/faq.html
259 cp -a %{askpass}/{README,ChangeLog,TODO,SshAskpass*.ad}  $DocD/%{askpass}
260 %if %{use_stable}
261   cp -p %{askpass}/%{xsa}.man $DocD/%{askpass}/%{xsa}.1
262 %else
263   cp -p %{askpass}/%{xsa}.man %{buildroot}%{_mandir}man1/%{xsa}.1
264   ln -s  %{xsa}.1 %{buildroot}%{_mandir}man1/ssh-askpass.1
265 %endif
266
267 find %{buildroot}%{_mandir} -type f -not -name  '*.gz' -print0 | xargs -0r %__gzip -9nf
268 rm %{buildroot}%{_mandir}/man1/slogin.1 && \
269     ln -s %{_mandir}/man1/ssh.1.gz \
270     %{buildroot}%{_mandir}/man1/slogin.1.gz
271
272
273 %Clean
274 #%{rmDESTDIR}
275 [ %{buildroot} != "/" ] && rm -rf %{buildroot}
276
277 %Post
278 # Generate host key when none is present to get up and running,
279 # both client and server require this for host-based auth!
280 # ssh-host-keygen checks for existing keys.
281 /usr/sbin/ssh-host-keygen
282 : # to protect the rpm database
283
284 %pre server
285 %{_sbindir}/groupadd -g %{sshd_gid} sshd 2>/dev/null || :
286 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
287         -c "SSH Daemon virtual user" -g sshd sshd 2>/dev/null || :
288 : # to protect the rpm database
289
290 %Post server
291 if [ -x %{LSBinit}-install ]; then
292   %{LSBinit}-install sshd
293 else
294   lisa --SysV-init install sshd S55 2:3:4:5 K45 0:1:6
295 fi
296
297 ! %{SVIdir}/sshd status || %{SVIdir}/sshd restart
298 : # to protect the rpm database
299
300
301 %PreUn server
302 [ "$1" = 0 ] || exit 0
303
304 ! %{SVIdir}/sshd status || %{SVIdir}/sshd stop
305 : # to protect the rpm database
306
307
308 %PostUn server
309 if [ -x %{LSBinit}-remove ]; then
310   %{LSBinit}-remove sshd
311 else
312   lisa --SysV-init remove sshd $1
313 fi
314 : # to protect the rpm database
315
316
317 %Files 
318 %defattr(-,root,root)
319 %dir %{_sysconfdir}
320 %config %{_sysconfdir}/ssh_config
321 %{_bindir}/*
322 %dir %{_libexecdir}
323 %{_sbindir}/ssh-host-keygen
324 %dir %{_defaultdocdir}/%{name}-%{version}
325 %{_defaultdocdir}/%{name}-%{version}/CREDITS
326 %{_defaultdocdir}/%{name}-%{version}/ChangeLog
327 %{_defaultdocdir}/%{name}-%{version}/LICENCE
328 %{_defaultdocdir}/%{name}-%{version}/OVERVIEW
329 %{_defaultdocdir}/%{name}-%{version}/README*
330 %{_defaultdocdir}/%{name}-%{version}/TODO
331 %{_defaultdocdir}/%{name}-%{version}/faq.html
332 %{_mandir}/man1/*
333  
334 %Files server
335 %defattr(-,root,root)
336 %dir %attr(0700,root,root) %{_var}/empty/sshd
337 %config %{SVIdir}/sshd
338 %config /etc/pam.d/sshd
339 %config %{_sysconfdir}/moduli
340 %config %{_sysconfdir}/sshd_config
341 %config %{SVIcdir}/sshd
342 %{_libexecdir}/sftp-server
343 %{_sbindir}/sshd
344 %{_mandir}/man8/sftp-server.8.gz
345 %{_mandir}/man8/sshd.8.gz
346  
347 %Files askpass
348 %defattr(-,root,root)
349 %{_libexecdir}/ssh-askpass
350 %{_libexecdir}/x11-ssh-askpass
351 %{_defaultdocdir}/%{name}-%{version}/%{askpass}
352  
353
354 %ChangeLog
355 * Mon Jan 01 1998 ...
356 Template Version: 1.31
357
358 $Id$
This page took 0.068987 seconds and 5 git commands to generate.