]> andersk Git - openssh.git/blobdiff - contrib/suse/openssh.spec
- (djm) Crank RPM spec versions
[openssh.git] / contrib / suse / openssh.spec
index ab16c40ba9349170730208a4f7614a8b203bc5de..7eb71adf4bd1a5e9f3d8bd2970c93703c1ab74de 100644 (file)
@@ -1,6 +1,7 @@
-Summary: OpenSSH, a free Secure Shell (SSH) implementation
+Summary: OpenSSH, a free Secure Shell (SSH) protocol implementation
 Name: openssh
-Version: 1.2.3pre2
+Version: 3.8p1
+URL: http://www.openssh.com/
 Release: 1
 Source0: openssh-%{version}.tar.gz
 Copyright: BSD
@@ -15,32 +16,12 @@ Obsoletes: ssh
 #   TCP Wrappers (nkitb),
 #   and Gnome (glibdev, gtkdev, and gnlibsd)
 #
-BuildPrereq: openssl-devel
+BuildPrereq: openssl
 BuildPrereq: nkitb
 BuildPrereq: glibdev
 BuildPrereq: gtkdev
 BuildPrereq: gnlibsd
 
-%package clients
-Summary: OpenSSH Secure Shell protocol clients
-Requires: openssh
-Group: Applications/Internet
-Obsoletes: ssh-clients
-
-%package server
-Summary: OpenSSH Secure Shell protocol server (sshd)
-Requires: openssh
-Group: System Environment/Daemons
-PreReq: openssh
-Obsoletes: ssh-server
-
-%package askpass
-Summary: OpenSSH GNOME passphrase dialog
-Group: Applications/Internet
-Requires: openssh
-Obsoletes: ssh-extras
-Obsoletes: ssh-askpass
-
 %description
 Ssh (Secure Shell) a program for logging into a remote machine and for
 executing commands in a remote machine.  It is intended to replace
@@ -49,56 +30,19 @@ two untrusted hosts over an insecure network.  X11 connections and
 arbitrary TCP/IP ports can also be forwarded over the secure channel.
 
 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
-up to date in terms of security and features, as well as removing all 
-patented algorithms to seperate libraries (OpenSSL).
-
-This package includes the core files necessary for both the OpenSSH
-client and server.  To make this package useful, you should also
-install openssh-clients, openssh-server, or both.
-
-%description clients
-Ssh (Secure Shell) a program for logging into a remote machine and for
-executing commands in a remote machine.  It is intended to replace
-rlogin and rsh, and provide secure encrypted communications between
-two untrusted hosts over an insecure network.  X11 connections and
-arbitrary TCP/IP ports can also be forwarded over the secure channel.
-
-OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
-up to date in terms of security and features, as well as removing all 
-patented algorithms to seperate libraries (OpenSSL).
-
-This package includes the clients necessary to make encrypted connections
-to SSH servers.
-
-%description server
-Ssh (Secure Shell) a program for logging into a remote machine and for
-executing commands in a remote machine.  It is intended to replace
-rlogin and rsh, and provide secure encrypted communications between
-two untrusted hosts over an insecure network.  X11 connections and
-arbitrary TCP/IP ports can also be forwarded over the secure channel.
-
-OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
-up to date in terms of security and features, as well as removing all 
+up to date in terms of security and features, as well as removing all
 patented algorithms to seperate libraries (OpenSSL).
 
-This package contains the secure shell daemon. The sshd is the server 
-part of the secure shell protocol and allows ssh clients to connect to 
-your host.
-
-%description askpass
-Ssh (Secure Shell) a program for logging into a remote machine and for
-executing commands in a remote machine.  It is intended to replace
-rlogin and rsh, and provide secure encrypted communications between
-two untrusted hosts over an insecure network.  X11 connections and
-arbitrary TCP/IP ports can also be forwarded over the secure channel.
-
-OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
-up to date in terms of security and features, as well as removing all 
-patented algorithms to seperate libraries (OpenSSL).
-
-This package contains the GNOME passphrase dialog.
+This package includes all files necessary for both the OpenSSH
+client and server. Additionally, this package contains the GNOME
+passphrase dialog.
 
 %changelog
+* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
+- Glob manpages to catch compressed files
+* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
+- Updated for new location
+- Updated for new gnome-ssh-askpass build
 * Sun Dec 26 1999 Chris Saia <csaia@wtower.com>
 - Made symlink to gnome-ssh-askpass called ssh-askpass
 * Wed Nov 24 1999 Chris Saia <csaia@wtower.com>
@@ -144,10 +88,22 @@ This package contains the GNOME passphrase dialog.
 
 %build
 CFLAGS="$RPM_OPT_FLAGS" \
-./configure --prefix=/usr --sysconfdir=/etc/ssh --with-gnome-askpass \
-            --with-tcp-wrappers --with-ipv4-default
+./configure    --prefix=/usr \
+               --sysconfdir=/etc/ssh \
+               --datadir=/usr/share/openssh \
+               --with-pam \
+               --with-gnome-askpass \
+               --with-tcp-wrappers \
+               --with-ipv4-default \
+               --libexecdir=/usr/lib/ssh
 make
 
+cd contrib
+gcc -O -g `gnome-config --cflags gnome gnomeui` \
+       gnome-ssh-askpass.c -o gnome-ssh-askpass \
+       `gnome-config --libs gnome gnomeui`
+cd ..
+
 %install
 rm -rf $RPM_BUILD_ROOT
 make install DESTDIR=$RPM_BUILD_ROOT/
@@ -155,17 +111,19 @@ install -d $RPM_BUILD_ROOT/etc/ssh/
 install -d $RPM_BUILD_ROOT/etc/pam.d/
 install -d $RPM_BUILD_ROOT/sbin/init.d/
 install -d $RPM_BUILD_ROOT/var/adm/fillup-templates
-install -m644 sshd.pam.generic $RPM_BUILD_ROOT/etc/pam.d/sshd
-install -m744 packages/suse/rc.sshd $RPM_BUILD_ROOT/sbin/init.d/sshd
+install -d $RPM_BUILD_ROOT/usr/lib/ssh
+install -m644 contrib/sshd.pam.generic $RPM_BUILD_ROOT/etc/pam.d/sshd
+install -m744 contrib/suse/rc.sshd $RPM_BUILD_ROOT/sbin/init.d/sshd
 ln -s ../../sbin/init.d/sshd $RPM_BUILD_ROOT/usr/sbin/rcsshd
-ln -s gnome-ssh-askpass $RPM_BUILD_ROOT/usr/libexec/ssh/ssh-askpass
-install -m744 packages/suse/rc.config.sshd \
+install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT/usr/lib/ssh/gnome-ssh-askpass
+ln -s gnome-ssh-askpass $RPM_BUILD_ROOT/usr/lib/ssh/ssh-askpass
+install -m744 contrib/suse/rc.config.sshd \
    $RPM_BUILD_ROOT/var/adm/fillup-templates
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post server
+%post
 if [ "$1" = 1 ]; then
   echo "Creating SSH stop/start scripts in the rc directories..."
   ln -s ../sshd /sbin/init.d/rc2.d/K20sshd
@@ -182,62 +140,60 @@ else
   echo "  /var/adm/fillup-templates/rc.config.sshd"
 fi
 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
-        echo "Generating SSH host key..."
+       echo "Generating SSH host key..."
        /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
 fi
+if [ ! -f /etc/ssh/ssh_host_dsa_key -o ! -s /etc/ssh/ssh_host_dsa_key ]; then
+       echo "Generating SSH DSA host key..."
+       /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N '' >&2
+fi
 if test -r /var/run/sshd.pid
 then
-        echo "Restarting the running SSH daemon..."
+       echo "Restarting the running SSH daemon..."
        /usr/sbin/rcsshd restart >&2
 fi
 
-%preun server
+%preun
 if [ "$1" = 0 ]
 then
-        echo "Stopping the SSH daemon..."
+       echo "Stopping the SSH daemon..."
        /usr/sbin/rcsshd stop >&2
        echo "Removing SSH stop/start scripts from the rc directories..."
-        rm /sbin/init.d/rc2.d/K20sshd
-        rm /sbin/init.d/rc2.d/S20sshd
-        rm /sbin/init.d/rc3.d/K20sshd
-        rm /sbin/init.d/rc3.d/S20sshd
+       rm /sbin/init.d/rc2.d/K20sshd
+       rm /sbin/init.d/rc2.d/S20sshd
+       rm /sbin/init.d/rc3.d/K20sshd
+       rm /sbin/init.d/rc3.d/S20sshd
 fi
 
 %files
 %defattr(-,root,root)
-%doc COPYING.Ylonen ChangeLog OVERVIEW README README.Ylonen 
-%doc RFC.nroff TODO UPGRADING CREDITS
+%doc ChangeLog OVERVIEW README*
+%doc RFC.nroff TODO CREDITS LICENCE
+%attr(0755,root,root) %dir /etc/ssh
+%attr(0644,root,root) %config /etc/ssh/ssh_config
+%attr(0600,root,root) %config /etc/ssh/sshd_config
+%attr(0600,root,root) %config /etc/ssh/moduli
+%attr(0644,root,root) %config /etc/pam.d/sshd
+%attr(0755,root,root) %config /sbin/init.d/sshd
 %attr(0755,root,root) /usr/bin/ssh-keygen
 %attr(0755,root,root) /usr/bin/scp
-%attr(0644,root,root) %doc /usr/man/man1/ssh-keygen.1
-%attr(0644,root,root) %doc /usr/man/man1/scp.1
-%attr(0755,root,root) %dir /etc/ssh
-%attr(0755,root,root) %dir /usr/libexec/ssh
-
-%files clients
-%defattr(-,root,root)
 %attr(4755,root,root) /usr/bin/ssh
+%attr(-,root,root) /usr/bin/slogin
 %attr(0755,root,root) /usr/bin/ssh-agent
 %attr(0755,root,root) /usr/bin/ssh-add
-%attr(0644,root,root) %doc /usr/man/man1/ssh.1
-%attr(0644,root,root) %doc /usr/man/man1/ssh-agent.1
-%attr(0644,root,root) %doc /usr/man/man1/ssh-add.1
-%attr(0644,root,root) %config /etc/ssh/ssh_config
-%attr(-,root,root) /usr/bin/slogin
-%attr(-,root,root) %doc /usr/man/man1/slogin.1
-
-%files server
-%defattr(-,root,root)
+%attr(0755,root,root) /usr/bin/ssh-keyscan
+%attr(0755,root,root) /usr/bin/sftp
 %attr(0755,root,root) /usr/sbin/sshd
-%attr(0644,root,root) %doc /usr/man/man8/sshd.8
-%attr(0600,root,root) %config /etc/ssh/sshd_config
-%attr(0644,root,root) %config /etc/pam.d/sshd
-%attr(0755,root,root) %config /sbin/init.d/sshd
 %attr(-,root,root) /usr/sbin/rcsshd
+%attr(0755,root,root) %dir /usr/lib/ssh
+%attr(0755,root,root) /usr/lib/ssh/ssh-askpass
+%attr(0755,root,root) /usr/lib/ssh/gnome-ssh-askpass
+%attr(0644,root,root) %doc /usr/man/man1/scp.1*
+%attr(0644,root,root) %doc /usr/man/man1/ssh.1*
+%attr(-,root,root) %doc /usr/man/man1/slogin.1*
+%attr(0644,root,root) %doc /usr/man/man1/ssh-agent.1*
+%attr(0644,root,root) %doc /usr/man/man1/ssh-add.1*
+%attr(0644,root,root) %doc /usr/man/man1/ssh-keygen.1*
+%attr(0644,root,root) %doc /usr/man/man8/sshd.8*
 %attr(0644,root,root) /var/adm/fillup-templates/rc.config.sshd
 
-%files askpass
-%defattr(-,root,root)
-%attr(0755,root,root) /usr/libexec/ssh/ssh-askpass
-%attr(0755,root,root) /usr/libexec/ssh/gnome-ssh-askpass
-
This page took 0.067742 seconds and 4 git commands to generate.