]> andersk Git - openssh.git/blobdiff - contrib/redhat/openssh.spec
Use contrib/ Makefile for building askpass programs
[openssh.git] / contrib / redhat / openssh.spec
index 14be171f8c1a9de75bb4f736323cc1fdcc76cb25..bf9c97035b3c13c91f15d3c84e009a9db2fe13a1 100644 (file)
@@ -98,7 +98,7 @@ BuildPreReq: db1-devel, /usr/include/security/pam_appl.h
 BuildPreReq: XFree86-devel
 %endif
 %if ! %{no_gnome_askpass}
-BuildPreReq: gnome-libs-devel
+BuildPreReq: pkgconfig
 %endif
 %if %{kerberos5}
 BuildPreReq: krb5-devel
@@ -234,25 +234,15 @@ popd
 %if ! %{no_gnome_askpass}
 pushd contrib
 if [ $gtk2 = yes ] ; then
-       gcc $RPM_OPT_FLAGS `pkg-config --cflags gtk+-2.0` \
-           gnome-ssh-askpass2.c -o gnome-ssh-askpass \
-           `pkg-config --libs gtk+-2.0`
+       make gnome-ssh-askpass2
+       mv gnome-ssh-askpass2 gnome-ssh-askpass
 else
-       gcc $RPM_OPT_FLAGS `gnome-config --cflags gnome gnomeui` \
-           gnome-ssh-askpass1.c -o gnome-ssh-askpass \
-           `gnome-config --libs gnome gnomeui`
+       make gnome-ssh-askpass1
+       mv gnome-ssh-askpass1 gnome-ssh-askpass
 fi
 popd
 %endif
 
-%if ! %{no_gnome_askpass}
-pushd contrib
-gcc $RPM_OPT_FLAGS `gnome-config --cflags gnome gnomeui` \
-        gnome-ssh-askpass.c -o gnome-ssh-askpass \
-        `gnome-config --libs gnome gnomeui`
-popd
-%endif
-
 %install
 rm -rf $RPM_BUILD_ROOT
 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
@@ -406,6 +396,9 @@ fi
 %endif
 
 %changelog
+* Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
+- Use contrib/ Makefile for building askpass programs
+
 * Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
 - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
 - Add new {ssh,sshd}_config.5 manpages
This page took 0.061156 seconds and 4 git commands to generate.