]> andersk Git - nss_nonlocal.git/blobdiff - debian/rules
Only exclude glibc-private for new enough libc6.
[nss_nonlocal.git] / debian / rules
index b5c63d82aa4ccf3fbdde277039281d3b71e66377..d6a072e5e620b699999a91c6b7bda8fb6d99ffff 100755 (executable)
@@ -10,7 +10,11 @@ include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
 
 DEB_CONFIGURE_PREFIX = /
-DEB_DH_SHLIBDEPS_ARGS = -- -xglibc-private
+
+LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
+ifeq ($(shell dpkg --compare-versions '$(LIBC6_VERSION)' '>=' '2.8+20080809' && echo y),y)
+    DEB_DH_SHLIBDEPS_ARGS = -- -xglibc-private
+endif
 
 debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing
 
This page took 0.386627 seconds and 4 git commands to generate.