]> andersk Git - nss_nonlocal.git/blobdiff - debian/rules
Add multiarch support for distros from the future
[nss_nonlocal.git] / debian / rules
index 7868536a965c93b7637773014a8889a2491e2244..310099ca2cc347416bebbc5cb4710f3abf086a98 100755 (executable)
@@ -13,6 +13,13 @@ DEB_DESTDIR = $(CURDIR)/debian/tmp/
 DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
 DEB_CONFIGURE_PREFIX = /
 
+ifneq ($(DEB_HOST_MULTIARCH),)
+    export DH_COMPAT = 9
+    DEB_CONFIGURE_EXTRA_FLAGS += $(MULTIARCH_CONFIGURE_FLAGS)
+    MULTIARCH_CONFIGURE_FLAGS = --libdir='$${prefix}/lib/$(DEB_HOST_MULTIARCH)'
+    DEB_DH_GENCONTROL_ARGS_libnss-nonlocal += -- -DMulti-Arch=same
+endif
+
 IS_UBUNTU := $(if $(filter Ubuntu,$(shell lsb_release -is)),y)
 LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
 libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y)
@@ -29,6 +36,7 @@ REAL_DEB_HOST_GNU_TYPE := $(DEB_HOST_GNU_TYPE)
 
 DEB_BUILDDIR_lib32nss-nonlocal = debian/build_32
 cleanbuilddir/lib32nss-nonlocal:: clean/lib32nss-nonlocal
+configure/lib32nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS =
 configure/lib32nss-nonlocal:: cdbs_crossbuild =
 # i386_configure_target in eglibc/debian/sysdeps/amd64.mk
 ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.8+20080809)),y)
@@ -49,6 +57,7 @@ endif
 
 DEB_BUILDDIR_lib64nss-nonlocal = debian/build_64
 cleanbuilddir/lib64nss-nonlocal:: clean/lib64nss-nonlocal
+configure/lib64nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS =
 configure/lib64nss-nonlocal:: cdbs_crossbuild =
 # amd64_configure_target in eglibc/debian/sysdeps/i386.mk
 configure/lib64nss-nonlocal:: DEB_BUILD_GNU_TYPE = x86_64-linux
This page took 0.044787 seconds and 4 git commands to generate.