]> andersk Git - nss_nonlocal.git/blobdiff - debian/rules
Remove the workaround for buggy CDBS $(CC) splitting (fixed upstream).
[nss_nonlocal.git] / debian / rules
index d41058c757d07a0e076cb08c1e66bc14cc895c1b..982e1916007d8f68674677ce0d4894f5b354f8a9 100755 (executable)
@@ -6,10 +6,6 @@ DEB_AUTO_UPDATE_AUTOMAKE = 1.9
 DEB_AUTO_UPDATE_ACLOCAL = 1.9
 DEB_AUTO_UPDATE_LIBTOOL = pre
 
-# Fix http://bugs.debian.org/576967 : CDBS 0.4.77 in squeeze
-# incorrectly splits multiword $(CC) and $(CXX).
-override cdbs_set_nondefaultvars = $(foreach var,$1,$(if $(filter-out $(origin $(var)),default),$(var)='$($(var))'))
-
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
 
@@ -17,11 +13,11 @@ DEB_DESTDIR = $(CURDIR)/debian/tmp/
 DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
 DEB_CONFIGURE_PREFIX = /
 
-IS_UBUNTU := $(if $(filter Ubuntu, $(shell lsb_release -is)), y)
+IS_UBUNTU := $(if $(filter Ubuntu,$(shell lsb_release -is)),y)
 LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
 libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y)
 
-ifeq ($(call libc6_ge, 2.8+20080809), y)
+ifeq ($(call libc6_ge,2.8+20080809),y)
     DEB_DH_SHLIBDEPS_ARGS = -- -xglibc-private
 endif
 
@@ -39,7 +35,7 @@ DEB_BUILDDIR_lib32nss-nonlocal = debian/build_32
 cleanbuilddir/lib32nss-nonlocal:: clean/lib32nss-nonlocal
 configure/lib32nss-nonlocal:: cdbs_crossbuild =
 # i386_configure_target in eglibc/debian/sysdeps/amd64.mk
-ifeq ($(or $(IS_UBUNTU), $(call libc6_ge, 2.8+20080809)), y)
+ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.8+20080809)),y)
 configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i686-linux
 else
 configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i486-linux
@@ -47,10 +43,12 @@ endif
 # i386_CC in eglibc/debian/sysdeps/amd64.mk
 configure/lib32nss-nonlocal:: CC += -m32
 # i386_slibdir in eglibc/debian/sysdeps/amd64.mk
-ifeq ($(or $(IS_UBUNTU), $(call libc6_ge, 2.9-14~)), y)
+ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.9-14~)),y)
 configure/lib32nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib32"
+binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'lib32/*'
 else
 configure/lib32nss-nonlocal:: DEB_CONFIGURE_PREFIX = /emul/ia32-linux
+binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'emul/ia32-linux/lib/*'
 endif
 
 DEB_BUILDDIR_lib64nss-nonlocal = debian/build_64
This page took 0.034064 seconds and 4 git commands to generate.