]> andersk Git - nss_nonlocal.git/blobdiff - debian/rules
Add multiarch support for distros from the future
[nss_nonlocal.git] / debian / rules
index 982e1916007d8f68674677ce0d4894f5b354f8a9..310099ca2cc347416bebbc5cb4710f3abf086a98 100755 (executable)
@@ -1,9 +1,9 @@
 #!/usr/bin/make -f
 
-DEB_AUTO_UPDATE_AUTOCONF = 2.50
-DEB_AUTO_UPDATE_AUTOHEADER = 2.50
-DEB_AUTO_UPDATE_AUTOMAKE = 1.9
-DEB_AUTO_UPDATE_ACLOCAL = 1.9
+DEB_AUTO_UPDATE_AUTOCONF = 2.61
+DEB_AUTO_UPDATE_AUTOHEADER = 2.61
+DEB_AUTO_UPDATE_AUTOMAKE = 1.10
+DEB_AUTO_UPDATE_ACLOCAL = 1.10
 DEB_AUTO_UPDATE_LIBTOOL = pre
 
 include /usr/share/cdbs/1/rules/debhelper.mk
@@ -13,14 +13,17 @@ DEB_DESTDIR = $(CURDIR)/debian/tmp/
 DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
 DEB_CONFIGURE_PREFIX = /
 
+ifneq ($(DEB_HOST_MULTIARCH),)
+    export DH_COMPAT = 9
+    DEB_CONFIGURE_EXTRA_FLAGS += $(MULTIARCH_CONFIGURE_FLAGS)
+    MULTIARCH_CONFIGURE_FLAGS = --libdir='$${prefix}/lib/$(DEB_HOST_MULTIARCH)'
+    DEB_DH_GENCONTROL_ARGS_libnss-nonlocal += -- -DMulti-Arch=same
+endif
+
 IS_UBUNTU := $(if $(filter Ubuntu,$(shell lsb_release -is)),y)
 LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
 libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y)
 
-ifeq ($(call libc6_ge,2.8+20080809),y)
-    DEB_DH_SHLIBDEPS_ARGS = -- -xglibc-private
-endif
-
 debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing
 
 debian/stamp-autotools-files: aclocal.m4
@@ -33,6 +36,7 @@ REAL_DEB_HOST_GNU_TYPE := $(DEB_HOST_GNU_TYPE)
 
 DEB_BUILDDIR_lib32nss-nonlocal = debian/build_32
 cleanbuilddir/lib32nss-nonlocal:: clean/lib32nss-nonlocal
+configure/lib32nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS =
 configure/lib32nss-nonlocal:: cdbs_crossbuild =
 # i386_configure_target in eglibc/debian/sysdeps/amd64.mk
 ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.8+20080809)),y)
@@ -53,6 +57,7 @@ endif
 
 DEB_BUILDDIR_lib64nss-nonlocal = debian/build_64
 cleanbuilddir/lib64nss-nonlocal:: clean/lib64nss-nonlocal
+configure/lib64nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS =
 configure/lib64nss-nonlocal:: cdbs_crossbuild =
 # amd64_configure_target in eglibc/debian/sysdeps/i386.mk
 configure/lib64nss-nonlocal:: DEB_BUILD_GNU_TYPE = x86_64-linux
@@ -61,6 +66,9 @@ configure/lib64nss-nonlocal:: CC += -m64 -D__x86_64__
 # amd64_slibdir in eglibc/debian/sysdeps/i386.mk
 configure/lib64nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib64"
 
+# Fix for CDBS ≥ 0.4.59ubuntu4, < 0.4.83ubuntu1 (karmic and lucid).
+configure/lib32nss-nonlocal configure/lib64nss-nonlocal:: DEB_CONFIGURE_SCRIPT_ENV += CC="$(CC)"
+
 configure/lib32nss-nonlocal configure/lib64nss-nonlocal::
        $(DEB_CONFIGURE_INVOKE) $(cdbs_configure_flags) $(DEB_CONFIGURE_EXTRA_FLAGS) $(DEB_CONFIGURE_USER_FLAGS)
 
This page took 0.241626 seconds and 4 git commands to generate.