]> andersk Git - nss_nonlocal.git/blobdiff - debian/rules
Autotoolfiscate.
[nss_nonlocal.git] / debian / rules
index 76766f1fb3914cb82e95da3ece676f9cf238d103..c90fcf2aed27b8be414197504fc017650b16c0a5 100755 (executable)
@@ -1,6 +1,22 @@
 #!/usr/bin/make -f
 
+DEB_AUTO_UPDATE_AUTOCONF = 2.50
+DEB_AUTO_UPDATE_AUTOHEADER = 2.50
+DEB_AUTO_UPDATE_AUTOMAKE = 1.9
+DEB_AUTO_UPDATE_ACLOCAL = 1.9
+DEB_AUTO_UPDATE_LIBTOOL = pre
+
 include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/makefile.mk
+include /usr/share/cdbs/1/class/autotools.mk
+
+DEB_CONFIGURE_PREFIX = /
+
+debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing
+
+debian/stamp-autotools-files: aclocal.m4
+aclocal.m4:
+       touch $@
 
-DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DEB_DESTDIR)
+clean::
+       rm -f aclocal.m4 config.guess config.sub install-sh ltmain.sh \
+           configure config.h.in missing depcomp Makefile.in
This page took 0.027579 seconds and 4 git commands to generate.