]> andersk Git - nss_nonlocal.git/blob - debian/rules
Add multiarch support for distros from the future
[nss_nonlocal.git] / debian / rules
1 #!/usr/bin/make -f
2
3 DEB_AUTO_UPDATE_AUTOCONF = 2.61
4 DEB_AUTO_UPDATE_AUTOHEADER = 2.61
5 DEB_AUTO_UPDATE_AUTOMAKE = 1.10
6 DEB_AUTO_UPDATE_ACLOCAL = 1.10
7 DEB_AUTO_UPDATE_LIBTOOL = pre
8
9 include /usr/share/cdbs/1/rules/debhelper.mk
10 include /usr/share/cdbs/1/class/autotools.mk
11
12 DEB_DESTDIR = $(CURDIR)/debian/tmp/
13 DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
14 DEB_CONFIGURE_PREFIX = /
15
16 ifneq ($(DEB_HOST_MULTIARCH),)
17     export DH_COMPAT = 9
18     DEB_CONFIGURE_EXTRA_FLAGS += $(MULTIARCH_CONFIGURE_FLAGS)
19     MULTIARCH_CONFIGURE_FLAGS = --libdir='$${prefix}/lib/$(DEB_HOST_MULTIARCH)'
20     DEB_DH_GENCONTROL_ARGS_libnss-nonlocal += -- -DMulti-Arch=same
21 endif
22
23 IS_UBUNTU := $(if $(filter Ubuntu,$(shell lsb_release -is)),y)
24 LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
25 libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y)
26
27 debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing
28
29 debian/stamp-autotools-files: aclocal.m4
30 aclocal.m4:
31         touch $@
32
33 DEB_BUILDDIR = $(or $(DEB_BUILDDIR_$(cdbs_curpkg)),debian/build)
34
35 REAL_DEB_HOST_GNU_TYPE := $(DEB_HOST_GNU_TYPE)
36
37 DEB_BUILDDIR_lib32nss-nonlocal = debian/build_32
38 cleanbuilddir/lib32nss-nonlocal:: clean/lib32nss-nonlocal
39 configure/lib32nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS =
40 configure/lib32nss-nonlocal:: cdbs_crossbuild =
41 # i386_configure_target in eglibc/debian/sysdeps/amd64.mk
42 ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.8+20080809)),y)
43 configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i686-linux
44 else
45 configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i486-linux
46 endif
47 # i386_CC in eglibc/debian/sysdeps/amd64.mk
48 configure/lib32nss-nonlocal:: CC += -m32
49 # i386_slibdir in eglibc/debian/sysdeps/amd64.mk
50 ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.9-14~)),y)
51 configure/lib32nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib32"
52 binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'lib32/*'
53 else
54 configure/lib32nss-nonlocal:: DEB_CONFIGURE_PREFIX = /emul/ia32-linux
55 binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'emul/ia32-linux/lib/*'
56 endif
57
58 DEB_BUILDDIR_lib64nss-nonlocal = debian/build_64
59 cleanbuilddir/lib64nss-nonlocal:: clean/lib64nss-nonlocal
60 configure/lib64nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS =
61 configure/lib64nss-nonlocal:: cdbs_crossbuild =
62 # amd64_configure_target in eglibc/debian/sysdeps/i386.mk
63 configure/lib64nss-nonlocal:: DEB_BUILD_GNU_TYPE = x86_64-linux
64 # amd64_CC in eglibc/debian/sysdeps/i386.mk
65 configure/lib64nss-nonlocal:: CC += -m64 -D__x86_64__
66 # amd64_slibdir in eglibc/debian/sysdeps/i386.mk
67 configure/lib64nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib64"
68
69 # Fix for CDBS ≥ 0.4.59ubuntu4, < 0.4.83ubuntu1 (karmic and lucid).
70 configure/lib32nss-nonlocal configure/lib64nss-nonlocal:: DEB_CONFIGURE_SCRIPT_ENV += CC="$(CC)"
71
72 configure/lib32nss-nonlocal configure/lib64nss-nonlocal::
73         $(DEB_CONFIGURE_INVOKE) $(cdbs_configure_flags) $(DEB_CONFIGURE_EXTRA_FLAGS) $(DEB_CONFIGURE_USER_FLAGS)
74
75 build/lib32nss-nonlocal build/lib64nss-nonlocal::
76         +$(DEB_MAKE_INVOKE) $(DEB_MAKE_BUILD_TARGET)
77
78 install/lib32nss-nonlocal install/lib64nss-nonlocal::
79         +$(DEB_MAKE_INVOKE) $(DEB_MAKE_INSTALL_TARGET)
80
81 clean/lib32nss-nonlocal clean/lib64nss-nonlocal::
82         +-$(DEB_MAKE_INVOKE) -k $(DEB_MAKE_CLEAN_TARGET)
83
84 clean::
85         rm -f aclocal.m4 config.guess config.sub install-sh ltmain.sh \
86             configure config.h.in missing depcomp Makefile.in
This page took 0.145637 seconds and 5 git commands to generate.