]> andersk Git - gssapi-openssh.git/blob - openssh/contrib/redhat/openssh.spec
e7c3bb121a495a9ecc04062a7d73a90e661045cb
[gssapi-openssh.git] / openssh / contrib / redhat / openssh.spec
1 %define ver 3.6.1p2
2 %define rel 1
3
4 # OpenSSH privilege separation requires a user & group ID
5 %define sshd_uid    74
6 %define sshd_gid    74
7
8 # Version of ssh-askpass
9 %define aversion 1.2.4.1
10
11 # Do we want to disable building of x11-askpass? (1=yes 0=no)
12 %define no_x11_askpass 0
13
14 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
15 %define no_gnome_askpass 0
16
17 # Do we want to link against a static libcrypto? (1=yes 0=no)
18 %define static_libcrypto 0
19
20 # Do we want smartcard support (1=yes 0=no)
21 %define scard 0
22
23 # Use GTK2 instead of GNOME in gnome-ssh-askpass
24 %define gtk2 1
25
26 # Is this build for RHL 6.x?
27 %define build6x 0
28
29 # Disable IPv6 (avoids DNS hangs on some glibc versions)
30 %define noip6 0
31
32 # Do we want kerberos5 support (1=yes 0=no)
33 %define kerberos5 1
34
35 # Reserve options to override askpass settings with:
36 # rpm -ba|--rebuild --define 'skip_xxx 1'
37 %{?skip_x11_askpass:%define no_x11_askpass 1}
38 %{?skip_gnome_askpass:%define no_gnome_askpass 1}
39
40 # Is this a build for RHL 6.x or earlier?
41 %{?build_6x:%define build6x 1}
42
43 # If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
44 %if %{build6x}
45 %define _sysconfdir /etc
46 %define noip6 1
47 %endif
48
49 # Options for static OpenSSL link:
50 # rpm -ba|--rebuild --define "static_openssl 1"
51 %{?static_openssl:%define static_libcrypto 1}
52
53 # Options for Smartcard support: (needs libsectok and openssl-engine)
54 # rpm -ba|--rebuild --define "smartcard 1"
55 %{?smartcard:%define scard 1}
56
57 # Option to disable ipv6
58 # rpm -ba|--rebuild --define "noipv6 1"
59 %{?noipv6:%define noip6 1}
60
61 # Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
62 %define rescue 0
63 %{?build_rescue:%define rescue 1}
64
65 # Turn off some stuff for resuce builds
66 %if %{rescue}
67 %define kerberos5 0
68 %endif
69
70 Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
71 Name: openssh
72 Version: %{ver}
73 %if %{rescue}
74 Release: %{rel}rescue
75 %else
76 Release: %{rel}
77 %endif
78 URL: http://www.openssh.com/portable.html
79 Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
80 Source1: http://www.pobox.com/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
81 License: BSD
82 Group: Applications/Internet
83 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
84 Obsoletes: ssh
85 %if %{build6x}
86 PreReq: initscripts >= 5.00
87 %else
88 PreReq: initscripts >= 5.20
89 %endif
90 BuildPreReq: perl, openssl-devel, sharutils, tcp_wrappers
91 BuildPreReq: /bin/login
92 %if ! %{build6x}
93 BuildPreReq: glibc-devel, pam
94 %else
95 BuildPreReq: db1-devel, /usr/include/security/pam_appl.h
96 %endif
97 %if ! %{no_x11_askpass}
98 BuildPreReq: XFree86-devel
99 %endif
100 %if ! %{no_gnome_askpass}
101 BuildPreReq: pkgconfig
102 %endif
103 %if %{kerberos5}
104 BuildPreReq: krb5-devel
105 BuildPreReq: krb5-libs
106 %endif
107
108 %package clients
109 Summary: OpenSSH clients.
110 Requires: openssh = %{version}-%{release}
111 Group: Applications/Internet
112 Obsoletes: ssh-clients
113
114 %package server
115 Summary: The OpenSSH server daemon.
116 Group: System Environment/Daemons
117 Obsoletes: ssh-server
118 PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
119 %if ! %{build6x}
120 Requires: /etc/pam.d/system-auth
121 %endif
122
123 %package askpass
124 Summary: A passphrase dialog for OpenSSH and X.
125 Group: Applications/Internet
126 Requires: openssh = %{version}-%{release}
127 Obsoletes: ssh-extras
128
129 %package askpass-gnome
130 Summary: A passphrase dialog for OpenSSH, X, and GNOME.
131 Group: Applications/Internet
132 Requires: openssh = %{version}-%{release}
133 Obsoletes: ssh-extras
134
135 %description
136 SSH (Secure SHell) is a program for logging into and executing
137 commands on a remote machine. SSH is intended to replace rlogin and
138 rsh, and to provide secure encrypted communications between two
139 untrusted hosts over an insecure network. X11 connections and
140 arbitrary TCP/IP ports can also be forwarded over the secure channel.
141
142 OpenSSH is OpenBSD's version of the last free version of SSH, bringing
143 it up to date in terms of security and features, as well as removing
144 all patented algorithms to separate libraries.
145
146 This package includes the core files necessary for both the OpenSSH
147 client and server. To make this package useful, you should also
148 install openssh-clients, openssh-server, or both.
149
150 %description clients
151 OpenSSH is a free version of SSH (Secure SHell), a program for logging
152 into and executing commands on a remote machine. This package includes
153 the clients necessary to make encrypted connections to SSH servers.
154 You'll also need to install the openssh package on OpenSSH clients.
155
156 %description server
157 OpenSSH is a free version of SSH (Secure SHell), a program for logging
158 into and executing commands on a remote machine. This package contains
159 the secure shell daemon (sshd). The sshd daemon allows SSH clients to
160 securely connect to your SSH server. You also need to have the openssh
161 package installed.
162
163 %description askpass
164 OpenSSH is a free version of SSH (Secure SHell), a program for logging
165 into and executing commands on a remote machine. This package contains
166 an X11 passphrase dialog for OpenSSH.
167
168 %description askpass-gnome
169 OpenSSH is a free version of SSH (Secure SHell), a program for logging
170 into and executing commands on a remote machine. This package contains
171 an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
172 environment.
173
174 %prep
175
176 %if ! %{no_x11_askpass}
177 %setup -q -a 1
178 %else
179 %setup -q
180 %endif
181
182 %build
183 %if %{rescue}
184 CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
185 %endif
186
187 %configure \
188         --sysconfdir=%{_sysconfdir}/ssh \
189         --libexecdir=%{_libexecdir}/openssh \
190         --datadir=%{_datadir}/openssh \
191         --with-tcp-wrappers \
192         --with-rsh=%{_bindir}/rsh \
193         --with-default-path=/usr/local/bin:/bin:/usr/bin \
194         --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
195         --with-privsep-path=%{_var}/empty/sshd \
196 %if %{scard}
197         --with-smartcard \
198 %endif
199 %if %{noip6}
200         --with-ipv4-default \
201 %endif
202 %if %{rescue}
203         --without-pam --with-md5-passwords \
204 %else
205         --with-pam \
206 %endif
207 %if %{kerberos5}
208          --with-kerberos5=/usr/kerberos \
209 %endif
210
211
212 %if %{static_libcrypto}
213 perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
214 %endif
215
216 make
217
218 %if ! %{no_x11_askpass}
219 pushd x11-ssh-askpass-%{aversion}
220 %configure --libexecdir=%{_libexecdir}/openssh
221 xmkmf -a
222 make
223 popd
224 %endif
225
226 # Define a variable to toggle gnome1/gtk2 building.  This is necessary
227 # because RPM doesn't handle nested %if statements.
228 %if %{gtk2}
229         gtk2=yes
230 %else
231         gtk2=no
232 %endif
233
234 %if ! %{no_gnome_askpass}
235 pushd contrib
236 if [ $gtk2 = yes ] ; then
237         make gnome-ssh-askpass2
238         mv gnome-ssh-askpass2 gnome-ssh-askpass
239 else
240         make gnome-ssh-askpass1
241         mv gnome-ssh-askpass1 gnome-ssh-askpass
242 fi
243 popd
244 %endif
245
246 %install
247 rm -rf $RPM_BUILD_ROOT
248 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
249 mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
250 mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
251
252 make install DESTDIR=$RPM_BUILD_ROOT
253
254 install -d $RPM_BUILD_ROOT/etc/pam.d/
255 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
256 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
257 %if %{build6x}
258 install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
259 %else
260 install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
261 %endif
262 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
263
264 %if ! %{no_x11_askpass}
265 install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
266 ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
267 %endif
268
269 %if ! %{no_gnome_askpass}
270 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
271 %endif
272
273 %if ! %{scard}
274          rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
275 %endif
276
277 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
278 install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
279 install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
280
281 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
282
283 %clean
284 rm -rf $RPM_BUILD_ROOT
285
286 %triggerun server -- ssh-server
287 if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
288         touch /var/run/sshd.restart
289 fi
290
291 %triggerun server -- openssh-server < 2.5.0p1
292 # Count the number of HostKey and HostDsaKey statements we have.
293 gawk    'BEGIN {IGNORECASE=1}
294          /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
295          END {exit sawhostkey}' /etc/ssh/sshd_config
296 # And if we only found one, we know the client was relying on the old default
297 # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
298 # specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
299 # one nullifies the default, which would have loaded both.
300 if [ $? -eq 1 ] ; then
301         echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
302         echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
303 fi
304
305 %triggerpostun server -- ssh-server
306 if [ "$1" != 0 ] ; then
307         /sbin/chkconfig --add sshd
308         if test -f /var/run/sshd.restart ; then
309                 rm -f /var/run/sshd.restart
310                 /sbin/service sshd start > /dev/null 2>&1 || :
311         fi
312 fi
313
314 %pre server
315 %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
316 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
317         -g sshd -M -r sshd 2>/dev/null || :
318
319 %post server
320 /sbin/chkconfig --add sshd
321
322 %postun server
323 /sbin/service sshd condrestart > /dev/null 2>&1 || :
324
325 %preun server
326 if [ "$1" = 0 ]
327 then
328         /sbin/service sshd stop > /dev/null 2>&1 || :
329         /sbin/chkconfig --del sshd
330 fi
331
332 %files
333 %defattr(-,root,root)
334 %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
335 %attr(0755,root,root) %{_bindir}/scp
336 %attr(0644,root,root) %{_mandir}/man1/scp.1*
337 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
338 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
339 %if ! %{rescue}
340 %attr(0755,root,root) %{_bindir}/ssh-keygen
341 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
342 %attr(0755,root,root) %dir %{_libexecdir}/openssh
343 %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
344 %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
345 %endif
346 %if %{scard}
347 %attr(0755,root,root) %dir %{_datadir}/openssh
348 %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
349 %endif
350
351 %files clients
352 %defattr(-,root,root)
353 %attr(0755,root,root) %{_bindir}/ssh
354 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
355 %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
356 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
357 %attr(-,root,root) %{_bindir}/slogin
358 %attr(-,root,root) %{_mandir}/man1/slogin.1*
359 %if ! %{rescue}
360 %attr(2755,root,nobody) %{_bindir}/ssh-agent
361 %attr(0755,root,root) %{_bindir}/ssh-add
362 %attr(0755,root,root) %{_bindir}/ssh-keyscan
363 %attr(0755,root,root) %{_bindir}/sftp
364 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
365 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
366 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
367 %attr(0644,root,root) %{_mandir}/man1/sftp.1*
368 %endif
369
370 %if ! %{rescue}
371 %files server
372 %defattr(-,root,root)
373 %dir %attr(0111,root,root) %{_var}/empty/sshd
374 %attr(0755,root,root) %{_sbindir}/sshd
375 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
376 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
377 %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
378 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
379 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
380 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
381 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
382 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
383 %endif
384
385 %if ! %{no_x11_askpass}
386 %files askpass
387 %defattr(-,root,root)
388 %doc x11-ssh-askpass-%{aversion}/README
389 %doc x11-ssh-askpass-%{aversion}/ChangeLog
390 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
391 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
392 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
393 %endif
394
395 %if ! %{no_gnome_askpass}
396 %files askpass-gnome
397 %defattr(-,root,root)
398 %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
399 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
400 %endif
401
402 %changelog
403 * Wed Oct 01 2002 Damien Miller <djm@mindrot.org>
404 - Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
405
406 * Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
407 - Use contrib/ Makefile for building askpass programs
408
409 * Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
410 - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
411 - Add new {ssh,sshd}_config.5 manpages
412 - Add new ssh-keysign program and remove setuid from ssh client
413
414 * Fri May 10 2002 Damien Miller <djm@mindrot.org>
415 - Merge in spec changes from RedHat, reorgansie a little
416 - Add Privsep user, group and directory
417
418 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
419 - bump and grind (through the build system)
420
421 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
422 - require sharutils for building (mindrot #137)
423 - require db1-devel only when building for 6.x (#55105), which probably won't
424   work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
425 - require pam-devel by file (not by package name) again
426 - add Markus's patch to compile with OpenSSL 0.9.5a (from
427   http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
428   building for 6.x
429
430 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
431 - update to 3.1p1
432
433 * Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
434 - update to SNAP-20020305
435 - drop debug patch, fixed upstream
436
437 * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
438 - update to SNAP-20020220 for testing purposes (you've been warned, if there's
439   anything to be warned about, gss patches won't apply, I don't mind)
440
441 * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
442 - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
443   exchange, authentication, and named key support
444
445 * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
446 - remove dependency on db1-devel, which has just been swallowed up whole
447   by gnome-libs-devel
448
449 * Sun Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
450 - adjust build dependencies so that build6x actually works right (fix
451   from Hugo van der Kooij)
452
453 * Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
454 - update to 3.0.2p1
455
456 * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
457 - update to 3.0.1p1
458
459 * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
460 - update to current CVS (not for use in distribution)
461
462 * Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
463 - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
464   3.0p1 spec file and init script
465
466 * Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
467 - update to 3.0p1
468 - update to x11-ssh-askpass 1.2.4.1
469 - change build dependency on a file from pam-devel to the pam-devel package
470 - replace primes with moduli
471
472 * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
473 - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
474
475 * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
476 - Merge changes to rescue build from current sysadmin survival cd
477
478 * Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
479 - fix scp's server's reporting of file sizes, and build with the proper
480   preprocessor define to get large-file capable open(), stat(), etc.
481   (sftp has been doing this correctly all along) (#51827)
482 - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
483 - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
484 - mark profile.d scriptlets as config files (#42337)
485 - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
486 - change a couple of log() statements to debug() statements (#50751)
487 - pull cvs patch to add -t flag to sshd (#28611)
488 - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
489
490 * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
491 - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
492
493 * Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
494 - pull cvs patch to fix remote port forwarding with protocol 2
495
496 * Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
497 - pull cvs patch to add session initialization to no-pty sessions
498 - pull cvs patch to not cut off challengeresponse auth needlessly
499 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
500   it by default on a system that doesn't have X installed (#49263)
501
502 * Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
503 - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
504
505 * Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
506 - pass OPTIONS correctly to initlog (#50151)
507
508 * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
509 - switch to x11-ssh-askpass 1.2.2
510
511 * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
512 - rebuild in new environment
513
514 * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
515 - disable the gssapi patch
516
517 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
518 - update to 2.9p2
519 - refresh to a new version of the gssapi patch
520
521 * Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
522 - change Copyright: BSD to License: BSD
523 - add Markus Friedl's unverified patch for the cookie file deletion problem
524   so that we can verify it
525 - drop patch to check if xauth is present (was folded into cookie patch)
526 - don't apply gssapi patches for the errata candidate
527 - clear supplemental groups list at startup
528
529 * Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
530 - fix an error parsing the new default sshd_config
531 - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
532   dealing with comments right
533
534 * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
535 - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
536   to be removed before the next beta cycle because it's a big departure
537   from the upstream version
538
539 * Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
540 - finish marking strings in the init script for translation
541 - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
542   at startup (change merged from openssh.com init script, originally by
543   Pekka Savola)
544 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
545   it by default on a system that doesn't have X installed
546
547 * Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
548 - update to 2.9
549 - drop various patches that came from or went upstream or to or from CVS
550
551 * Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
552 - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
553
554 * Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
555 - remove explicit openssl requirement, fixes builddistro issue
556 - make initscript stop() function wait until sshd really dead to avoid 
557   races in condrestart
558
559 * Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
560 - mention that challengereponse supports PAM, so disabling password doesn't
561   limit users to pubkey and rsa auth (#34378)
562 - bypass the daemon() function in the init script and call initlog directly,
563   because daemon() won't start a daemon it detects is already running (like
564   open connections)
565 - require the version of openssl we had when we were built
566
567 * Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
568 - make do_pam_setcred() smart enough to know when to establish creds and
569   when to reinitialize them
570 - add in a couple of other fixes from Damien for inclusion in the errata
571
572 * Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
573 - update to 2.5.2p2
574 - call setcred() again after initgroups, because the "creds" could actually
575   be group memberships
576
577 * Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
578 - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
579 - don't enable challenge-response by default until we find a way to not
580   have too many userauth requests (we may make up to six pubkey and up to
581   three password attempts as it is)
582 - remove build dependency on rsh to match openssh.com's packages more closely
583
584 * Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
585 - remove dependency on openssl -- would need to be too precise
586
587 * Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
588 - rebuild in new environment
589
590 * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
591 - Revert the patch to move pam_open_session.
592 - Init script and spec file changes from Pekka Savola. (#28750)
593 - Patch sftp to recognize '-o protocol' arguments. (#29540)
594
595 * Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
596 - Chuck the closing patch.
597 - Add a trigger to add host keys for protocol 2 to the config file, now that
598   configuration file syntax requires us to specify it with HostKey if we
599   specify any other HostKey values, which we do.
600
601 * Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
602 - Redo patch to move pam_open_session after the server setuid()s to the user.
603 - Rework the nopam patch to use be picked up by autoconf.
604
605 * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
606 - Update for 2.5.1p1.
607 - Add init script mods from Pekka Savola.
608 - Tweak the init script to match the CVS contrib script more closely.
609 - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
610   adding id_rsa.
611
612 * Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
613 - Update for 2.5.0p1.
614 - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
615 - Resync with parts of Damien Miller's openssh.spec from CVS, including
616   update of x11 askpass to 1.2.0.
617 - Only require openssl (don't prereq) because we generate keys in the init
618   script now.
619
620 * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
621 - Don't open a PAM session until we've forked and become the user (#25690).
622 - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
623   host the user is attempting a login from.
624 - Resync with parts of Damien Miller's openssh.spec from CVS.
625 - Don't expose KbdInt responses in debug messages (from CVS).
626 - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
627
628 * Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
629 - i18n-tweak to initscript.
630
631 * Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
632 - More gettextizing.
633 - Close all files after going into daemon mode (needs more testing).
634 - Extract patch from CVS to handle auth banners (in the client).
635 - Extract patch from CVS to handle compat weirdness.
636
637 * Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
638 - Finish with the gettextizing.
639
640 * Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
641 - Fix a bug in auth2-pam.c (#23877)
642 - Gettextize the init script.
643
644 * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
645 - Incorporate a switch for using PAM configs for 6.x, just in case.
646
647 * Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
648 - Incorporate Bero's changes for a build specifically for rescue CDs.
649
650 * Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
651 - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
652   succeeded, to allow public-key authentication after a failure with "none"
653   authentication.  (#21268)
654
655 * Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
656 - Update to x11-askpass 1.1.1. (#21301)
657 - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
658
659 * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
660 - Merge multiple PAM text messages into subsequent prompts when possible when
661   doing keyboard-interactive authentication.
662
663 * Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
664 - Disable the built-in MD5 password support.  We're using PAM.
665 - Take a crack at doing keyboard-interactive authentication with PAM, and
666   enable use of it in the default client configuration so that the client
667   will try it when the server disallows password authentication.
668 - Build with debugging flags.  Build root policies strip all binaries anyway.
669
670 * Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
671 - Use DESTDIR instead of %%makeinstall.
672 - Remove /usr/X11R6/bin from the path-fixing patch.
673
674 * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
675 - Add the primes file from the latest snapshot to the main package (#20884).
676 - Add the dev package to the prereq list (#19984).
677 - Remove the default path and mimic login's behavior in the server itself.
678
679 * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
680 - Resync with conditional options in Damien Miller's .spec file for an errata.
681 - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
682
683 * Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
684 - Update to OpenSSH 2.3.0p1.
685 - Update to x11-askpass 1.1.0.
686 - Enable keyboard-interactive authentication.
687
688 * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
689 - Update to ssh-askpass-x11 1.0.3.
690 - Change authentication related messages to be private (#19966).
691
692 * Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
693 - Patch ssh-keygen to be able to list signatures for DSA public key files
694   it generates.
695
696 * Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
697 - Add BuildPreReq on /usr/include/security/pam_appl.h to be sure we always
698   build PAM authentication in.
699 - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
700 - Clean out no-longer-used patches.
701 - Patch ssh-add to try to add both identity and id_dsa, and to error only
702   when neither exists.
703
704 * Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
705 - Update x11-askpass to 1.0.2. (#17835)
706 - Add BuildPreReqs for /bin/login and /usr/bin/rsh so that configure will
707   always find them in the right place. (#17909)
708 - Set the default path to be the same as the one supplied by /bin/login, but
709   add /usr/X11R6/bin. (#17909)
710 - Try to handle obsoletion of ssh-server more cleanly.  Package names
711   are different, but init script name isn't. (#17865)
712
713 * Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
714 - Update to 2.2.0p1. (#17835)
715 - Tweak the init script to allow proper restarting. (#18023)
716
717 * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
718 - Update to 20000823 snapshot.
719 - Change subpackage requirements from %%{version} to %%{version}-%%{release}
720 - Back out the pipe patch.
721
722 * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
723 - Update to 2.1.1p4, which includes fixes for config file parsing problems.
724 - Move the init script back.
725 - Add Damien's quick fix for wackiness.
726
727 * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
728 - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
729
730 * Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
731 - Move condrestart to server postun.
732 - Move key generation to init script.
733 - Actually use the right patch for moving the key generation to the init script.
734 - Clean up the init script a bit.
735
736 * Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
737 - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
738
739 * Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
740 - Update to 2.1.1p2.
741 - Use of strtok() considered harmful.
742
743 * Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
744 - Get the build root out of the man pages.
745
746 * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
747 - Add and use condrestart support in the init script.
748 - Add newer initscripts as a prereq.
749
750 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
751 - Build in new environment (release 2)
752 - Move -clients subpackage to Applications/Internet group
753
754 * Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
755 - Update to 2.2.1p1
756
757 * Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
758 - Patch to build with neither RSA nor RSAref.
759 - Miscellaneous FHS-compliance tweaks.
760 - Fix for possibly-compressed man pages.
761
762 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
763 - Updated for new location
764 - Updated for new gnome-ssh-askpass build
765
766 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
767 - Added Jim Knoble's <jmknoble@pobox.com> askpass
768
769 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
770 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
771
772 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
773 - Added 'Obsoletes' directives
774
775 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
776 - Use make install
777 - Subpackages
778
779 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
780 - Added links for slogin
781 - Fixed perms on manpages
782
783 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
784 - Renamed init script
785
786 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
787 - Back to old binary names
788
789 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
790 - Use autoconf
791 - New binary names
792
793 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
794 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
This page took 0.088255 seconds and 3 git commands to generate.